Bug 981052 - [abrt] WARNING: at lib/list_debug.c:33 __list_add+0xac/0xc0()
[abrt] WARNING: at lib/list_debug.c:33 __list_add+0xac/0xc0()
Status: CLOSED DUPLICATE of bug 980254
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:669c13fcd1c0a1bbb4d7db1a567...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 17:29 EDT by Shahnavaz
Modified: 2013-07-09 00:23 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-05 08:52:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (186.79 KB, text/plain)
2013-07-03 17:29 EDT, Shahnavaz
no flags Details

  None (edit)
Description Shahnavaz 2013-07-03 17:29:39 EDT
Description of problem:
Ran the command "sudo yum reinstall kernel*fc19*"

Additional info:
reporter:       libreport-2.1.5
WARNING: at lib/list_debug.c:33 __list_add+0xac/0xc0()
Hardware name: 1066AWU
list_add corruption. prev->next should be next (ffff8802342e94f8), but was           (null). (prev=ffff880209ea2b80).
Modules linked in: ebtable_nat xt_CHECKSUM ppdev parport_pc parport fuse bnep bluetooth bridge stp llc nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_nat nf_nat_ipv6 ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables vsock vfat fat mperf coretemp kvm_intel kvm uvcvideo videobuf2_vmalloc videobuf2_memops i2400m_usb videobuf2_core i2400m videodev wimax media acer_wmi iTCO_wdt iTCO_vendor_support microcode arc4 iwldvm mac80211 snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device joydev i2c_i801 snd_pcm iwlwifi lpc_ich mfd_core cfg80211 snd_page_alloc snd_timer snd mei soundcore ideapad_laptop sparse_keymap rfkill binfmt_misc uinput crc32_pclmul crc32c_intel i915 ghash_clmulni_intel i2c_algo_bit drm_kms_helper r8169 drm mii i2c_core wmi video sunrpc
Pid: 0, comm: swapper/3 Not tainted 3.9.8-300.fc19.x86_64 #1
Call Trace:
 <IRQ>  [<ffffffff81306d00>] ? btree_merge+0x100/0x100
 [<ffffffff8105cc56>] warn_slowpath_common+0x66/0x80
 [<ffffffff8105ccbc>] warn_slowpath_fmt+0x4c/0x50
 [<ffffffff81306dac>] __list_add+0xac/0xc0
 [<ffffffff8106bed3>] __internal_add_timer+0x113/0x130
 [<ffffffff8106c527>] internal_add_timer+0x17/0x40
 [<ffffffff8106d812>] mod_timer+0x102/0x210
 [<ffffffffa05cf21b>] br_multicast_rcv+0x86b/0x1220 [bridge]
 [<ffffffffa05c55ba>] br_handle_frame_finish+0x24a/0x330 [bridge]
 [<ffffffffa05cc34c>] br_nf_pre_routing_finish+0x18c/0x370 [bridge]
 [<ffffffffa05cc908>] br_nf_pre_routing+0x3d8/0x640 [bridge]
 [<ffffffff815684cb>] nf_iterate+0x8b/0xa0
 [<ffffffffa05c5370>] ? br_handle_local_finish+0x60/0x60 [bridge]
 [<ffffffff81568554>] nf_hook_slow+0x74/0x130
 [<ffffffffa05c5370>] ? br_handle_local_finish+0x60/0x60 [bridge]
 [<ffffffffa05c5870>] br_handle_frame+0x1d0/0x270 [bridge]
 [<ffffffff8153aef2>] __netif_receive_skb_core+0x242/0x7f0
 [<ffffffff8101a300>] ? native_read_tsc+0x20/0x20
 [<ffffffff8153b4b8>] __netif_receive_skb+0x18/0x60
 [<ffffffff8153b533>] netif_receive_skb+0x33/0xb0
 [<ffffffff8153bf10>] napi_gro_receive+0x80/0xb0
 [<ffffffffa00c3c8e>] rtl8169_poll+0x15e/0x658 [r8169]
 [<ffffffff8153b8a9>] net_rx_action+0x149/0x240
 [<ffffffff81065657>] __do_softirq+0xf7/0x240
 [<ffffffff814f0960>] ? intel_pstate_timer_func+0x2c0/0x2c0
 [<ffffffff81065925>] irq_exit+0xa5/0xb0
 [<ffffffff81650c16>] do_IRQ+0x56/0xc0
 [<ffffffff81646e6d>] common_interrupt+0x6d/0x6d
 <EOI>  [<ffffffff814f12e1>] ? cpuidle_wrap_enter+0x41/0x80
 [<ffffffff814f1330>] cpuidle_enter_tk+0x10/0x20
 [<ffffffff814f1092>] cpuidle_idle_call+0xb2/0x1e0
 [<ffffffff8101c035>] cpu_idle+0xe5/0x140
 [<ffffffff81635c09>] start_secondary+0x249/0x24b

Potential duplicate: bug 920922
Comment 1 Shahnavaz 2013-07-03 17:29:45 EDT
Created attachment 768494 [details]
File: dmesg
Comment 2 nikolay 2013-07-04 10:21:01 EDT
Description of problem:
System randomly freezes, perhaps may be useful:2 times freeze happened while locking screen(Ctrl+L)

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.1.5
cmdline:        BOOT_IMAGE=/boot/vmlinuz-3.9.8-300.fc19.x86_64 root=UUID=b56cab25-3788-4ce1-adc8-26287e4ad855 ro LANG=ru_RU.UTF-8 rd.md=0 rd.lvm=0 rd.dm=0 SYSFONT=False rd.luks=0 KEYTABLE=ru rhgb quiet
kernel:         3.9.8-300.fc19.x86_64
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: at lib/list_debug.c:33 __list_add+0xac/0xc0()
Hardware name: System Product Name
list_add corruption. prev->next should be next (ffff8802122755f8), but was           (null). (prev=ffff8801d7d31880).
Modules linked in: bnep bluetooth fuse ebtable_nat nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_nat nf_nat_ipv6 ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables bridge stp llc snd_hda_codec_hdmi snd_hda_codec_via snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm iTCO_wdt acpi_cpufreq mperf coretemp iTCO_vendor_support kvm_intel kvm ppdev eeepc_wmi asus_wmi sparse_keymap rfkill crc32_pclmul crc32c_intel snd_page_alloc ghash_clmulni_intel snd_timer lpc_ich snd i2c_i801 r8169 soundcore microcode serio_raw parport_pc mei parport mii mfd_core uinput nouveau mxm_wmi i2c_algo_bit drm_kms_helper ttm drm i2c_core wmi video
Pid: 0, comm: swapper/3 Not tainted 3.9.8-300.fc19.x86_64 #1
Call Trace:
 <IRQ>  [<ffffffff81306d00>] ? btree_merge+0x100/0x100
 [<ffffffff8105cc56>] warn_slowpath_common+0x66/0x80
 [<ffffffff8105ccbc>] warn_slowpath_fmt+0x4c/0x50
 [<ffffffff81306dac>] __list_add+0xac/0xc0
 [<ffffffff8106bed3>] __internal_add_timer+0x113/0x130
 [<ffffffff8106c527>] internal_add_timer+0x17/0x40
 [<ffffffff8106d812>] mod_timer+0x102/0x210
 [<ffffffffa034621b>] br_multicast_rcv+0x86b/0x1220 [bridge]
 [<ffffffffa033c370>] ? br_handle_local_finish+0x60/0x60 [bridge]
 [<ffffffffa033c5ba>] br_handle_frame_finish+0x24a/0x330 [bridge]
 [<ffffffffa033c825>] br_handle_frame+0x185/0x270 [bridge]
 [<ffffffff8153aef2>] __netif_receive_skb_core+0x242/0x7f0
 [<ffffffff8101a300>] ? native_read_tsc+0x20/0x20
 [<ffffffff8153b4b8>] __netif_receive_skb+0x18/0x60
 [<ffffffff8153b533>] netif_receive_skb+0x33/0xb0
 [<ffffffff8153bf10>] napi_gro_receive+0x80/0xb0
 [<ffffffffa0208c8e>] rtl8169_poll+0x15e/0x658 [r8169]
 [<ffffffff8153b8a9>] net_rx_action+0x149/0x240
 [<ffffffff81065657>] __do_softirq+0xf7/0x240
 [<ffffffff814f0960>] ? intel_pstate_timer_func+0x2c0/0x2c0
 [<ffffffff81065925>] irq_exit+0xa5/0xb0
 [<ffffffff81650c16>] do_IRQ+0x56/0xc0
 [<ffffffff81646e6d>] common_interrupt+0x6d/0x6d
 <EOI>  [<ffffffff814f12e4>] ? cpuidle_wrap_enter+0x44/0x80
 [<ffffffff814f1330>] cpuidle_enter_tk+0x10/0x20
 [<ffffffff814f1092>] cpuidle_idle_call+0xb2/0x1e0
 [<ffffffff8101c035>] cpu_idle+0xe5/0x140
 [<ffffffff81635c09>] start_secondary+0x249/0x24b
Comment 3 Yogesh Sharma 2013-07-04 13:49:19 EDT
Description of problem:
I guess it crashed when I tried to access kvm guest hosted website

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.1.5
cmdline:        BOOT_IMAGE=/vmlinuz-3.9.8-300.fc19.x86_64 root=/dev/mapper/fedora_vmhost-root ro rd.md=0 rd.dm=0 vconsole.keymap=us rd.lvm.lv=fedora_vmhost/swap rd.luks=0 vconsole.font=latarcyrheb-sun16 rd.lvm.lv=fedora_vmhost/root rhgb quiet LANG=en_US.UTF-8
kernel:         3.9.8-300.fc19.x86_64
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: at lib/list_debug.c:33 __list_add+0xac/0xc0()
Hardware name: MS-7501
list_add corruption. prev->next should be next (ffff8802144d96b8), but was ffffffffffffffff. (prev=ffff8801f9417640).
Modules linked in: fuse vhost_net macvtap macvlan tun bridge stp llc arc4 raid1 edac_core mperf kvm_amd kvm ath9k ath9k_common ath9k_hw ath mac80211 edac_mce_amd k10temp snd_hda_codec_realtek sp5100_tco snd_hda_intel i2c_piix4 cfg80211 rfkill snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm shpchp r8169 e1000 mii microcode snd_page_alloc snd_timer snd soundcore ata_generic pata_acpi radeon usb_storage pata_atiixp i2c_algo_bit drm_kms_helper ttm drm i2c_core [last unloaded: iptable_mangle]
Pid: 31119, comm: kworker/3:1 Not tainted 3.9.8-300.fc19.x86_64 #1
Call Trace:
 [<ffffffff81306d00>] ? btree_merge+0x100/0x100
 [<ffffffff8105cc56>] warn_slowpath_common+0x66/0x80
 [<ffffffff8105ccbc>] warn_slowpath_fmt+0x4c/0x50
 [<ffffffff8140a5b6>] ? scsi_init_sgtable+0x46/0x70
 [<ffffffff81306dac>] __list_add+0xac/0xc0
 [<ffffffff8106bed3>] __internal_add_timer+0x113/0x130
 [<ffffffff8106c527>] internal_add_timer+0x17/0x40
 [<ffffffff8106d812>] mod_timer+0x102/0x210
 [<ffffffff812d5ef0>] blk_add_timer+0xb0/0xc0
 [<ffffffff812d075f>] blk_start_request+0x2f/0x40
 [<ffffffff8140b8e3>] scsi_request_fn+0x123/0x520
 [<ffffffff81176479>] ? alloc_pages_current+0xa9/0x170
 [<ffffffff812ce333>] __blk_run_queue+0x33/0x40
 [<ffffffff812d48a5>] blk_execute_rq_nowait+0x75/0xf0
 [<ffffffff812d49a0>] blk_execute_rq+0x80/0xf0
 [<ffffffff812d0b58>] ? blk_rq_bio_prep+0x68/0xc0
 [<ffffffff812d4749>] ? blk_rq_map_kern+0xb9/0x160
 [<ffffffff812d0310>] ? blk_get_request+0x60/0xd0
 [<ffffffff814099e9>] scsi_execute+0xd9/0x160
 [<ffffffff8140aca6>] scsi_execute_req+0x96/0x100
 [<ffffffff8141a7e3>] sr_check_events+0xb3/0x2d0
 [<ffffffff81444928>] cdrom_check_events+0x18/0x30
 [<ffffffff8141ac79>] sr_block_check_events+0x39/0x50
 [<ffffffff812d8d9c>] disk_check_events+0x4c/0x150
 [<ffffffff812d8eb6>] disk_events_workfn+0x16/0x20
 [<ffffffff8107997e>] process_one_work+0x16e/0x3f0
 [<ffffffff8107b3ff>] worker_thread+0x10f/0x3d0
 [<ffffffff8107b2f0>] ? manage_workers+0x340/0x340
 [<ffffffff810802a0>] kthread+0xc0/0xd0
 [<ffffffff810801e0>] ? insert_kthread_work+0x40/0x40
 [<ffffffff8164ef2c>] ret_from_fork+0x7c/0xb0
 [<ffffffff810801e0>] ? insert_kthread_work+0x40/0x40
Comment 4 Alexander Dyadyun 2013-07-05 07:35:06 EDT
Description of problem:
hardware: Core 2 Quad 6600/P43chipset/8GB RAM/HD4550(r600 driver)

software: F19/KDE/qemu-kvm/virt-manager

I have not 100% bug reproducer, only some suggestions...

The last 2 crashes of my home server were in moment, when my virtual machines actively used network and hdd (for example, virtual WSUS-server on Win2k8R2 began DB sync).

All guests connected through network bridge to hostmachine`s network card. Both IPv4 and IPv6 protocols are used. No NetworkManager, classical "network" only.

All guests are running on the same ext4-partition (hdd with good S.M.A.R.T. and without bad blocks). All windows-guests uses virtio-disks and virtio-ethernet drivers (virtio-win-0.1-49.iso). All Scientific Linux 6.3 guests uses native virtio-drivers for disks and network.

Crashes began at last month on F18 with latest kernels. I installed from scratch F19, but problem is still here. Average crash rate - 1 crash at 1-2 days.

P.S. May be it is hardware problems with my ancient PC, but all hardware tests (hdd|memory|temperature) was finished without errors.

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.1.5
cmdline:        BOOT_IMAGE=/vmlinuz-3.9.8-300.fc19.x86_64 root=/dev/mapper/SysVolGroup-VolRoot ro rd.md=0 rd.dm=0 rd.lvm.lv=SysVolGroup/VolSwap rd.lvm.lv=SysVolGroup/VolRoot rd.luks=0 vconsole.keymap=us vconsole.font=latarcyrheb-sun16
kernel:         3.9.8-300.fc19.x86_64
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: at lib/list_debug.c:33 __list_add+0xac/0xc0()
Hardware name: EP43-UD3L
list_add corruption. prev->next should be next (ffffffff81ed98c8), but was           (null). (prev=ffff8801fb27c1c0).
Modules linked in: vhost_net macvtap macvlan tun bnep bluetooth rfkill ebtable_nat nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_nat nf_nat_ipv6 ip6table_mangle bridge stp llc ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables acpi_cpufreq mperf coretemp kvm_intel kvm snd_hda_codec_hdmi snd_hda_codec_realtek snd_emu10k1 snd_hda_intel snd_util_mem snd_rawmidi snd_hda_codec snd_ac97_codec snd_hwdep ac97_bus snd_seq snd_seq_device snd_pcm iTCO_wdt iTCO_vendor_support bttv snd_page_alloc btcx_risc tveeprom videobuf_dma_sg videobuf_core rc_core v4l2_common videodev lpc_ich cypress_m8 media raid456 async_raid6_recov async_memcpy async_pq snd_timer raid6_pq async_xor xor async_tx i2c_i801 mfd_core r8169 mii emu10k1_gp gameport microcode snd soundcore uinput radeon i2c_algo_bit drm_kms_helper firewire_ohci firewire_core ttm crc_itu_t drm i2c_core
Pid: 2273, comm: Socket Thread Not tainted 3.9.8-300.fc19.x86_64 #1
Call Trace:
 [<ffffffff81306d00>] ? btree_merge+0x100/0x100
 [<ffffffff8105cc56>] warn_slowpath_common+0x66/0x80
 [<ffffffff8105ccbc>] warn_slowpath_fmt+0x4c/0x50
 [<ffffffff81306dac>] __list_add+0xac/0xc0
 [<ffffffff8106bed3>] __internal_add_timer+0x113/0x130
 [<ffffffff8106c527>] internal_add_timer+0x17/0x40
 [<ffffffff8106d812>] mod_timer+0x102/0x210
 [<ffffffff8106d938>] add_timer+0x18/0x20
 [<ffffffffa045ce0b>] __nf_conntrack_confirm+0x2cb/0x460 [nf_conntrack]
 [<ffffffffa0394278>] ipv4_confirm+0xc8/0x110 [nf_conntrack_ipv4]
 [<ffffffff815684cb>] nf_iterate+0x8b/0xa0
 [<ffffffff815754b0>] ? ip_fragment+0x880/0x880
 [<ffffffff81568554>] nf_hook_slow+0x74/0x130
 [<ffffffff815754b0>] ? ip_fragment+0x880/0x880
 [<ffffffff81576bb2>] ip_output+0x82/0x90
 [<ffffffff815762f5>] ip_local_out+0x25/0x30
 [<ffffffff8157664a>] ip_queue_xmit+0x14a/0x3f0
 [<ffffffff8158ef8d>] tcp_transmit_skb+0x44d/0x970
 [<ffffffff815919f6>] tcp_connect+0x4e6/0x5c0
 [<ffffffff810af07e>] ? getnstimeofday+0xe/0x30
 [<ffffffff810af106>] ? ktime_get_real+0x16/0x50
 [<ffffffff815950b1>] tcp_v4_connect+0x321/0x480
 [<ffffffff815a8765>] __inet_stream_connect+0xa5/0x320
 [<ffffffff8157c4fe>] ? inet_csk_init_xmit_timers+0x6e/0xa0
 [<ffffffff815a8a18>] inet_stream_connect+0x38/0x50
 [<ffffffff81524e17>] sys_connect+0xe7/0x120
 [<ffffffff810dcb36>] ? __audit_syscall_exit+0x1f6/0x2a0
 [<ffffffff8164efd9>] system_call_fastpath+0x16/0x1b
Comment 5 Josh Boyer 2013-07-05 08:52:42 EDT

*** This bug has been marked as a duplicate of bug 980254 ***

Note You need to log in before you can comment on or make changes to this bug.