Bug 981056 - F19 rebuild broke sofia-sip
F19 rebuild broke sofia-sip
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: sofia-sip (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 17:58 EDT by Olivier Crête
Modified: 2015-06-29 21:31 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-06-29 21:31:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix (1.83 KB, patch)
2013-09-20 12:14 EDT, Radist Morse
no flags Details | Diff

  None (edit)
Description Olivier Crête 2013-07-03 17:58:13 EDT
When trying to initial a call, the F19 version sends the body before the header when sending an invite.. So it's probably a compiler problem, or the compiler changed some undefined behavior, either way, sofia-sip doesn't work !
Comment 1 Olivier Crête 2013-07-03 18:29:35 EDT
Good nows, this is a compiler bug! Just rebuilding from the srpm fixed it, can you please bump & rebuild ?
Comment 2 Olivier Crête 2013-08-12 16:03:13 EDT
strange.. the koji rebuild didn't fix this..
Comment 3 Olivier Crête 2013-08-16 15:50:18 EDT
Actually, rebuilding with CFLAGS="-O0 -g" does fix it it seem, so it is a compiler bug...!
Comment 4 Radist Morse 2013-09-20 12:14:04 EDT
Created attachment 800563 [details]
fix

There is a hacky loop through the members of the struct, which won't work if the compiler inserts a padding between them.
Comment 5 Ilya Melnikov 2013-10-29 23:49:08 EDT
Compiling with "CFLAGS=-fno-aggressive-loop-optimizations" fix issue too. The reason is gcc 4.8:
http://gcc.gnu.org/gcc-4.8/changes.html
Comment 6 Jean-François Fortin Tam 2013-11-14 13:59:26 EST
AFAICS, this still occurs in Fedora 20. With the information provided by Ilya in comment 5, does the patch in comment 4 still make sense?

How responsive is upstream expected to be on this? Would be great if the fix could be applied to the Fedora packages if not.
Comment 7 Radist Morse 2013-11-14 15:23:13 EST
My patch and Ilya's option are not mutually exclusive. The loop used in the original code can still possibly break, with or without "-fno-aggressive-loop-optimizations", because, as I mentioned, the C standard doesn't guarantee there will be no paddings between the struct's fields (C 2011 (N1570) 6.7.2.1 15, “There may be unnamed padding within a structure object, but not at its beginning.”).

The flag fixes it for gcc 4.8, that's all.
Comment 8 Olivier Crête 2013-11-14 16:04:34 EST
Submitted it upstream, but don't hold your breath, sofia-sip came from Nokia Research.
Comment 9 Simon McVittie 2013-12-05 15:19:23 EST
Upstream bug with references to various other downstream reports: https://sourceforge.net/p/sofia-sip/bugs/121/
Comment 10 Fedora Update System 2013-12-05 18:59:36 EST
sofia-sip-1.12.11-8.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/sofia-sip-1.12.11-8.fc20
Comment 11 Fedora Update System 2013-12-05 19:11:06 EST
sofia-sip-1.12.11-8.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/sofia-sip-1.12.11-8.fc19
Comment 12 Fedora Update System 2013-12-07 01:55:34 EST
Package sofia-sip-1.12.11-8.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sofia-sip-1.12.11-8.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22879/sofia-sip-1.12.11-8.fc19
then log in and leave karma (feedback).
Comment 13 Jean-François Fortin Tam 2013-12-07 10:41:50 EST
Hmmm, unfortunately with the -8 version from updates-testing, on both Fedora 19 and Fedora 20, the symptoms persist. I'm unable to call my echo test or a landline, the call never "connects".
Comment 14 Ilya Melnikov 2013-12-07 11:00:48 EST
In build sofia-sip-1.12.11-8.fc19 was added only supplied patch?
Did flag "-fno-aggressive-loop-optimizations" was added to this build?
Comment 15 Guillaume Desmottes 2014-01-29 09:06:32 EST
sofia-sip-1.12.11-7.fc20.x86_64 is still broken.

I manually build sofia-sip master from git and the bug seems solved.
Comment 16 Radist Morse 2014-01-29 09:45:51 EST
It's because sofia-sip-1.12.11-7.fc20 is not the fixed build. I just installed telepathy-rakia-0.8.0-1.fc20 and sofia-sip-1.12.11-8.fc20 from updates-testing and it worked without problems.
Comment 17 Jean-François Fortin Tam 2014-01-29 10:08:32 EST
Radist: odd, as 1.12.11-8.fc20 did not work for me (re-tested just now). The call doesn't connect/initiate.
Comment 18 Radist Morse 2014-01-29 10:41:56 EST
Odd indeed. I just called my desk and my mobile using youmagic.ru as a SIP provider. Both were ok. I reinstalled the system recently, so it shouldn't have any custom packages.

Try rebuilding 1.12.11-8 with CFLAGS="-O0 -g" to see if there is some other optimization issue. When I was digging the sources there were several places with the warnings, maybe the patches should be introduced for all of them.

Also can you check that the error is indeed the same: empty content of all SIP messages (as described here: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=729301 ).
Comment 19 Fedora End Of Life 2015-05-29 05:09:14 EDT
This message is a reminder that Fedora 20 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 20. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '20'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 20 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 20 Fedora End Of Life 2015-06-29 21:31:52 EDT
Fedora 20 changed to end-of-life (EOL) status on 2015-06-23. Fedora 20 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.