Bug 981066 - Cheese will not respond after taking photograph
Cheese will not respond after taking photograph
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: cheese (Show other bugs)
rawhide
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: David King
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 18:43 EDT by Randall "Randy" Berry
Modified: 2014-10-08 15:01 EDT (History)
4 users (show)

See Also:
Fixed In Version: cheese-3.10.2-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-08 15:01:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randall "Randy" Berry 2013-07-03 18:43:02 EDT
Description of problem:
Application locks up after taking photo. Live video is still displayed but the application will not respond. 

Version-Release number of selected component (if applicable):

cheese-3.8.2-4.fc19.i686

How reproducible:
Every time

Steps to Reproduce:
1.take a photo

Actual results:
application locks up and will no longer respond.

Expected results:
Application should continue to work.

Additional info:
Logitech, Inc. Webcam C270
Worked fine in previous versions of cheese (f18)
Comment 1 Hans de Goede 2013-07-04 11:07:37 EDT
Hi,

Under which desktop enviroment are you running cheese?

And what do you mean with no longer responds? When you take a picture most of the controls get greyed out, but they should get re-enabled after the countdown.

If you're running under gnome-3, can you also take a look at the application menu by clicking on the cheese
text in the gnome top panel. Does that have all the options sensitive, or are some greyed out ?

If some options are greyed out and some are not, do the non greyed out (ie about, quit) still work?

Thanks,

Hans
Comment 2 Randall "Randy" Berry 2013-07-04 12:49:33 EDT
 I'm using Xfce 4.10

 By not responding I mean after the photo is taken none of the buttons in the application work, the photo scroll at the bottom also fails to respond. The buttons are not greyed out, they just don't work. Including buttons on the window itself. I have to close the application from the task bar buttons (left click; close). Meanwhile it still saves the photograph taken. This is also the case with the option to take multiple photos as well. After the photos have been taken the application stops responding.

 Video however works fine. You can start and stop video just fine.

 It's as if the window itself locks up because after taking a photo you can't even move, resize or minimize the window. It's always on top as well. I'll try this in Gnome 3 and report back to see if it's a Xfce issue. Although I doubt it, I was using Xfce  4.10 in F18 as well and cheese worked perfectly.
Comment 3 Randall "Randy" Berry 2013-07-04 12:57:25 EDT
OK, this appears to be a problem in Xfce4, I just tried it in Gnome 3 and it works as expected. I'm not sure where to go from here.
Comment 4 Randall "Randy" Berry 2014-01-09 03:48:17 EST
Still an issue with F20, assuming Rawhide also has the issue as well.
Comment 5 David King 2014-09-12 05:38:42 EDT
This is probably related to an upstream Cheese bug with changing the opacity of the flash window (which explains why a different compositor would trigger the bug):

https://bugzilla.gnome.org/show_bug.cgi?id=733433

I have backported the fix to the version of Cheese in Fedora 20 and made a scratch build including the change:

http://koji.fedoraproject.org/koji/taskinfo?taskID=7571262

Please test the build and see if it fixes the problem.
Comment 6 Randall "Randy" Berry 2014-09-29 12:55:43 EDT
Thanks David, it works like a champ now. No hanging.
Comment 7 Fedora Update System 2014-09-29 13:59:48 EDT
cheese-3.10.2-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/cheese-3.10.2-2.fc20
Comment 8 Fedora Update System 2014-10-01 00:15:22 EDT
Package cheese-3.10.2-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing cheese-3.10.2-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-11857/cheese-3.10.2-2.fc20
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2014-10-08 15:01:15 EDT
cheese-3.10.2-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.