Bug 981089 - Non-existent environment group after installing KDE using yum groupinstall and removing it
Non-existent environment group after installing KDE using yum groupinstall an...
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
19
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 22:13 EDT by Michel Alexandre Salim
Modified: 2015-02-17 10:50 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 10:50:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2013-07-03 22:13:06 EDT
Description: 
I installed KDE 4.10 right after Fedora 19 came out, using:

  yum groupinstall "KDE Plasma Workspaces"

(per comps-f19.xml.in, the group ID is kde-desktop)

After installation is done, curiously yum grouplist shows that KDE Plasma Workspaces is available, not installed.

After removing KDE using "yum remove kde\*", Every 'yum update' operation results in a warning being shown:


Warning: Environment Group kde-desktop-environment does not exist.
No packages marked for update

Note that the group is different from the group in comps-f19, but this environment id is valid and is in comps-f19.xml

Comps group:  kde-desktop / kde-desktop-environment

This could be a yum bug, so for completeness:
yum-3.4.3-99.fc19.noarch
Comment 1 Michel Alexandre Salim 2013-07-03 22:29:34 EDT
Note: removing using yum groupremove instead of manually using yum remove results in this:

# yum groupremove "KDE Plasma Workspaces"
No environment named KDE Plasma Workspaces exists
No group named KDE Plasma Workspaces exists
No packages to remove from groups

# yum groupremove kde-desktop
=> this succeeds in removing the warning, but then when I issue yum update, it tries to install some KDE packages, so something KDE-related must still be left behind:

Installing:
 akonadi                           x86_64 1.9.2-1.fc19            fedora  715 k
 akonadi-mysql                     x86_64 1.9.2-1.fc19            fedora   15 k
 apper                             x86_64 0.8.1-0.3.20130511.fc19 fedora  987 k
 appmenu-qt                        x86_64 0.2.6-3.fc19            fedora   33 k
 ark                               x86_64 4.10.4-1.fc19           fedora  276 k
 bluedevil                         x86_64 1.3-3.fc19              updates 438 k
 cagibi                            x86_64 0.2.0-5.fc19            fedora   55 k
 gwenview                          x86_64 4.10.4-1.fc19           fedora  1.9 M
 initial-setup                     noarch 0.3.6-2.fc19            fedora   31 k
 k3b-extras-freeworld              x86_64 1:2.0.2-11.fc19         rpmfusion-free
                                                                           64 k
 kamera                            x86_64 4.10.4-1.fc19           fedora   62 k
 kamoso                            x86_64 2.0.2-10.fc19           fedora  233 k
 kcalc                             x86_64 4.10.4-1.fc19           fedora  172 k
 kcharselect                       x86_64 4.10.4-1.fc19           fedora   92 k
 kcm-gtk                           x86_64 0.5.3-12.fc19           fedora   53 k
 kcm_touchpad                      x86_64 0.3.1-9.fc19            fedora   47 k
 kcolorchooser                     x86_64 4.10.4-1.fc19           fedora   15 k
 kde-baseapps                      x86_64 4.10.4-1.fc19           fedora  3.4 M
 kde-plasma-networkmanagement      x86_64 1:0.9.0.9-1.fc19        updates 533 k
 kde-plasma-networkmanagement-openconnect
                                   x86_64 1:0.9.0.9-1.fc19        updates  50 k
 kde-plasma-networkmanagement-openvpn
                                   x86_64 1:0.9.0.9-1.fc19        updates  65 k
 kde-plasma-networkmanagement-pptp x86_64 1:0.9.0.9-1.fc19        updates  38 k
 kde-plasma-networkmanagement-vpnc x86_64 1:0.9.0.9-1.fc19        updates  52 k
 kde-print-manager                 x86_64 4.10.4-1.fc19           fedora  268 k
 kde-runtime                       x86_64 4.10.4-2.fc19           updates 7.2 M
 kde-settings-pulseaudio           noarch 19-23.fc19              fedora   14 k
 kde-workspace                     x86_64 4.10.4-5.fc19           updates  13 M
 kdeaccessibility                  noarch 1:4.10.4-1.fc19         fedora   14 k
 kdegames-minimal                  noarch 6:4.10.4-1.fc19         fedora  7.0 k
 kdegraphics-strigi-analyzer       x86_64 4.10.4-1.fc19           fedora   27 k
 kdegraphics-thumbnailers          x86_64 4.10.4-1.fc19           fedora   50 k
 kdelibs                           x86_64 6:4.10.4-1.fc19         fedora   11 M
 kdenetwork-kdnssd                 x86_64 7:4.10.4-1.fc19         fedora   38 k
 kdenetwork-kget                   x86_64 7:4.10.4-1.fc19         fedora  1.4 M
 kdepim                            x86_64 7:4.10.4-1.fc19         fedora   10 M
 kdeplasma-addons                  x86_64 4.10.4-2.fc19           fedora  2.8 M
 kdm                               x86_64 4.10.4-5.fc19           updates 651 k
 kgpg                              x86_64 4.10.4-1.fc19           fedora  957 k
 kipi-plugins                      x86_64 3.2.0-3.fc19            fedora  7.8 M
 kmix                              x86_64 4.10.4-1.fc19           fedora  568 k
 konsole                           x86_64 4.10.4-1.fc19           fedora   77 k
 kruler                            x86_64 4.10.4-1.fc19           fedora  133 k
 kscreen                           x86_64 1:1.0-1.fc19            updates 154 k
 ksnapshot                         x86_64 4.10.4-1.fc19           fedora  308 k
 ksshaskpass                       x86_64 0.5.3-5.fc19            fedora   20 k
 ksysguard                         x86_64 4.10.4-5.fc19           updates 286 k
 kwallet                           x86_64 4.10.4-1.fc19           fedora  350 k
 kwebkitpart                       x86_64 1.3.2-2.fc19            fedora  299 k
 kwrite                            x86_64 4.10.4-1.fc19           fedora   77 k
 okular                            x86_64 4.10.4-1.fc19           fedora  414 k
 oxygen-gtk                        noarch 1.2.0-4.fc19            fedora  4.7 k
 phonon-backend-gstreamer          x86_64 2:4.6.3-1.fc19          fedora  138 k
 plasma-scriptengine-python        x86_64 4.10.4-5.fc19           updates  82 k
 system-config-services            noarch 0.101.10-1.fc19         fedora  209 k
 xine-lib-extras-freeworld         x86_64 1.1.21-6.fc19           rpmfusion-free
                                                                          278 k
 xsettings-kde                     x86_64 0.12.3-5.fc19           fedora   26 k
 xterm                             x86_64 293-1.fc19              fedora  453 k
Installing for dependencies:
 ark-libs                          x86_64 4.10.4-1.fc19           fedora  134 k
 gwenview-libs                     x86_64 4.10.4-1.fc19           fedora  341 k
 jovie                             x86_64 4.10.4-1.fc19           fedora  407 k
 jovie-libs                        x86_64 4.10.4-1.fc19           fedora   31 k
 k3b                               x86_64 1:2.0.2-16.fc19         fedora  1.3 M
 k3b-common                        noarch 1:2.0.2-16.fc19         fedora  6.7 M
 k3b-libs                          x86_64 1:2.0.2-16.fc19         fedora  1.2 M
 kaccessible                       x86_64 4.10.4-1.fc19           fedora   39 k
 kaccessible-libs                  x86_64 4.10.4-1.fc19           fedora   20 k
 kactivities                       x86_64 4.10.4-1.fc19           fedora  308 k
 kate-part                         x86_64 4.10.4-1.fc19           fedora  1.6 M
 kcm_colors                        x86_64 4.10.4-5.fc19           updates 141 k
 kde-baseapps-libs                 x86_64 4.10.4-1.fc19           fedora  412 k
 kde-plasma-networkmanagement-libs x86_64 1:0.9.0.9-1.fc19        updates 1.0 M
 kde-runtime-drkonqi               x86_64 4.10.4-2.fc19           updates 196 k
 kde-runtime-flags                 noarch 4.10.4-2.fc19           updates 141 k
 kde-runtime-libs                  x86_64 4.10.4-2.fc19           updates 1.2 M
 kde-settings                      noarch 19-23.fc19              fedora   44 k
 kde-settings-kdm                  noarch 19-23.fc19              fedora   30 k
 kde-settings-ksplash              noarch 19-23.fc19              fedora   15 k
 kde-settings-plasma               noarch 19-23.fc19              fedora   15 k
 kde-workspace-libs                x86_64 4.10.4-5.fc19           updates 1.0 M
 kdelibs-common                    x86_64 6:4.10.4-1.fc19         fedora  1.9 M
 kdenetwork-common                 noarch 7:4.10.4-1.fc19         fedora  9.6 k
 kdenetwork-kget-libs              x86_64 7:4.10.4-1.fc19         fedora  276 k
 kdepim-libs                       x86_64 7:4.10.4-1.fc19         fedora  5.8 M
 kdepim-runtime                    x86_64 1:4.10.4-1.fc19.2       fedora  3.0 M
 kdepim-runtime-libs               x86_64 1:4.10.4-1.fc19.2       fedora  148 k
 kdepimlibs                        x86_64 4.10.4-2.fc19           fedora  2.3 M
 kdepimlibs-akonadi                x86_64 4.10.4-2.fc19           fedora  1.5 M
 kdepimlibs-kxmlrpcclient          x86_64 4.10.4-2.fc19           fedora   38 k
 kdeplasma-addons-libs             x86_64 4.10.4-2.fc19           fedora  403 k
 kgreeter-plugins                  x86_64 4.10.4-5.fc19           updates  91 k
 kio_msits                         x86_64 7:4.10.4-1.fc19         fedora   19 k
 kio_sysinfo                       x86_64 20090930-6.fc19         fedora  361 k
 kipi-plugins-libs                 x86_64 3.2.0-3.fc19            fedora  118 k
 kmag                              x86_64 4.10.4-1.fc19           fedora  121 k
 kmahjongg                         x86_64 4.10.4-1.fc19           fedora  1.1 M
 kmines                            x86_64 4.10.4-1.fc19           fedora  645 k
 kmousetool                        x86_64 4.10.4-1.fc19           fedora   68 k
 kmouth                            x86_64 4.10.4-1.fc19           fedora  410 k
 konsole-part                      x86_64 4.10.4-1.fc19           fedora  387 k
 kpat                              x86_64 4.10.4-1.fc19           fedora  2.9 M
 ksysguard-libs                    x86_64 4.10.4-5.fc19           updates 239 k
 ksysguardd                        x86_64 4.10.4-5.fc19           updates 110 k
 libkcddb                          x86_64 4.10.4-1.fc19           fedora  258 k
 libkdcraw                         x86_64 4.10.4-1.fc19           fedora  473 k
 libkdegames                       x86_64 4.10.4-1.fc19           fedora  6.7 M
 libkexiv2                         x86_64 4.10.4-1.fc19           fedora  253 k
 libkgapi                          x86_64 2.0.1-1.fc19            fedora  341 k
 libkgeomap                        x86_64 3.2.0-3.fc19            fedora  184 k
 libkipi                           x86_64 4.10.4-1.fc19           fedora   98 k
 libkmahjongg                      x86_64 4.10.4-1.fc19           fedora  1.8 M
 libkolab                          x86_64 0.4.1-3.fc19            fedora  290 k
 libksane                          x86_64 4.10.4-1.fc19           fedora  103 k
 libkscreen                        x86_64 1:1.0-1.fc19            updates  72 k
 libktorrent                       x86_64 1.3.1-2.fc19            fedora  640 k
 libkvkontakte                     x86_64 3.2.0-3.fc19            fedora  106 k
 libkworkspace                     x86_64 4.10.4-5.fc19           updates 107 k
 libmediawiki                      x86_64 3.2.0-3.fc19            fedora   78 k
 marble                            x86_64 1:4.10.4-1.fc19         fedora   15 M
 marble-libs                       x86_64 1:4.10.4-1.fc19         fedora  2.0 M
 nepomuk-core                      x86_64 4.10.4-1.fc19           fedora  506 k
 nepomuk-core-libs                 x86_64 4.10.4-1.fc19           fedora  281 k
 nepomuk-widgets                   x86_64 4.10.4-1.fc19           fedora  119 k
 okular-libs                       x86_64 4.10.4-1.fc19           fedora  225 k
 okular-part                       x86_64 4.10.4-1.fc19           fedora  907 k
 polkit-kde                        x86_64 0.99.1-1.20130311git.fc19
                                                                  fedora   70 k
 pykde4                            x86_64 4.10.4-1.fc19           fedora  4.1 M

Transaction Summary
================================================================================
Install  57 Packages (+69 Dependent packages)

Total download size: 141 M
Installed size: 423 M
Comment 2 Michel Alexandre Salim 2013-07-03 23:15:19 EDT
yum history list from the time of the groupinstall:
ID     | Command line             | Date and time    | Action(s)      | Altered
-------------------------------------------------------------------------------
   150 | history rollback force 1 | 2013-07-04 10:06 | E, I           |   28   
   149 | history undo 139         | 2013-07-04 09:41 | Erase          |  114 EE
   148 | remove kde-filesystem    | 2013-07-04 09:34 | Erase          |    8   
   147 | remove initial-setup sys | 2013-07-04 09:22 | Erase          |    3   
   146 | install system-config-se | 2013-07-04 09:18 | Install        |    2   
   145 | groupremove kde-desktop  | 2013-07-04 09:15 | Erase          |   11   
   144 | install wesnoth          | 2013-07-03 21:08 | Install        |    6   
   143 | update                   | 2013-07-03 20:27 | Update         |    5 P<
   142 | remove kde-settings-kdm  | 2013-07-03 20:19 | Erase          |    1 >#
   141 | remove kde-settings-kdm  | 2013-07-03 20:10 | Erase          |    1 ##
   140 | shell                    | 2013-07-03 20:05 | E, R           |  117 ##
   139 | groupinstall KDE Plasma  | 2013-07-03 19:40 | Install        |  242   

- per this, I tried transaction #149 -- undoing the KDE installation:
  https://ask.fedoraproject.org/question/7931/yum-group-remove/

- per skvidal's suggestion I tried using rollback instead.
- rolling back #139 actually results in yum trying to install those remaining KDE packages.
- rolling back #138 instead seems to work (it brings back packages like VLC that got removed when I was sorting out the mess, but nothing more), but a subsequent yum update again attempts to pull in KDE
Comment 3 Bill Nottingham 2013-07-09 12:17:27 EDT
The kde-desktop and kde-desktop-environment groups have the same name attribute.
Don't do that.

How we want to fix this for F-19 is debatable, since it's been released. In the meantime, refer to them by id, not by name?
Comment 4 lnxslck 2013-09-25 11:54:46 EDT
I have the same problem but in a different way.

I installed Fedora 19 and then KDE through yum. After that i upgraded to Fedora 20 i still have KDE but yum keeps printing that same Warning: Environment Group kde-desktop-environment does not exist.

How can i remove this warning?
Comment 5 Fedora End Of Life 2015-01-09 13:39:22 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 6 Fedora End Of Life 2015-02-17 10:50:06 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.