Bug 981107 - nwfilter-edit should give error when modify the value to inadmissibility
nwfilter-edit should give error when modify the value to inadmissibility
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt (Show other bugs)
7.0
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Pavel Hrdina
Virtualization Bugs
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-03 23:26 EDT by EricLee
Modified: 2016-04-26 09:28 EDT (History)
7 users (show)

See Also:
Fixed In Version: libvirt-1.2.8-16.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 981106
Environment:
Last Closed: 2015-11-19 00:43:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description EricLee 2013-07-03 23:26:43 EDT
+++ This bug was initially created as a clone of Bug #981106 +++

Description
nwfilter-edit should give error when modify the value to inadmissibility, not return successfully as delete the line which including inadmissible value.

Version:
libvirt-0.10.2-18.el6_4.9.x86_64

How reproducible:
100%

Steps to Reproduce:
1. # vim disallow-arp.xml
<filter name='disallow-arp' chain='arp'>
  <rule action='drop' direction='inout' priority='500'/>
</filter>

2. # virsh nwfilter-define disallow-arp.xml
Network filter disallow-arp defined from disallow-arp.xml

3. # virsh nwfilter-dumpxml disallow-arp
<filter name='disallow-arp' chain='arp' priority='-500'>
  <uuid>2f737f78-779c-4b2c-b223-b67b90765afb</uuid>
  <rule action='drop' direction='inout' priority='500'/>
</filter>

4. Use nwfilter-edit "rule action='drop'" to “rule action='dropaaa'” and save:
# virsh nwfilter-edit disallow-arp
Network filter disallow-arp XML configuration edited.

5. the rule line will disappear:
# virsh nwfilter-dumpxml disallow-arp
<filter name='disallow-arp' chain='arp' priority='-500'>
  <uuid>e088d644-6e76-4827-a7ea-ba1ea924dd1c</uuid>
</filter>

6. Also for nwfilter-define works like that.

Actual results:
As description.

Expected results:
nwfilter-edit should give error when modify the value to inadmissibility, not return successfully as delete the line which including inadmissible value.
It should judge 'rule action' only support 'drop',' reject','accept','return','continue' and "direction" only support 'in','out' and 'inout' and give error info but just delete the rule if there are not those value.

Additional info:
For nwfilter-define, if there is some inadmissible value like "dropaaa" in xml, define will succeed, but there is no <rule> element in that nwfilter. Also need to fix.
Comment 8 Shanzhi Yu 2015-07-21 04:59:58 EDT
Verify this bug with libvirt-1.2.17-2.el7.x86_64
When try to modify rule action with an invalid value, libvirt will post below error: 

# virsh nwfilter-edit disallow-arp
error: unsupported configuration: unknown rule action attribute value
Failed. Try again? [y,n,f,?]:
Comment 10 errata-xmlrpc 2015-11-19 00:43:24 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2202.html

Note You need to log in before you can comment on or make changes to this bug.