Bug 981120 - rpm/yum fails after f19 install
Summary: rpm/yum fails after f19 install
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 19
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Brian Lane
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-04 05:22 UTC by birger
Modified: 2014-02-01 01:07 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-01 01:07:43 UTC
Type: Bug


Attachments (Terms of Use)
anaconda log (57.14 KB, text/plain)
2013-08-01 08:36 UTC, birger
no flags Details
anaconda.ifcfg.log (1.95 KB, text/plain)
2013-08-01 08:37 UTC, birger
no flags Details
anaconda.packaging.log (201 bytes, text/x-log)
2013-08-01 08:38 UTC, birger
no flags Details
anaconda.program.log (207.37 KB, text/x-log)
2013-08-01 08:39 UTC, birger
no flags Details
anaconda.storage.log (357.65 KB, text/x-log)
2013-08-01 08:40 UTC, birger
no flags Details

Description birger 2013-07-04 05:22:31 UTC
Description of problem:
# yum update
CRITICAL:yum.main:

Error: rpmdb failed release provides. Try: rpm --rebuilddb
# rpm -qa
#


Version-Release number of selected component (if applicable):
Since rpm doesn't list any packages at all I cannot find the exact versions of the rpm packages.
rpm --version says "RPM version 4.11.0.1"
yum --version says "3.4.3"

How reproducible:
I have installed twice on this laptop with the exact same result.

Steps to Reproduce:
1. Boot Gnome live media from USB
2. Manually remove all old linux partitions using parted
3. During install I use default install language, select Norwegian keyboard, set my own NTP servers and manual partition scheme. The system has 2 existing NTFS partitions (corporate win 7 installation), and I install with only a 500MB /boot and a ca 25GB btrfs /. No swap. I set up one admin user in the installer.
4. After install/boot log in with the admin user and run yum update.

Actual results:
Error message as listed above

Expected results:
updated system

Additional info:
rpmdb --rebuilddb does nothing. the rpm database is still empty.

Comment 1 Panu Matilainen 2013-07-04 06:33:03 UTC
An entirely missing/empty rpmdb sounds like a bug in the livecd install procedure more than an rpm bug. Reassigning to anaconda which I suppose handles the install in this case too.

Comment 2 birger 2013-07-06 21:01:56 UTC
I have now retried with plain ext4 partitions instead of btrfs.
I still get the same failure.

I have also installed the 32 bit lxde spin on two older systems without any problems, but they didn't have any NTFS partitions.

Comment 3 Steve Tyler 2013-07-16 03:15:28 UTC
(In reply to birger from comment #0)
> ... No swap. ...

How much memory?

Could you attach the installer logs?
Since it sounds like your system can be booted, the installer logs should be /var/log/anaconda/.

Comment 4 birger 2013-08-01 08:20:50 UTC
I have 8GB RAM. I have also tried installing with 8GB swap with no difference.

I just tried adding the attachments, but nothing happens. I'll save these changes, reload and try again.

Comment 5 birger 2013-08-01 08:36:42 UTC
Created attachment 781474 [details]
anaconda log

Comment 6 birger 2013-08-01 08:37:34 UTC
Created attachment 781475 [details]
anaconda.ifcfg.log

Comment 7 birger 2013-08-01 08:38:10 UTC
Created attachment 781476 [details]
anaconda.packaging.log

Comment 8 birger 2013-08-01 08:39:11 UTC
Created attachment 781477 [details]
anaconda.program.log

Comment 9 birger 2013-08-01 08:40:51 UTC
Created attachment 781478 [details]
anaconda.storage.log

Comment 10 birger 2013-08-01 08:43:37 UTC
there are also 3 log files called ks-script-XXXXXX.log, but these are all 0 byte.

Comment 11 Steve Tyler 2013-08-01 09:07:06 UTC
Thanks for attaching the log files. That is very helpful.

For a Live install, rsync is used to copy files from the install media to the install target. There are numerous errors from rsync.

Does your Live image on the USB stick pass the media test?
It's under the Troubleshooting menu:
Test this media & start Fedora Live

Snippet from attached anaconda.program.log:
...
15:47:36,567 INFO program: Running... rsync -pogAXtlHrDx --exclude /dev/ --exclude /proc/ --exclude /sys/ --exclude /run/ /mnt/install/source/ /mnt/sysimage
15:50:12,482 INFO program: rsync: rsync_xal_set: lremovexattr(""/mnt/sysimage/tmp/hsperfdata_root/.12257.zpEJEz"","security.selinux") failed: Permission denied (13)
15:50:12,484 INFO program: rsync: read errors mapping "/mnt/install/source/usr/lib/python2.7/site-packages/firewall/__init__.pyo": Input/output error (5)
...
15:50:12,694 INFO program: ERROR: usr/share/locale/zh_TW/LC_MESSAGES/setroubleshoot.mo failed verification -- update discarded.
15:50:12,694 INFO program: rsync: read errors mapping "/mnt/install/source/var/lib/rpm/Packages": Input/output error (5)
15:50:12,694 INFO program: rsync: read errors mapping "/mnt/install/source/var/lib/rpm/Packages": Input/output error (5)
15:50:12,694 INFO program: ERROR: var/lib/rpm/Packages failed verification -- update discarded.
15:50:12,695 INFO program: rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1052) [sender=3.0.9]
15:50:12,695 DEBUG program: Return code: 23
...

Comment 12 Steve Tyler 2013-08-01 09:18:22 UTC
According to the rsync man page, return code 23 means:
       23     Partial transfer due to error

I guess we already know that much, anyway ... :-)

Snippet from attached anaconda.program.log:
...
15:50:12,695 INFO program: rsync error: some files/attrs were not transferred (see previous errors) (code 23) at main.c(1052) [sender=3.0.9]
15:50:12,695 DEBUG program: Return code: 23
...

Comment 13 Steve Tyler 2013-08-01 10:25:41 UTC
(In reply to birger from comment #2)
> I have now retried with plain ext4 partitions instead of btrfs.
> I still get the same failure.
...

The log files show btrfs being created on sda6. After trying ext4, did you reinstall with btrfs?

Also, mkfs.btrfs thinks sda is an SSD.

The attached anaconda.storage.log shows:
  model: ATA SanDisk SD5SG212  path: /dev/sda  type: 1

I googled for SanDisk SD5SG212 and searched the SanDisk web site, but couldn't find anything about it. Could you confirm that it is an SSD?

Snippet from attached anaconda.program.log:
...
15:47:29,248 INFO program: Running... mkfs.btrfs --data=single --label=fedora_sch-lf-00047 /dev/sda6
15:47:35,547 INFO program: 
15:47:35,548 INFO program: WARNING! - Btrfs v0.20-rc1 IS EXPERIMENTAL
15:47:35,548 INFO program: WARNING! - see http://btrfs.wiki.kernel.org before using
15:47:35,548 INFO program: 
15:47:35,549 INFO program: Detected a SSD, turning off metadata duplication.  Mkfs with -m dup if you want to force metadata duplication.
15:47:35,549 INFO program: fs created label fedora_sch-lf-00047 on /dev/sda6
15:47:35,549 INFO program: 	nodesize 4096 leafsize 4096 sectorsize 4096 size 16.29GB
15:47:35,549 INFO program: Btrfs v0.20-rc1
15:47:35,549 DEBUG program: Return code: 0
...

Comment 14 Steve Tyler 2013-08-01 10:48:47 UTC
(In reply to birger from comment #2)
> I have now retried with plain ext4 partitions instead of btrfs.
> I still get the same failure.
> 
> I have also installed the 32 bit lxde spin on two older systems without any
> problems, but they didn't have any NTFS partitions.

If you were using the same install media, that suggests that it is not a problem.

Do you have any SanDisk disk diagnostics you can run?

Fedora has the smartmontools package, which can read SMART data from a device:
$ man smartctl
$ sudo smartctl --health /dev/sda
$ sudo smartctl --all /dev/sda
$ sudo repoquery smartmontools
smartmontools-1:6.1-1.fc19.x86_64

Comment 15 Brian Lane 2013-08-08 00:30:34 UTC
The problem here is that something is wrong with your source media. I'd guess that if you looked at your syslog you'd see a pile of read errors.

On the other hand, I need to figure out a better way to get error info from rsync. Some errors are soft, others like these should be hard. I think I already have an error for this, but will leave this open until I track it down.

Comment 16 Steve Tyler 2013-08-10 06:28:25 UTC
These are closed, but they have rsync in the bug summary:

$ bugzilla query -c anaconda -s rsync | sed 's/^#/Bug /'
Bug 162292 CLOSED     - Anaconda Maintenance Team - RFE: rsync on the rescue system
Bug 868755 CLOSED     - Brian C. Lane - rsync error handling - UEFI and live installs without enough space
Bug 871637 CLOSED     - Brian C. Lane - SELinux is preventing /usr/bin/rsync from 'associate' accesses on the filesystem /sys.
Bug 872926 CLOSED     - Anaconda Maintenance Team - PayloadInstallError: rsync exited with code 12
Bug 875329 CLOSED     - Brian C. Lane - [rsync] "No space left on device" not reported to user
Bug 960501 CLOSED     - Anaconda Maintenance Team - PayloadInstallError: rsync exited with code 12

Comment 17 Steve Tyler 2013-08-10 07:58:56 UTC
(In reply to Brian C. Lane from comment #15)
...
> On the other hand, I need to figure out a better way to get error info from
> rsync. ...

Why is rsync required?
Don't all install destinations appear as local storage?
Couldn't "cp -a *" be used instead?

cp - copy files and directories
http://man7.org/linux/man-pages/man1/cp.1.html

Comment 18 Steve Tyler 2013-08-10 08:56:14 UTC
According to Bug 873467, Comment 1, the rsync excludes were supposed to prevent this error:

15:47:36,567 INFO program: Running... rsync -pogAXtlHrDx --exclude /dev/ --exclude /proc/ --exclude /sys/ --exclude /run/ /mnt/install/source/ /mnt/sysimage
15:50:12,482 INFO program: rsync: rsync_xal_set: lremovexattr(""/mnt/sysimage/tmp/hsperfdata_root/.12257.zpEJEz"","security.selinux") failed: Permission denied (13)

Is rsync trying to copy files to /mnt/sysimage/tmp/?

Comment 19 Brian Lane 2014-02-01 01:07:43 UTC
sadly rsync is too vague about some of its errors for us to be able to recognize all the problems that could arise.


Note You need to log in before you can comment on or make changes to this bug.