This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 981135 - After updating from Fedora 18 to Fedora 19, emacs does not work and some Fedora 18 emacs packages are not updated
After updating from Fedora 18 to Fedora 19, emacs does not work and some Fedo...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Hracek
Fedora Extras Quality Assurance
:
: 979860 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-04 02:05 EDT by Mike FABIAN
Modified: 2013-07-18 01:57 EDT (History)
9 users (show)

See Also:
Fixed In Version: emacs-24.2-20.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 01:57:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
/var/log/fedup.log (1.94 MB, text/plain)
2013-07-04 02:08 EDT, Mike FABIAN
no flags Details

  None (edit)
Description Mike FABIAN 2013-07-04 02:05:42 EDT
I updated from Fedora 18 to Fedora 19 using fedup.

Emacs does not start anymore after doing that:

$ /usr/bin/emacs
/usr/bin/emacs: error while loading shared libraries: libgnutls.so.26: cannot open shared object file: No such file or directory
mfabian@ari:~
$ 

Several emacs related packages have not been updated, their fc18 versions
are still there:

mfabian@ari:~
$ rpm -qa | grep emacs| grep fc18
emacs-w3m-1.4.435-0.3.20110225cvs.fc18.noarch
emacs-el-24.2-19.fc18.noarch
emacs-ecb-el-2.40.1-0.6.cvs20101021.fc18.noarch
emacs-w3m-el-1.4.435-0.3.20110225cvs.fc18.noarch
emacs-common-w3m-1.4.435-0.3.20110225cvs.fc18.noarch
emacs-nox-24.2-19.fc18.x86_64
emacs-common-24.2-19.fc18.x86_64
emacs-filesystem-24.2-19.fc18.noarch
emacs-ecb-2.40.1-0.6.cvs20101021.fc18.noarch
emacs-24.2-19.fc18.x86_64
mfabian@ari:~
$
Comment 1 Mike FABIAN 2013-07-04 02:08:30 EDT
Created attachment 768591 [details]
/var/log/fedup.log

The /var/log/fedup.log file.

It contains some messages about emacs and libgnutls:

[   101.668] (DD) fedup.depsolve:procReqPo() req po:   libgnutls.so.26()(64bit) → 1:emacs-24.2-19.fc18.x86_64
[   101.668] (DD) fedup.depsolve:format_missing_requires() MISSING REQ: 1:emacs-24.2-19.fc18.x86_64 requires libgnutls.so.26()(64bit)
[   101.669] (DD) fedup.depsolve:format_missing_requires() MISSING REQ: 1:emacs-24.2-19.fc18.x86_64 requires libgnutls.so.26()(64bit)
[   101.669] (DD) fedup.depsolve:procReqPo() req po:   libgnutls.so.26()(64bit) → 1:emacs-nox-24.2-19.fc18.x86_64
[   101.669] (DD) fedup.depsolve:format_missing_requires() MISSING REQ: 1:emacs-nox-24.2-19.fc18.x86_64 requires libgnutls.so.26()(64bit)
[   101.669] (DD) fedup.depsolve:format_missing_requires() MISSING REQ: 1:emacs-nox-24.2-19.fc18.x86_64 requires libgnutls.so.26()(64bit)
[   101.669] (DD) fedup.depsolve:procReqPo() req po:   libgnutls.so.26(GNUTLS_1_4)(64bit) → 1:emacs-24.2-19.fc18.x86_64
[   101.669] (DD) fedup.depsolve:format_missing_requires() MISSING REQ: 1:emacs-24.2-19.fc18.x86_64 requires libgnutls.so.26(GNUTLS_1_4)(64bit)
[   101.670] (DD) fedup.depsolve:format_missing_requires() MISSING REQ: 1:emacs-24.2-19.fc18.x86_64 requires libgnutls.so.26(GNUTLS_1_4)(64bit)
[   101.670] (DD) fedup.depsolve:procReqPo() req po:   libgnutls.so.26(GNUTLS_1_4)(64bit) → 1:emacs-nox-24.2-19.fc18.x86_64
[   101.670] (DD) fedup.depsolve:format_missing_requires() MISSING REQ: 1:emacs-nox-24.2-19.fc18.x86_64 requires libgnutls.so.26(GNUTLS_1_4)(64bit)
[   101.671] (DD) fedup.depsolve:format_missing_requires() MISSING REQ: 1:emacs-nox-24.2-19.fc18.x86_64 requires libgnutls.so.26(GNUTLS_1_4)(64bit)
[   101.671] (DD) fedup.depsolve:pkgAdded() added gnutls.i686 for u
[   101.680] (DD) fedup.depsolve:procReqPo() req po:   libnettle.so.4 → gnutls-3.1.11-1.fc19.i686
[   101.697] (DD) fedup.depsolve:procReqPo() req po:   libhogweed.so.2 → gnutls-3.1.11-1.fc19.i686
[   101.697] (DD) fedup.depsolve:procReqPo() req po:   libgmp.so.10 → gnutls-3.1.11-1.fc19.i686
[   101.714] (DD) fedup.depsolve:pkgAdded() added gnutls.x86_64 for u
[   101.721] (DD) fedup.depsolve:procReqPo() req po:   libnettle.so.4()(64bit) → gnutls-3.1.11-1.fc19.x86_64
[   101.726] (DD) fedup.depsolve:procReqPo() req po:   libhogweed.so.2()(64bit) → gnutls-3.1.11-1.fc19.x86_64
[   101.726] (DD) fedup.depsolve:pkgAdded() added gnutls-c++.x86_64 for ud
[   101.731] (DD) fedup.depsolve:pkgAdded() added gnutls-c++.x86_64 for u
[   101.734] (DD) fedup.depsolve:pkgAdded() added gnutls-devel.x86_64 for ud
[   101.739] (DD) fedup.depsolve:pkgAdded() added gnutls-devel.x86_64 for u
[   101.745] (DD) fedup.depsolve:procReqPo() req po:   gnutls-dane(x86-64) = 3.1.11-1.fc19 → gnutls-devel-3.1.11-1.fc19.x86_64
[   101.750] (DD) fedup.depsolve:procReqPo() req po:   libgnutls-dane.so.0()(64bit) → gnutls-devel-3.1.11-1.fc19.x86_64
[   101.750] (DD) fedup.depsolve:pkgAdded() added gnutls-utils.x86_64 for ud
[   101.752] (DD) fedup.depsolve:pkgAdded() added gnutls-utils.x86_64 for u
Comment 2 Alex Tucker 2013-07-04 05:39:38 EDT
I had the same issue.  As a workaround, I reinstalled emacs by removing the installed F18 version and installing the new F19 one through yum, i.e.:

sudo yum remove emacs emacs-common
sudo yum install emacs

Note that the removal also removed a couple of emacs extra packages I had previously installed, which needed to be installed again.

Not sure why yum refused to do this itself though.
Comment 3 John Morris 2013-07-05 01:56:14 EDT
This problem is the result of the fc18 and fc19 packages diverging.

The fc18 package is at version 1:24.2-19, which is higher than the fc19 package at version 1:24.2-18.  Yum sees that the fc18 package has a higher release number and therefore does not upgrade.

These two branches' last common commit was c458421e, "Spell checking broken by non-default dictionary (#827033)".  The f19 branch is now one ahead, and the f18 branch now three ahead.  It appears that the master branch is different from both of these.

Please (at least) bump the fc19 revision so that those upgrading to fc19 aren't stuck without their editor.

Thanks for maintaining the emacs package!
Comment 4 Ralf Schneider 2013-07-05 06:59:57 EDT
I had the same issue.
As a workaround I linked the missing library to the new one.

ln -s /usr/lib64/libgnutls.so.28 /usr/lib64/libgnutls.so.26
Comment 5 John Morris 2013-07-05 09:30:24 EDT
Ralf, you're better off removing and reinstalling emacs with the f19 version that's linked against the f19 gnutls library:

yum remove emacs emacs-common
yum install emacs emacs-common

Once the package maintainer bumps the RPM release, this problem will go away.
Comment 6 John Morris 2013-07-05 10:50:14 EDT
Add 'emacs-filesystem' to the above list of pkgs to remove and install.


Another workaround recommended in the upgrade wiki [1] to fix system package deps correctly is 'yum distro-sync' [2].  This will ensure that all packages come from the f19 distro, even if the replacement package appears to be a 'downgrade'.

This fails on my system, however; it seems to be downgrading even f19 updates, which is incorrect, and ultimately fails due to dependency resolution problems.  <sigh>


[1] http://fedoraproject.org/wiki/FedUp#Cleaning_Up_Post_Upgrade

[2] from yum man page:
distribution-synchronization or distro-sync
  Synchronizes the installed package set with the latest  packages
  available, this is done by either obsoleting, upgrading or down-
  grading as appropriate. This will "normally" do the  same  thing
  as  the  upgrade  command  however  if  you have the package FOO
  installed at version 4, and the latest available is only version
  3, then this command will downgrade FOO to version 3.
Comment 7 Ralf Schneider 2013-07-05 16:55:46 EDT
The distro-sync worked for me. It downgraded 5 Packages:

yum distribution-synchronization
....
================================================================================
 Package            Arch     Version                             Paketquelle
                                                                          Größe
================================================================================
Downgrading:
 emacs              x86_64   1:24.2-18.fc19                      fedora   2.7 M
 emacs-common       x86_64   1:24.2-18.fc19                      fedora    20 M
 emacs-filesystem   noarch   1:24.2-18.fc19                      fedora    56 k
 libtevent          x86_64   0.9.18-1.fc19                       fedora    29 k
 screen             x86_64   4.1.0-0.14.20120314git3c2946.fc19   fedora   549 k
...

I also removed the symbolic link to /usr/lib64/libgnutls.so.28

Thanks for the hint.
Comment 8 Ralf Schneider 2013-07-05 16:58:14 EDT
I forgot to say that I did the distro-sync after installation of the latest updates.
Comment 9 Petr Hracek 2013-07-15 07:45:44 EDT
*** Bug 979860 has been marked as a duplicate of this bug. ***
Comment 10 Petr Hracek 2013-07-15 08:36:09 EDT
scm-commit (https://lists.fedoraproject.org/pipermail/scm-commits/Week-of-Mon-20130715/1056500.html) -> MODIFIED

I have bump the version so that upgrade should be fine now.
Comment 11 Fedora Update System 2013-07-15 09:10:24 EDT
emacs-24.2-20.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/emacs-24.2-20.fc19
Comment 12 Fedora Update System 2013-07-15 21:39:52 EDT
Package emacs-24.2-20.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing emacs-24.2-20.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13022/emacs-24.2-20.fc19
then log in and leave karma (feedback).
Comment 13 John Morris 2013-07-16 00:01:23 EDT
Thanks, Petr!
Comment 14 Ralf Schneider 2013-07-16 16:40:54 EDT
The update works perfectly.

Thanks for that !

Sadly with the new version BUG 984177 shows up
https://bugzilla.redhat.com/show_bug.cgi?id=984177
Comment 15 Fedora Update System 2013-07-18 01:57:51 EDT
emacs-24.2-20.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.