This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 981147 - Broken provides/obsoletes
Broken provides/obsoletes
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: seabios (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-04 02:35 EDT by Mattias Ellert
Modified: 2013-07-18 02:06 EDT (History)
3 users (show)

See Also:
Fixed In Version: seabios-1.7.2.2-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 02:06:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mattias Ellert 2013-07-04 02:35:26 EDT
Description of problem:
The provides/obsoletes of vgabios are using the wrong syntax:

Obsoletes: vgabios < vgabios-0.6c-10
Provides: vgabios = vgabios-0.6c-10

Only version-release should be used in the right side:

Obsoletes: vgabios < 0.6c-10
Provides: vgabios = 0.6c-10

Version-Release number of selected component (if applicable):
seavgabios-bin-1.7.2.2-1.fc19.noarch

How reproducible:
Always

Steps to Reproduce:
1. Install seavgabios-bin with vgabios installed.

Actual results:
vgabios not removed when installing seavgabios-bin

Expected results:
vgabios removed when installing seavgabios-bin
Comment 1 Cole Robinson 2013-07-08 16:13:55 EDT
Yeah I messed that up, thanks for the report. I just changed it to Obsoletes: vgabios, because the version number usage would actually conflict with F18 where we are still doing bug fix updates for vgabios. Build coming shortly.
Comment 2 Fedora Update System 2013-07-08 16:19:27 EDT
seabios-1.7.3-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/seabios-1.7.3-1.fc19
Comment 3 Fedora Update System 2013-07-09 10:42:07 EDT
seabios-1.7.2.2-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/seabios-1.7.2.2-2.fc19
Comment 4 Fedora Update System 2013-07-09 21:28:13 EDT
Package seabios-1.7.2.2-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing seabios-1.7.2.2-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12673/seabios-1.7.2.2-2.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-07-18 02:06:19 EDT
seabios-1.7.2.2-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.