Bug 98118 - If a file viewed via Mozilla proxies through privoxy, the open keyword gats translated to concat
Summary: If a file viewed via Mozilla proxies through privoxy, the open keyword gats t...
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: privoxy (Show other bugs)
(Show other bugs)
Version: 9
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact:
URL: http://davesource.com/Bugs/mozilla.2....
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-26 20:18 UTC by Steven W. Orr
Modified: 2007-04-18 16:55 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-26 21:07:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steven W. Orr 2003-06-26 20:18:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030525

Description of problem:
Using Mozilla which is using privoxy, go to
http://davesource.com/Bugs/mozilla.2.html
and see that the text which contains the open keyword is translated to concat.
Reproducible every time. We have determined that the problem is privoxy related.

You can see the reported bug at mozilla at 

http://bugzilla.mozilla.org/show_bug.cgi?id=203609

(We originally thought the bug was in Mozilla.)

Version-Release number of selected component (if applicable):
privoxy-3.0.0-8

How reproducible:
Always

Steps to Reproduce:
1. http://davesource.com/Bugs/mozilla.2.html
2. See the word concat?
3. Now fetch the same file using lynx (or without privoxy).
    

Actual Results:  The word concat was displayed.

Expected Results:  The word open should have been displayed.

Additional info:

I'm calling this severity high because it represents a data loss.

Comment 1 Karsten Hopp 2003-06-26 21:07:28 UTC
Thats a known problem of privoxy. Everything will be filtered unless you configure privoxy to 
omit filtering for URLs match a certain pattern.  
Please add a regex like this at the top of your user.action file (accessable vi http://p.p/): 
{ -filter } 
/(.*/)?.*\.(pl|(s|p)?h|c(c|xx|pp)?|p?y|tcl|in|m4|diff|am|init?|cfg?|conf(ig)?|sgml?|css|txt|rc|bat|spec|log)$cvsview./(.*/)?(cvsweb|cvsview|viewcvs|rc\.|README|Makefile|INSTALL|CPAN|txt) 
 
(Everything after { -filter }  needs to be in one line) 
A similar line is already as a comment in the user.action file, this one is a more enhanced 
version from one of the privoxy authors. 
 


Note You need to log in before you can comment on or make changes to this bug.