Bug 981226 - Cannot sort VM list by any field under the “Virtual Machines” tab under “Storage”
Cannot sort VM list by any field under the “Virtual Machines” tab under “Stor...
Status: CLOSED DUPLICATE of bug 895222
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
x86_64 Linux
unspecified Severity medium
: ---
: 3.4.0
Assigned To: Ayal Baron
vvyazmin@redhat.com
storage
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-04 05:32 EDT by vvyazmin@redhat.com
Modified: 2016-02-10 12:58 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-07 05:01:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
## Screenshot (360.35 KB, image/png)
2013-07-04 05:32 EDT, vvyazmin@redhat.com
no flags Details

  None (edit)
Description vvyazmin@redhat.com 2013-07-04 05:32:43 EDT
Created attachment 768680 [details]
## Screenshot

Description of problem:
Can sort result VM  it by any field (Alias, Virtual Size, Actual size) under the “Virtual Machines” tab under “Storage”

Version-Release number of selected component (if applicable):
RHEVM 3.3 - IS4 environment:

RHEVM: rhevm-3.3.0-0.6.master.el6ev.noarch
VDSM: vdsm-4.11.0-89.git8bf916a.el6.x86_64
LIBVIRT: libvirt-0.10.2-18.el6_4.9.x86_64
QEMU & KVM: qemu-kvm-rhev-0.12.1.2-2.355.el6_4.5.x86_64
SANLOCK: sanlock-2.6-2.el6.x86_64

How reproducible:
100 %

Steps to Reproduce:
1. Create VM Pool with 8 VMs
1.1. As alternative way create 8 VM’s in one Storage Domain
2. Under “Storage” tub select your relevant Storage Domain, and in details pane select “Virtual Machines” tab
  
Actual results:
You can view all VM’s under “Virtual Machines” tab, but not sorted / or can sort it by any field (Alias, Virtual Size, Actual size) (see attached Screenshot)

It's very hard find in this list some thing relevant if I have a list of more than 100 VM's

Expected results:
You can view all VM’s under “Virtual Machines” tab, and sorted it by any field (Alias, Virtual Size, Actual size)

Impact on user:

Workaround:
no

Additional info:

Screenshot attached 

/var/log/ovirt-engine/engine.log

/var/log/vdsm/vdsm.log
Comment 1 Daniel Erez 2013-07-07 05:01:56 EDT

*** This bug has been marked as a duplicate of bug 895222 ***

Note You need to log in before you can comment on or make changes to this bug.