Bug 981279 - Should use '[]' to separate ipv6 server and port number in status page
Should use '[]' to separate ipv6 server and port number in status page
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-04 07:10 EDT by wanghui
Modified: 2014-01-21 14:44 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously the IPv6 addresses were shown as ordinary text. To highlight that they are IPv6 addresses they are now shown according to RFC 2732 - contained in [] brackets.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:44:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs display in status page (40.59 KB, image/png)
2013-07-04 07:10 EDT, wanghui
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 16519 None None None Never

  None (edit)
Description wanghui 2013-07-04 07:10:04 EDT
Created attachment 768729 [details]
logs display in status page

Description of problem:
It should use '[]' to seperate ipv6 server and port number.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20130222.0.auto1707.el6.iso
ovirt-node-3.0.0-1.999.20130701111251git99aadc6.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Clean install the rhev-hypervisor6-6.5.
2. Configure the network with ipv6 auto mode.
3. Configure the Rsyslog server using ipv6 address.
4. Check the display in Status page.

Actual results:
In step4, it display the rsyslog server like the follows.
Rsyslog:   3ef1:db80:1:0:5054:ff:fe54:5c24:514
It will lead misunderstanding that the 514 is part of the server's address.

Expected results:
In step4, it will display like [3ef1:db80:1:0:5054:ff:fe54:5c24]:514 according to definition from the RFC 2732.

Additional info:
RFC 2732:  http://www.ietf.org/rfc/rfc2732.txt
Comment 2 Fabian Deutsch 2013-07-05 11:14:39 EDT
Fixed in http://gerrit.ovirt.org/16519

Tested as follows:
1. Apply patch
2. Configure NIC with IPv6 auto
3. Enter status page and focus on IPv6 addr
4. IPv6 addr is shown in []
5. Enter logging page and set 1::1 as the syslog server address
6. Enter status page
7. The syslog server addr is shown in []
Comment 4 wanghui 2013-07-21 23:36:13 EDT
Test Version-Release :
rhev-hypervisor6-6.5-20130222.0.auto1744.el6.noarch.rpm
ovirt-node-3.0.0-999.0.20130719134242gitb6ab8be.el6.noarch

Test Steps:
1. Clean install the rhev-hypervisor6-6.5.
2. Configure the network with ipv6 auto mode.
3. Configure the Rsyslog/Netconsole server using ipv6 address.
4. Check the display in Status page.

Test Results:
In step4, it will display ipv6 address using '[]'.

This issue is fixed in this build. So change the status from ON_QA to VERIFIED.
Comment 5 wanghui 2013-07-21 23:52:55 EDT
Change it back to on-qa, because there is no official build now.
I will verify this bug when official build on brewweb is ready.
Comment 6 wanghui 2013-07-30 01:17:05 EDT
Test Version-Release :
rhev-hypervisor6-6.5-20130725.0.el6.noarch.rpm
ovirt-node-3.0.0-6.1.el6.noarch

Test Steps:
1. Clean install the rhev-hypervisor6-6.5.
2. Configure the Rsyslog/Netconsole server using ipv6 address.
3. Check the display in Status page.

Test Results:
In step4, it will display ipv6 address using '[]'.

This issue is fixed in this build. So change the status from ON_QA to VERIFIED.
Comment 9 Cheryn Tan 2013-11-07 19:30:56 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 11 errata-xmlrpc 2014-01-21 14:44:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.