Bug 981312 - Nautilus fixed column width & 'Name' column too narrow in list view
Nautilus fixed column width & 'Name' column too narrow in list view
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
19
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-04 08:51 EDT by czerny.jakub
Modified: 2015-03-04 07:11 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-25 15:52:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Horizontal shrinking of Nautilus window (148.51 KB, image/png)
2013-07-04 08:51 EDT, czerny.jakub
no flags Details
Screenshot for comment #4 (115.96 KB, image/png)
2013-08-14 19:27 EDT, amreg
no flags Details

  None (edit)
Description czerny.jakub 2013-07-04 08:51:33 EDT
Created attachment 768783 [details]
Horizontal shrinking of Nautilus window

Description of problem:
It isn't possible to set column width in list view in Nautilus. If the window is small, nautilus shrinks 'name' column as much as possible before before creating horizontal scroll bar.  


Version-Release number of selected component (if applicable):
Fedora 19, Nautilus 3.8.2

How reproducible:


Steps to Reproduce:
1. Open Nautilus
2. Select list view
3. Gradually decrease width of nautilus window.
4. When horizontal scroll bar appears, try to change the width of any column.

Actual results:
'Name' column shrinks to minimum possible width (just icon and  ellipsis triple dot is visible). Width of other columns fits the content. Any column can't be resized.


Expected results:
All columns shrinks just as much as not to hide their content. If there is not enough space, horizontal scroll bar appears. All columns are always resizable to arbitrary width.

Additional info:
Comment 1 John B 2013-07-15 23:21:47 EDT
I am getting the same behavior with Fedora 19 (3.9.9-301.fc19.x86_64), nautilus 3.8.2

It is quite annoying to have to enlarge the window and make the scroll bar disappear before being able to read the name of the files.

I am willing to test any patch/update that may be produced.

cheers
Comment 2 Louis Melahn, L.C. 2013-08-10 04:31:54 EDT
I have exactly the same, on Debian Jessie, also Nautilus 3.8.2. Just one detail that might help:

The problem appears to be that _only_ the Name column is allowed to be re-sized to less than its text width, unless the name column is at its minimum.

In fact, the Name column should be the one least likely to be obscured in this way.

Also, all columns should be shrinkable to an arbitrary width if this is done manually.

The current configuration doesn't cause _much_ of a problem when the columns are all short. (It is still annoying, however.) If you activate the Location column, however, it can easily eat up all of the available space.
Comment 3 Didier G 2013-08-12 09:36:42 EDT
Same problem with columns sizes using Fedora 19 and nautilus-3.8.2-1.fc19.x86_64

Really annoying during daily use.
Comment 4 amreg 2013-08-14 19:25:59 EDT
Another way to get the same issue (I usually use the "list" view rather than the icon view, because I often need to see at a glance the main attributes -last modification time, owner, group, ...- of the file/directory I'm seeing. So I often use several columns at once in list view).

First, note that the text displayed in the "owner" column is the full-long name of the account, instead of the "login" name : for some user accounts created with an unusually long "full name" (e.g. user whose UID is 59, "login" name is "tss", and full name is "Account used by the trousers package to sandbox the tcsd daemon"), this trigger the same bug. How to reproduce :

1- Select the "list view" display mode for the window.
2- Configure it to show the following columns (in addition of "name") : size, type, last mod, owner, group, permissions.
3- Try to display the /etc directory, that has a subdirectory owned by the above "user account" : the "owner" colum should grow and eat up the most part of the window, crunching all others to the bare minimum, making them unreadable. In particular, the first column ("name") has scarcely the room to display the icon but not the file/dir name, so you end up not knowing which file/dir you (are desperately trying to) look at (I'll try to add a screenshot)... Especially boring when you need to move around /etc to fix a configuration problem, I agree with "Didier G" above.
4- Try to resize the offending "owner" column to shrink it : it's *impossible*, the widths got *locked*.
5- Escape from this directory, and go to another one : the columns keep the width they got in /etc, so the problem encountered in /etc is now "exported" to any other directory in the filesystem.
6- Try to resize the columns : still impossible, the widths remain locked. You have to hide a column, then unhide it, to re-enable the resizing of the columns.

The only workarounds I've found so far (that is, to be able to see what is in /etc) are :
- to revert to "icon view",
- or to hide the offending extra-wide column,
just when navigating this particular directory, and restoring my settings as soon as I've left this trap...

The problem is the combination of the following :
- using the "full" name" instead of the "login" name for the "owner" column, thus allowing arbitrarily-long content for this column (you may test with a full-name that can be 1000-character long, for instance...);
- for each column, using the width of its widest item as the imposed *minimum* colum size, regardless of overall available window space: it is impossible to resize it to less that this widest size;
- despite the appearance of an horizontal scrollbar, blocking the ability to resize columns when the "automatic widening" of a column makes the list exceeds the width of the window visible size.
Comment 5 amreg 2013-08-14 19:27:43 EDT
Created attachment 786725 [details]
Screenshot for comment #4
Comment 6 tosca 2013-09-10 04:30:36 EDT
Is a fix scheduled for soon?
That behavior is very annoying, especially when you have several files which differ only by the last characters (i.e. several versions of the same image or dcument).
Comment 7 jakobunt 2013-10-11 15:49:09 EDT
This is https://bugzilla.gnome.org/show_bug.cgi?id=693459 in the Gnome bugtracker.
Comment 8 Tom Colley 2014-03-10 23:14:00 EDT
I have had issues with Nautilus (Files) 3.8.2 in Ubuntu 13.10. I discovered that when I removed the column for MIME Type, that the resizing issue disappeared. Perhaps this is a workaround or a clue about the cause of the problem. Resizing columns works fine for me now using 4 columns: Name, Size, Type, Modified.
Comment 9 czerny.jakub 2014-11-25 15:14:12 EST
It seems to work in Fedora 21 (Nautilus 3.14.1) so I suggest to close this bus with resolution NEXTRELEASE.
Comment 10 brad.banko 2015-03-04 07:11:22 EST
I have the same problem in fedora 20.

Note You need to log in before you can comment on or make changes to this bug.