Bug 981319 - All tasks aborted after registration to RHN Classic
All tasks aborted after registration to RHN Classic
Status: CLOSED CANTFIX
Product: Beaker
Classification: Community
Component: beah (Show other bugs)
0.11
Unspecified Unspecified
high Severity medium (vote)
: ---
: ---
Assigned To: beaker-dev-list
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-04 09:04 EDT by Jakub Dorňák
Modified: 2016-11-30 19:57 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 19:57:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
console.log (246.20 KB, text/x-log)
2013-07-04 09:04 EDT, Jakub Dorňák
no flags Details

  None (edit)
Description Jakub Dorňák 2013-07-04 09:04:44 EDT
Created attachment 768798 [details]
console.log

Description of problem:
Regardless to whether the system is registered by task or manually, all the remaining tasks are aborted.

Version-Release number of selected component (if applicable):
beaker current live
RHEL-6.4 (released)


How reproducible:
always with RHEL-6.4 (did not try any other distro)

Steps to Reproduce:
1. Clone job 445415
2. See the logs

Actual results:
Every task after /installation/entitlement/RHN/units/register is aborted.

Expected results:
All the tasks run successfully.
Comment 2 Dan Callaghan 2013-07-18 19:57:23 EDT
It looks like RHN registration broke yum:

Error: failed to retrieve repodata/3e7d01fc2f00baf584414c50eaf3c7c0e6f9e123bf877036dd4539f877704d27-primary.xml.gz from rhel-x86_64-server-6
error was [Errno 14] PYCURL ERROR 7 - "couldn't connect to host"

package installation-installation-content-testing-units-verify-content is not installed

which is why all subsequent tasks failed to install. The harness installs tasks using yum, so I'm not sure if there is anything else it could do here. The only solution I can offer is "don't break yum".

In the (distant?) future tasks will be installed by fetching a tarball over HTTP or from git-archive (bug 554844), so that the harness won't depend on a working yum configuration.

Note You need to log in before you can comment on or make changes to this bug.