Bug 981331 - RFE: allow attaching a volume from the instance view
RFE: allow attaching a volume from the instance view
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
unspecified
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Runge
Ido Ovadia
storage
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-04 09:27 EDT by Dafna Ron
Modified: 2015-12-08 02:47 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-08 02:47:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1378317 None None None Never

  None (edit)
Description Dafna Ron 2013-07-04 09:27:59 EDT
Description of problem:

to attach a volume we need to go to the volumes tab and select an instance in the edit attachment dialogue. 
but since instances will usually be created as a bulk and will be assigned UIDs and not a human readable name while the volumes will be attached one at a time and probably with human names it will be easier to attach a volume from the instance view and not from the volume view. 

Version-Release number of selected component (if applicable):

python-django-horizon-2013.1.2-1.el6ost.noarch

How reproducible:

100%

Steps to Reproduce:
1. run a lot of instances at once
2. try to attach a volume and select the correct instance from a huge list of instances 
3.

Actual results:

its hard to locate the correct instance since the list of instances will be in UUID's and not a human readable name 

Expected results:

we should add attach volume to the "More" button near each vm to allow a user to easily attach a volume. 

Additional info:
Comment 1 Matthias Runge 2015-12-08 02:47:49 EST
This was reported upstream, but finally decided not to implement this.

Note You need to log in before you can comment on or make changes to this bug.