Bug 981349 - [abrt] libreoffice-core-4.1.0.1-3.fc19: exit: Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 6 (SIGABRT)
[abrt] libreoffice-core-4.1.0.1-3.fc19: exit: Process /usr/lib64/libreoffice/...
Status: CLOSED DUPLICATE of bug 1030009
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michael Stahl
Fedora Extras Quality Assurance
abrt_hash:fb93dd5d4847ac260591700b893...
:
: 996473 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-04 10:02 EDT by Herman Grootaers
Modified: 2013-11-14 05:02 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-22 09:18:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (82.91 KB, text/plain)
2013-07-04 10:02 EDT, Herman Grootaers
no flags Details
File: cgroup (140 bytes, text/plain)
2013-07-04 10:02 EDT, Herman Grootaers
no flags Details
File: dso_list (31.98 KB, text/plain)
2013-07-04 10:02 EDT, Herman Grootaers
no flags Details
File: environ (2.29 KB, text/plain)
2013-07-04 10:02 EDT, Herman Grootaers
no flags Details
File: hs_err.log (209.32 KB, text/plain)
2013-07-04 10:02 EDT, Herman Grootaers
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-04 10:02 EDT, Herman Grootaers
no flags Details
File: maps (184.13 KB, text/plain)
2013-07-04 10:02 EDT, Herman Grootaers
no flags Details
File: open_fds (1004 bytes, text/plain)
2013-07-04 10:02 EDT, Herman Grootaers
no flags Details
File: proc_pid_status (945 bytes, text/plain)
2013-07-04 10:02 EDT, Herman Grootaers
no flags Details
File: var_log_messages (703 bytes, text/plain)
2013-07-04 10:02 EDT, Herman Grootaers
no flags Details
A not modified sourcefile (24.81 KB, application/vnd.oasis.opendocument.text)
2013-08-20 16:08 EDT, Herman Grootaers
no flags Details
Fonts installed on my system (103.71 KB, text/plain)
2013-08-20 16:09 EDT, Herman Grootaers
no flags Details

  None (edit)
Description Herman Grootaers 2013-07-04 10:02:01 EDT
Description of problem:
Closing a file when finished with editing and/or viewing.

Version-Release number of selected component:
libreoffice-core-4.1.0.1-3.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --writer /home/herman/Boekenlezer/Akathisti/ODT/03_Theotokos-Kazan-Icon_kazansk.odt --splash-pipe=5
core_backtrace: 
crash_function: exit
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.9.8-300.fc19.x86_64
runlevel:       N 5
uid:            1000
xsession_errors: 

Truncated backtrace:
Thread no. 1 (1 frames)
 #22 exit at exit.c:99

Potential duplicate: bug 919934
Comment 1 Herman Grootaers 2013-07-04 10:02:06 EDT
Created attachment 768820 [details]
File: backtrace
Comment 2 Herman Grootaers 2013-07-04 10:02:09 EDT
Created attachment 768821 [details]
File: cgroup
Comment 3 Herman Grootaers 2013-07-04 10:02:16 EDT
Created attachment 768822 [details]
File: dso_list
Comment 4 Herman Grootaers 2013-07-04 10:02:20 EDT
Created attachment 768823 [details]
File: environ
Comment 5 Herman Grootaers 2013-07-04 10:02:24 EDT
Created attachment 768824 [details]
File: hs_err.log
Comment 6 Herman Grootaers 2013-07-04 10:02:29 EDT
Created attachment 768825 [details]
File: limits
Comment 7 Herman Grootaers 2013-07-04 10:02:33 EDT
Created attachment 768826 [details]
File: maps
Comment 8 Herman Grootaers 2013-07-04 10:02:38 EDT
Created attachment 768827 [details]
File: open_fds
Comment 9 Herman Grootaers 2013-07-04 10:02:42 EDT
Created attachment 768828 [details]
File: proc_pid_status
Comment 10 Herman Grootaers 2013-07-04 10:02:45 EDT
Created attachment 768829 [details]
File: var_log_messages
Comment 11 Caolan McNamara 2013-07-04 10:41:41 EDT
Every document? Or a specific one ?

caolanm->mstahl: some SwXTextDocument global somewhere or other ?
Comment 12 Michael Stahl 2013-07-04 14:24:03 EDT
indeed stack looks like a global/static SwXTextDocument...
but i can't find such a thing (and why would anybody do that?)

supposedly if it were some uno::Reference there'd be at least
a release() call on the stack...

what is new in 4.1 is that the dtor grabs the SolarMutex
but clearly all instances should be deleted before exit handlers run.
Comment 13 Herman Grootaers 2013-07-05 07:27:19 EDT
The problem is for multiple files, which were generated from a PDF, imported in OpenOffice/LibreOffice by ^A; ^C; and ^V and stored in odt-format.

No problems were detected in the change from OpenOffice to LibreOffice, editing is normal, but when I save and close a file, or close a file directly after checking some details, it sometimes crashes with a probability of 75% of the times.
Comment 14 Michael Stahl 2013-08-13 05:48:06 EDT
*** Bug 996473 has been marked as a duplicate of this bug. ***
Comment 15 Caolan McNamara 2013-08-20 15:33:23 EDT
Can we get an example of something which crashes for you attached to this bug ?
Comment 16 Herman Grootaers 2013-08-20 16:08:50 EDT
Created attachment 788631 [details]
A not modified sourcefile
Comment 17 Herman Grootaers 2013-08-20 16:09:59 EDT
Created attachment 788632 [details]
Fonts installed on my system
Comment 18 Herman Grootaers 2013-08-20 16:14:28 EDT
Maybe a lot of fontfiles, but I am busy with generating tex-files from the odt-files to make nice documents, and I want to have the possibility to switch fonts to see what looks better, is more readable and so on.

Also I did not notice it before, but this crashing seems to have stopped with the new release of LibreOffice build 4.1.0.5-6fc19.
Comment 19 Caolan McNamara 2013-08-22 09:18:44 EDT
I load the doc I get a (non global) SwXTextDocument as expected, I close the doc and the SwXTextDocument dtor is called in the usual manner, no sign of any global SwXTextDocument anywhere getting into the exit chain. Nothing suspicious under valgrind either.

On the basis of "this crashing seems to have stopped with the new release of LibreOffice build 4.1.0.5" lets call it "worksforme" unless anyone has a known way to reproduce this
Comment 20 Caolan McNamara 2013-11-14 05:02:38 EST

*** This bug has been marked as a duplicate of bug 1030009 ***

Note You need to log in before you can comment on or make changes to this bug.