Bug 981407 - FORM input for a file name changed in a bad way
FORM input for a file name changed in a bad way
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-04 11:47 EDT by Milan Crha
Modified: 2013-07-08 05:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-08 03:37:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot of the actual view in firefox (10.84 KB, image/png)
2013-07-04 11:47 EDT, Milan Crha
no flags Details
how it should be (14.82 KB, image/png)
2013-07-04 12:03 EDT, Milan Crha
no flags Details

  None (edit)
Description Milan Crha 2013-07-04 11:47:51 EDT
Created attachment 768858 [details]
screen shot of the actual view in firefox

I just updated to firefox-22.0-1.fc19.x86_64 and it shows an Input for a file name in a WEB form (like when adding an attachment to bugzilla), as is shown in the attached picture. I consider it as a very bad idea from usability point of view due to these reasons:
a) the "Browse..." button used to be on the right, for Left-To-Right languages,
   and it made sense there, I first see what file is chosen and then pick
   another one, if I want to
b) the entry part shows only the file name, not full path. I can have multiple
   folders with the same name on my disk, or other disks I'm connected to, thus
   the file name itself, without full path, is basically meaningless with
   respect of verification that I attach the right file
Comment 1 Milan Crha 2013-07-04 12:03:19 EDT
Created attachment 768864 [details]
how it should be

This is how it should be, in firefox-21.0-3.fc19.x86_64. Note that one can even recognize the entry part from the other text in the window, not like with 22.0, where it's quite hard to know where the entry ends (clicking randomly around I would be surprised that on one place I get a file browser, when it looks like completely empty space on the page.
Comment 2 Jan Horak 2013-07-08 03:37:57 EDT
I'm afraid this change was intentional: 
https://bugzilla.mozilla.org/show_bug.cgi?id=838675
especially:
https://bugzilla.mozilla.org/show_bug.cgi?id=838676

I'm afraid we can't help you, it seems there's no option in about:config which would put back previous file input behaviour.

You may try to file bug on mozilla bugzilla against this change.
Comment 3 Milan Crha 2013-07-08 05:00:00 EDT
OK, thanks.

Note You need to log in before you can comment on or make changes to this bug.