Bug 981438 - icedtea-web - error with java applet
icedtea-web - error with java applet
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: icedtea-web (Show other bugs)
19
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: jiri vanek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-04 12:57 EDT by Michel Duquaine
Modified: 2014-08-07 09:08 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-07 09:08:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full error details (2.91 KB, text/plain)
2013-07-04 12:58 EDT, Michel Duquaine
no flags Details

  None (edit)
Description Michel Duquaine 2013-07-04 12:57:56 EDT
Description of problem:


Version-Release number of selected component (if applicable):
[icedtea-web.x86_64             1.4-2.fc19]

How reproducible:


Steps to Reproduce:
1.Got to java.com website and click to test the java version present on the computer
2.The applet shows an "error"
3.copy/paste of the full error message in attachment

Actual results:
java applet returns error

Expected results:
java applet returns no error

Additional info:
Comment 1 Michel Duquaine 2013-07-04 12:58:56 EDT
Created attachment 768917 [details]
full error details
Comment 2 jiri vanek 2013-07-10 04:13:33 EDT
This is known issue. Work in progress!
Comment 3 Riku Seppala 2013-08-12 14:14:20 EDT
Any progress?
Comment 4 Samuel Sieb 2013-09-11 16:28:27 EDT
This happens on F18 as well with icedtea-web-1.4-1.fc18.i686.
Comment 5 Samuel Sieb 2013-09-11 20:32:38 EDT
Oddly, it seem to be a firefox-only issue.  It works fine in SeaMonkey and Chrome.
Comment 6 Riku Seppala 2013-09-12 03:44:09 EDT
Now that you mention it, it works fine in Konqueror too.
Comment 7 Riku Seppala 2013-09-25 07:43:59 EDT
This seems to work now?
Comment 8 Sitsofe Wheeler 2013-12-20 05:25:09 EST
I'm seeing the error within comment #1 in Firefox on Fedora 20 x86_64 with an HP JetDirect embedded web server page. java.com's version tester produces a different issue (see Bug #903406).

How reproducible is the problem?
The problem is reproducible every time.

Additional information:
IcedTea-Web Plugin version: 1.4.1 (fedora-0.fc20-x86_64)
Fri Dec 20 10:18:14 GMT 2013
net.sourceforge.jnlp.LaunchException: Fatal: Initialization Error: Could not initialize applet. For more information click "more information button".
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:734)
	at net.sourceforge.jnlp.Launcher.getApplet(Launcher.java:662)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:914)
Caused by: net.sourceforge.jnlp.LaunchException: Fatal: Application Error: Unknown Main-Class. Could not determine the main class for this application.
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.initializeResources(JNLPClassLoader.java:708)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.<init>(JNLPClassLoader.java:249)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.createInstance(JNLPClassLoader.java:382)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:444)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:420)
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:700)
	... 2 more

 Chain: 
1) at Fri Dec 20 10:18:11 GMT 2013
net.sourceforge.jnlp.LaunchException: Fatal: Application Error: Unknown Main-Class. Could not determine the main class for this application.
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.initializeResources(JNLPClassLoader.java:708)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.<init>(JNLPClassLoader.java:249)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.createInstance(JNLPClassLoader.java:382)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:444)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:420)
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:700)
	at net.sourceforge.jnlp.Launcher.getApplet(Launcher.java:662)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:914)
2) at Fri Dec 20 10:18:11 GMT 2013
net.sourceforge.jnlp.LaunchException: Fatal: Initialization Error: Could not initialize applet. For more information click "more information button".
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:734)
	at net.sourceforge.jnlp.Launcher.getApplet(Launcher.java:662)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:914)
Caused by: net.sourceforge.jnlp.LaunchException: Fatal: Application Error: Unknown Main-Class. Could not determine the main class for this application.
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.initializeResources(JNLPClassLoader.java:708)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.<init>(JNLPClassLoader.java:249)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.createInstance(JNLPClassLoader.java:382)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:444)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:420)
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:700)
	... 2 more
3) at Fri Dec 20 10:18:11 GMT 2013
net.sourceforge.jnlp.LaunchException: Fatal: Application Error: Unknown Main-Class. Could not determine the main class for this application.
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.initializeResources(JNLPClassLoader.java:708)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.<init>(JNLPClassLoader.java:249)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.createInstance(JNLPClassLoader.java:382)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:444)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:420)
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:700)
	at net.sourceforge.jnlp.Launcher.getApplet(Launcher.java:662)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:914)
4) at Fri Dec 20 10:18:11 GMT 2013
net.sourceforge.jnlp.LaunchException: Fatal: Initialization Error: Could not initialize applet. For more information click "more information button".
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:734)
	at net.sourceforge.jnlp.Launcher.getApplet(Launcher.java:662)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:914)
Caused by: net.sourceforge.jnlp.LaunchException: Fatal: Application Error: Unknown Main-Class. Could not determine the main class for this application.
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.initializeResources(JNLPClassLoader.java:708)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.<init>(JNLPClassLoader.java:249)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.createInstance(JNLPClassLoader.java:382)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:444)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:420)
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:700)
	... 2 more
5) at Fri Dec 20 10:18:11 GMT 2013
net.sourceforge.jnlp.LaunchException: Fatal: Application Error: Unknown Main-Class. Could not determine the main class for this application.
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.initializeResources(JNLPClassLoader.java:708)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.<init>(JNLPClassLoader.java:249)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.createInstance(JNLPClassLoader.java:382)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:444)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:420)
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:700)
	at net.sourceforge.jnlp.Launcher.getApplet(Launcher.java:662)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:914)
6) at Fri Dec 20 10:18:11 GMT 2013
net.sourceforge.jnlp.LaunchException: Fatal: Initialization Error: Could not initialize applet. For more information click "more information button".
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:734)
	at net.sourceforge.jnlp.Launcher.getApplet(Launcher.java:662)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:914)
Caused by: net.sourceforge.jnlp.LaunchException: Fatal: Application Error: Unknown Main-Class. Could not determine the main class for this application.
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.initializeResources(JNLPClassLoader.java:708)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.<init>(JNLPClassLoader.java:249)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.createInstance(JNLPClassLoader.java:382)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:444)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:420)
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:700)
	... 2 more
7) at Fri Dec 20 10:18:11 GMT 2013
net.sourceforge.jnlp.LaunchException: Fatal: Application Error: Unknown Main-Class. Could not determine the main class for this application.
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.initializeResources(JNLPClassLoader.java:708)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.<init>(JNLPClassLoader.java:249)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.createInstance(JNLPClassLoader.java:382)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:444)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:420)
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:700)
	at net.sourceforge.jnlp.Launcher.getApplet(Launcher.java:662)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:914)
8) at Fri Dec 20 10:18:11 GMT 2013
net.sourceforge.jnlp.LaunchException: Fatal: Initialization Error: Could not initialize applet. For more information click "more information button".
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:734)
	at net.sourceforge.jnlp.Launcher.getApplet(Launcher.java:662)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:914)
Caused by: net.sourceforge.jnlp.LaunchException: Fatal: Application Error: Unknown Main-Class. Could not determine the main class for this application.
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.initializeResources(JNLPClassLoader.java:708)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.<init>(JNLPClassLoader.java:249)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.createInstance(JNLPClassLoader.java:382)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:444)
	at net.sourceforge.jnlp.runtime.JNLPClassLoader.getInstance(JNLPClassLoader.java:420)
	at net.sourceforge.jnlp.Launcher.createApplet(Launcher.java:700)
	... 2 more

Version information:
Fedora release 20 (Heisenbug)
java-1.7.0-openjdk-headless-1.7.0.60-2.4.3.0.fc20.x86_64
java-1.7.0-openjdk-devel-1.7.0.60-2.4.3.0.fc20.x86_64
java-1.7.0-openjdk-1.7.0.60-2.4.3.0.fc20.x86_64
icedtea-web-1.4.1-0.fc20.x86_64
firefox-26.0-3.fc20.x86_64
Comment 9 jiri vanek 2013-12-20 09:40:36 EST
Can you please provide url where I can check? 
Also please nexttime add error rport from just *single* run and as attachement, sot he formating is kept.
Comment 10 Sitsofe Wheeler 2013-12-20 10:26:27 EST
I apologise for the inline paste - it was to make it easier to find the bug if people google search on sub parts of the error.

Sadly the problem site is not publicly accessible as it is for control of a printer from HP. What can I provide to you to help you debug this anyway?
Comment 11 jiri vanek 2014-03-10 07:25:23 EDT
Do you mind to try with self compiled (or f21's RPMed) icedtea-web  1.5? If it  fails, in java console would be quite verbose output. Can you copypaste it to attachment? But I hopes the main-class searching  is fiexed here...
Comment 12 Sitsofe Wheeler 2014-03-10 09:08:21 EDT
Jiri:

Installing https://dl.fedoraproject.org/pub/fedora/linux/development/rawhide/x86_64/os/Packages/i/icedtea-web-1.5-0.3.pre03.fc21.x86_64.rpm and tagsoup on Fedora 20 has resolved the problem. The fonts look a bit crazy (too wide) but the site works.

For what it's worth Java in Windows browsers now blocks running of the Java applets from the Jet Direct box by default (presumably because only parts of it are signed). On Windows the only way round this is to manually add an exception for the whole site using the instructions on https://www.java.com/en/download/help/java_blocked.xml ...
Comment 13 Charles R. Anderson 2014-03-24 14:33:18 EDT
The solution in comment #12 works for me as will with the Cloudpath XpressConnect
installer on Fedora 20 (although now I'm running into a different error with XpressConnect: "The Network Manager daemon is not running.  Please start it and run this program again.")

It sounds like we need the new icedtea-web from rawhide backported to Fedora 19 and 20.  Can this be done?  Thanks.
Comment 14 jiri vanek 2014-03-25 03:28:40 EDT
In rawhide is pre release version. Once it - 1.5 - is properly release - It should be 1th of April, then I will backport to f20 and f19 (maybe with small intentional delay)
Comment 15 jiri vanek 2014-08-07 04:56:07 EDT
https is being rewritten fo 1.6

Note You need to log in before you can comment on or make changes to this bug.