Bug 981455 - SELinux is preventing /usr/lib64/erlang/erts-5.10.1/bin/beam.smp from 'read' accesses on the file crash.log.
SELinux is preventing /usr/lib64/erlang/erts-5.10.1/bin/beam.smp from 'read' ...
Status: CLOSED DUPLICATE of bug 981448
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:814a84cd55873c840cc3bf61ae7...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-04 14:48 EDT by Mark
Modified: 2013-07-07 03:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-07 03:12:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark 2013-07-04 14:48:26 EDT
Description of problem:
SELinux is preventing /usr/lib64/erlang/erts-5.10.1/bin/beam.smp from 'read' accesses on the file crash.log.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that beam.smp should be allowed read access on the crash.log file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep beam.smp /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:rabbitmq_beam_t:s0
Target Context                system_u:object_r:var_log_t:s0
Target Objects                crash.log [ file ]
Source                        beam.smp
Source Path                   /usr/lib64/erlang/erts-5.10.1/bin/beam.smp
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           erlang-erts-R16B-0.3.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-54.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.8-300.fc19.x86_64 #1 SMP Thu
                              Jun 27 19:24:23 UTC 2013 x86_64 x86_64
Alert Count                   35
First Seen                    2013-07-04 00:47:25 EDT
Last Seen                     2013-07-04 00:47:29 EDT
Local ID                      b914d0aa-693b-4fb8-9504-9bb4a336ab15

Raw Audit Messages
type=AVC msg=audit(1372913249.154:1601): avc:  denied  { read } for  pid=6095 comm="beam.smp" name="crash.log" dev="dm-1" ino=394775 scontext=system_u:system_r:rabbitmq_beam_t:s0 tcontext=system_u:object_r:var_log_t:s0 tclass=file


type=SYSCALL msg=audit(1372913249.154:1601): arch=x86_64 syscall=access success=no exit=EACCES a0=7fd6771c41a8 a1=4 a2=0 a3=0 items=0 ppid=5943 pid=6095 auid=4294967295 uid=992 gid=991 euid=992 suid=992 fsuid=992 egid=991 sgid=991 fsgid=991 ses=4294967295 tty=pts0 comm=beam.smp exe=/usr/lib64/erlang/erts-5.10.1/bin/beam.smp subj=system_u:system_r:rabbitmq_beam_t:s0 key=(null)

Hash: beam.smp,rabbitmq_beam_t,var_log_t,file,read

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.8-300.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-07-07 03:12:55 EDT

*** This bug has been marked as a duplicate of bug 981448 ***

Note You need to log in before you can comment on or make changes to this bug.