Bug 981485 - Install JBoss Enterprise Application Platform as a Service in Red Hat Enterprise Linux
Install JBoss Enterprise Application Platform as a Service in Red Hat Enterpr...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: GA
: ---
Assigned To: Lucas Costi
Matthew Casperson
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-04 18:46 EDT by Matthew Casperson
Modified: 2015-02-20 05:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Instance Name: Not Defined Build: CSProcessor Builder Version 1.7 Build Name: 11862, Installation Guide-6-2 Build Date: 18-12-2012 17:07:28
Last Closed: 2013-12-15 11:55:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Casperson 2013-07-04 18:46:12 EDT
The documentation states that the result is:

JBoss Enterprise Application Platform 6 starts automatically when the Red Hat Enterprise Linux reaches its default run-level

This is incorrect. After following the instructions, the EAP is installed as a service, but is not set to run at any runlevel.

To enable EAP to be started at the default runlevels, the following command needs to be run:

chkconfig jboss-as-standalone.sh on
Comment 1 Matthew Casperson 2013-07-04 18:49:55 EDT
Never mind - I was looking at the 6 docs, not 6.1.
Comment 2 Matthew Casperson 2013-07-04 18:52:07 EDT
Actually, on a second look, this bug is still accurate. Neither the 6.0 or 6.1 docs include the required command to enable EAP at the default runlevels.
Comment 4 Misty Stanley-Jones 2013-07-25 02:24:53 EDT
Fixed in revision 481853. This will be moved to ON_QA when the change is ready for review.
Comment 6 Pavel Janousek 2013-08-29 04:07:44 EDT
New issues:
- formatting (should be the same as previous boxes)
- has to be invoked via sudo as well (see previous boxes)
- typo "[root@host ~]#" -> "[user@host init.d]$"
- it isn't covered jboss-as-domain.sh (only jboss-as-standalone.sh is) - this fix should be made also to EAP-6.1.0 docs, because different space (branding)
- runlevel 3 isn't the only one where is will be started as is mentioned in sentence "The service will now be started when your server reaches run-level 3, and will be stopped when your server is shut down or restarted."
Comment 10 Lucas Costi 2013-10-23 01:19:44 EDT
>formatting (should be the same as previous boxes)
Fixed

>has to be invoked via sudo as well (see previous boxes)
Fixed 

>typo "[root@host ~]#" -> "[user@host init.d]$"
Fixed

>it isn't covered jboss-as-domain.sh (only jboss-as-standalone.sh is) - this fix should be made also to EAP-6.1.0 docs, because different space (branding)
I have moved the note to the top of the procedure, explaining the difference and steps for standalone vs. domain

>runlevel 3 isn't the only one where is will be started as is mentioned in sentence "The service will now be started when your server reaches run-level 3, and will be stopped when your server is shut down or restarted."
Automatic start and stopping of the service is implied, so I have removed that sentence altogether.

The above fixes have been made to topic 3758, revision 548482.

The changes will be reflected in the next document build, and the status will be changed to ON_QA when it is ready for review.
Comment 12 Pavel Janousek 2013-10-24 09:56:37 EDT
Fixed.

Note You need to log in before you can comment on or make changes to this bug.