Bug 981486 - Making an ISO works, but booting fails with dracut-initqueue errors and an emergency shell
Making an ISO works, but booting fails with dracut-initqueue errors and an em...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-04 18:52 EDT by cpg
Modified: 2013-07-06 20:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-06 20:30:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cpg 2013-07-04 18:52:51 EDT
Description of problem:

Booting an iso composed from the fedora-install-fedora.ks with mock and all that is necessary, according to dgilmore and others in the anaconda channel started failing after F19-RC3.

The error looks like this:

https://dl.dropboxusercontent.com/u/364883/Screenshots/dracut-initqueue-bails-to-shell.png

Version-Release number of selected component (if applicable):

F19

How reproducible:

100%

Steps to Reproduce:
1. build iso in a way that is close to the officially sanctioned way, with run_pungi
2. boot it
3.

Actual results:

It appears to be a dracut issue. The dracut-initqueue finds that dhclient is already running and it appears to freak out. However, this may be a red herring. After I got this, I could not see any recent changes in the dracut source code. I then built an ISO without network --foo --bar settings in the kickstart. The error for dhclient did not appear, yet dracut still dropped into the emergency shell.

This was working well in RC3. It started failing after I started fresh on a F19 install from the official release and a mirror of the official bits.

My goal is to tweak the ISO once it's working. But the process of composing the official bits (SOP in releng terms?) does not appear to be documented.

After a lot of prodding and learning, I got enough slivers of information to be able to reproduce nearly 100% of the steps for an official ISO. I used mock and pungi and mirrors that I keep local to my network. I was doing this on RC3 and it was working, but it's failing now on the official F19 bits.

Expected results:

Boot into the anaconda installer

Additional info:

I will bring in the sosreport.txt if that is what is needed (i will have to generate it again, because there was not easy way to get it at the time).

If there are other logs that would be useful to diagnose this, please state them and will bring them.
Comment 1 Harald Hoyer 2013-07-05 03:12:24 EDT
boot with "rd.debug" on the kernel command line

from the dracut shell, mount any partition by hand and copy over sosreport.txt.

The output of
# lsinitrd <initramfs.img>
is also helpful
Comment 2 cpg 2013-07-05 20:40:48 EDT
The lsinitrd comes out with the expected output (I assume you meant initrd.img ?).

I am having trouble getting the sosreport.txt out to a file from inside the VMware vm engine (and there is no network).

Now, things have regressed for me. Pungi is failing to build now for some reason. I get this error:

   no anaconda package in the repository

Even though in the output of pungi prior to bailing out with this error I see this:

(104/3924): anaconda-19.30.13-1.fc19.x86_64.rpm  | 2.0 MB  00:00:00

which indicates it was found just fine (and it's the exact same as in the official DVD).

I have gotten some other odd errors. Is this process usually so unreliable?

Also, and I was getting this before and shoudl have brought this up earlier, because it's extremely suspicious: I had to add an "everything" mirror, because without it, I was getting missing packages for firstboot and others.

Here is the thing: firstboot should not be needed. It is NOT in the official DVD, and people who claim to know (in the anaconda channel), said that "[firstboot] it's dead. replaced by initial-setup and gnome-initial-setup".

The kickstart file i am using is this: http://ur1.ca/ejlo2
with two exceptions, no updates and adding my local repos for

1) the official DVD (which should be ENOUGH!)
2) the local os mirror
3) the local everything mirror

So, what am I missing? Why can't I reproduce something close to the official bits, for tweaking??
Comment 3 cpg 2013-07-05 22:18:42 EDT
For the sake of future searchability, the original screenshot with the original issue contains the following text:

[ OK ] Reached target Paths.
[ OK ] Reached target Basic System.
dracut-initqueue[388]: dhclient(488) is already running - exiting.

dracut-initqueue[388]: This version of ISC DHCP is based on the release available
dracut-initqueue[388]: on ftp.isc.org.  Features have been added and other changes
dracut-initqueue[388]: have been made to the base software release in order to make
dracut-initqueue[388]: it work better with this distribution.
dracut-initqueue[388]: Please report for this software via the Red Hat Bugzilla site:
dracut-initqueue[388]: http://bugzilla.redhat.com
dracut-initqueue[388]: exiting.
dracut-initqueue[388]: Warning: Could not boot.
[ OK ] Started Show Plymouth Boot Screen.
[ OK ] Reached target Paths.
[ OK ] Reached target Basic System.
dracut-initqueue[388]: dhclient(488) is already running - exiting
dracut-initqueue[388]: This version of ISC DHCP is based on the release available
dracut-initqueue[388]: on ftp.isc.org.  Features have been added and other changes
dracut-initqueue[388]: have been made to the base software release in order to make
dracut-initqueue[388]: it work better with this distribution.
dracut-initqueue[388]: Please report for this software via the Red Hat Bugzilla site:
dracut-initqueue[388]: http://bugzilla.redhat.com
dracut-initqueue[388]: exiting.
dracut-initqueue[388]: Warning: Could not boot.
dracut-initqueue[388]: Warning: /dev/root does not exist
          Starting Emergency Shell...
Warning: /dev/root does not exist

Generating "/run/initramfs/sosreport.txt"

Entering emergency mode. Exit the shell to continue.
Type "journalctl" to view system logs.
You might want to save "/run/initramfs/sosreport.txt" to a USB stick or /boot
after mounting them and attach it to a bug report.

dracut:/#
Comment 4 cpg 2013-07-06 20:30:36 EDT
PEBKAC. Typo in the label caused this error -- not being able to find the root device. It just was not obvious how to track this!

Note You need to log in before you can comment on or make changes to this bug.