Bug 981503 - Octal device number is offered in libvirtError when virt-install guest with duplicate --host-device options.
Octal device number is offered in libvirtError when virt-install guest with d...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Martin Kletzander
Virtualization Bugs
:
Depends On: 967712
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-04 22:07 EDT by EricLee
Modified: 2013-11-21 04:04 EST (History)
13 users (show)

See Also:
Fixed In Version: libvirt-0.10.2-20.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 967712
Environment:
Last Closed: 2013-11-21 04:04:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Martin Kletzander 2013-07-10 10:59:38 EDT
Moving to POST:

http://post-office.corp.redhat.com/archives/rhvirt-patches/2013-July/msg00228.html
Comment 4 EricLee 2013-07-16 05:06:24 EDT
Verifying this bug in libvirt-0.10.2-20.el6:

# lsusb | grep RSA
Bus 006 Device 008: ID 15e1:2007 RSA RSA SecurID (R) Authenticator
Bus 002 Device 009: ID 058f:6387 Alcor Micro Corp. Flash Drive

# virt-install -n demo -r 1024 -f /var/lib/libvirt/images/demo.img -s 8 -l http://tree.englab.nay.redhat.com/pub/rhel/released/RHEL-6/6.3/Server/x86_64/os/ --host-device 006.008 --host-device 006.008 --debug
...
Tue, 16 Jul 2013 17:03:48 DEBUG    Removing /var/lib/libvirt/boot/virtinst-vmlinuz.Tm37AA
Tue, 16 Jul 2013 17:03:48 DEBUG    Removing /var/lib/libvirt/boot/virtinst-initrd.img.9BsRBy
Tue, 16 Jul 2013 17:03:48 ERROR    internal error Device 006:008 is already in use
Tue, 16 Jul 2013 17:03:48 DEBUG    Traceback (most recent call last):
  File "/usr/sbin/virt-install", line 629, in start_install
    noboot=options.noreboot)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 1223, in start_install
    noboot)
  File "/usr/lib/python2.6/site-packages/virtinst/Guest.py", line 1291, in _create_guest
    dom = self.conn.createLinux(start_xml or final_xml, 0)
  File "/usr/lib64/python2.6/site-packages/libvirt.py", line 2639, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: internal error Device 006:008 is already in use
Tue, 16 Jul 2013 17:03:48 DEBUG    Domain installation does not appear to have been successful.
If it was, you can restart your domain by running:
  virsh --connect qemu:///system start demo
otherwise, please restart your installation.
Domain installation does not appear to have been successful.
If it was, you can restart your domain by running:
  virsh --connect qemu:///system start demo
otherwise, please restart your installation.

"libvirtError: internal error Device 006:008 is already in use" is the expected result.

So setting VERIFIED.
Comment 6 errata-xmlrpc 2013-11-21 04:04:59 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1581.html

Note You need to log in before you can comment on or make changes to this bug.