Bug 981506 - transmission: preun scriptlet failure during fedup
transmission: preun scriptlet failure during fedup
Status: CLOSED DUPLICATE of bug 947627
Product: Fedora
Classification: Fedora
Component: transmission (Show other bugs)
17
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-04 22:13 EDT by tengel
Modified: 2013-07-17 02:27 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-17 02:25:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tengel 2013-07-04 22:13:15 EDT
Description of problem:

During a F17 -> F19 using 'fedup-cli --network 19', the cleanup (uninstall) of transmission-2.77-1.fc17.x86_64 fails with:

upgrade[776]: /var/tmp/rpm-tmp.ubCigN: line 1: fg: no job control
upgrade[776]: error: %preun(transmission-2.77-1.fc17.x86_64) scriptlet failed, exit status 1
upgrade[776]: Warning: fatal %preun scriptlet failure in transmission-2.77-1.fc17 (exit code 2)
upgrade[776]: error: transmission-2.77-1.fc17.x86_64: erase failed

After the upgrade we're left with the old and new RPMs installed; using rpm -e --noscripts was required to get it uninstalled from F19. The F19 RPMs all passed a rpm -qV and the app is working as expected, though.

Version-Release number of selected component (if applicable):

fedup-0.7.3-5.fc17.noarch
transmission-2.77-1.fc17.x86_64

How reproducible:

100% (well, once anyways :) )

Steps to Reproduce:
1. F17 -> yum install transmission
2. fedup-cli --reboot --network 19

Actual results:

F17 RPM left "installed" in RPMDB

Expected results:

F17 RPM not in RPMDB

Additional info:

This was the only RPM that had a failure of this sort (the only other listed failure in the log is unrelated to RPM)
Comment 1 Conrad Meyer 2013-07-17 02:25:26 EDT

*** This bug has been marked as a duplicate of bug 947627 ***
Comment 2 Conrad Meyer 2013-07-17 02:27:56 EDT
(To clarify: Fedup doesn't do any magic on top of yum, other than fetching the packages ahead of time. Yum doesn't do any magic here except the equivalent of "rpm -Uvh transmission-foo.fc18.bar.rpm". RPM is failing here because the earlier version of transmission is broken such that it cannot be uninstalled. See the other bug for more details on that.)

Note You need to log in before you can comment on or make changes to this bug.