Bug 981532 - Host call trace happened when try to boot multi guest
Host call trace happened when try to boot multi guest
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.5
x86_64 Unspecified
medium Severity high
: rc
: ---
Assigned To: Luiz Capitulino
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-05 01:24 EDT by yunpingzheng
Modified: 2014-03-03 19:13 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-18 08:29:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yunpingzheng 2013-07-05 01:24:45 EDT
Description of problem:
boot multi guest on the host, the host always all trace

BUG: scheduling while atomic: qemu-kvm/19874/0x10000200
Modules linked in: xt_physdev nfs lockd fscache auth_rpcgss nfs_acl sunrpc cpufreq_ondemand acpi_cpufreq freq_table mperf bridge stp llc ipv6 openvswitch vhost_net macvtap macvlan tun kvm_intel kvm dcdbas microcode serio_raw i2c_i801 sg lpc_ich mfd_core shpchp snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_timer snd soundcore snd_page_alloc e1000e ext4 mbcache jbd2 sr_mod cdrom sd_mod crc_t10dif ahci i915 drm_kms_helper drm i2c_algo_bit i2c_core video output dm_mirror dm_region_hash dm_log dm_mod [last unloaded: nf_conntrack]
Pid: 19874, comm: qemu-kvm Not tainted 2.6.32-392.el6.x86_64 #1
Call Trace:
 [<ffffffff8105ad36>] ? __schedule_bug+0x66/0x70
 [<ffffffff8151a400>] ? thread_return+0x64e/0x76e
 [<ffffffff810098e2>] ? __switch_to+0x2c2/0x320
 [<ffffffff81056a81>] ? update_curr+0xe1/0x1f0
 [<ffffffff8106504a>] ? __cond_resched+0x2a/0x40
 [<ffffffff8151a7c0>] ? _cond_resched+0x30/0x40
 [<ffffffff811683dd>] ? kmem_cache_alloc_node+0xdd/0x1d0
 [<ffffffff8100bd6e>] ? reschedule_interrupt+0xe/0x20
 [<ffffffff81443a1f>] ? __alloc_skb+0x4f/0x190
 [<ffffffff814b6181>] ? inet_get_link_af_size+0x1/0x20
 [<ffffffff81461321>] ? rtmsg_ifinfo+0x121/0x250
 [<ffffffff81461471>] ? rtnetlink_event+0x21/0x70
 [<ffffffff8151f8f5>] ? notifier_call_chain+0x55/0x80
 [<ffffffff8109d356>] ? raw_notifier_call_chain+0x16/0x20
 [<ffffffff8144f93b>] ? call_netdevice_notifiers+0x1b/0x20
 [<ffffffff81450256>] ? netdev_features_change+0x16/0x20
 [<ffffffffa0405da0>] ? br_features_recompute+0x70/0x80 [bridge]
 [<ffffffffa0405e08>] ? br_del_if+0x58/0x70 [bridge]
 [<ffffffffa040746b>] ? br_device_event+0xfb/0x1b0 [bridge]
 [<ffffffff8151f8f5>] ? notifier_call_chain+0x55/0x80
 [<ffffffff8109d356>] ? raw_notifier_call_chain+0x16/0x20
 [<ffffffff8144f93b>] ? call_netdevice_notifiers+0x1b/0x20
 [<ffffffff814507d4>] ? rollback_registered_many+0x154/0x280
 [<ffffffff814509a8>] ? rollback_registered+0x38/0x50
 [<ffffffff81450a18>] ? unregister_netdevice_queue+0x58/0xa0
 [<ffffffff81450a70>] ? unregister_netdevice+0x10/0x20
 [<ffffffffa0369768>] ? tun_chr_close+0xd8/0x100 [tun]
 [<ffffffff811841c5>] ? __fput+0xf5/0x210
 [<ffffffff81184305>] ? fput+0x25/0x30
 [<ffffffff8117f62d>] ? filp_close+0x5d/0x90
 [<ffffffff8117f705>] ? sys_close+0xa5/0x100
 [<ffffffff8100b072>] ? system_call_fastpath+0x16/0x1b
switch: port 20(tap27) entering disabled state

Version-Release number of selected component (if applicable):
kernel-2.6.32-392.el6.x86_64
qemu-kvm-rhev-tools-0.12.1.2-2.377.el6.x86_64
guest rhel.7.0

How reproducible:
100%

Steps to Reproduce:
1. boot the guest via the following script.
for j in $(seq 10)
do
for i in $(seq 3)
do
/usr/libexec/qemu-kvm \ 
-M pc \
-name vm$i \
-drive file=$DISK_IMAGE,index=0,if=none,id=drive-virtio-disk1,media=disk,cache=none,snapshot=on,format=qcow2,aio=native \
-device virtio-blk-pci,bus=pci.0,addr=0x5,drive=drive-virtio-disk1,id=virtio-disk1 \
-device virtio-net-pci,netdev=idKF4XM$i,mac=9a:9b:68:24:99:$i$i,id=ndev00idKF4XM$i  \
-netdev tap,id=idKF4XM$i,vhost=on,script=qemu-ifup-switch \
-smp 4,cores=2,threads=1,sockets=4,maxcpus=20 \
-m 4096 \
-vnc :$i \
-monitor stdio \
-boot order=cdn,once=c,menu=on   &
done
done 

2.
3.

Actual results:
host call trace

Expected results:
The three guest can boot successfully first time, the other times the qemu should report error like vnc port have been used. should not call trace

Additional info:
cpuinfo:
processor	: 7
vendor_id	: GenuineIntel
cpu family	: 6
model		: 42
model name	: Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz
stepping	: 7
cpu MHz		: 2000.000
cache size	: 8192 KB
physical id	: 0
siblings	: 8
core id		: 3
cpu cores	: 4
apicid		: 7
initial apicid	: 7
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm ida epb xsaveopt pln pts dts tpr_shadow vnmi flexpriority ept vpid
bogomips	: 6784.15
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
Comment 2 juzhang 2013-07-05 03:01:44 EDT
Hi Yunping,

Does same issue happens on rhel7.0 host?
Comment 3 Qunfang Zhang 2013-07-05 03:11:20 EDT
Hi, yunzheng
(1) Seems the p-cpu number is 8? And what is the host total memory?
(2) Does this happen with rhel6 guest? as we will not test rhel7.0 guest on rhel6.5 host.
Comment 4 Suqin Huang 2013-07-05 03:17:13 EDT
host overcommit, does host hang or just print call trace info.
Comment 5 yunpingzheng 2013-07-08 06:11:26 EDT
hi shuang:
not overcommit, just call trace
Comment 6 Ademar Reis 2013-07-22 17:26:40 EDT
(In reply to Qunfang Zhang from comment #3)
> Hi, yunzheng
> (1) Seems the p-cpu number is 8? And what is the host total memory?
> (2) Does this happen with rhel6 guest? as we will not test rhel7.0 guest on
> rhel6.5 host.

^^^^ NEEDINFO(reporter)
Comment 7 yunpingzheng 2013-07-22 22:37:09 EDT
1. host memory is 8G
2. when using rhel6 guest, can reproduce this issue. maybe, the issue is caused by bridge.
Comment 8 Luiz Capitulino 2013-09-17 13:26:41 EDT
I have few questions:

- How reproducible is it?

- What's the network setup in the host?

- I see this is a bit old, can you try with a more recent kernel?
Comment 9 yunpingzheng 2013-09-18 06:24:50 EDT
when i run this test on the latest kernel and qemu (kernel-2.6.32-419.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.404.el6.x86_64) can not reproduce this issue.
Comment 10 Luiz Capitulino 2013-09-18 08:29:17 EDT
Closing as WORKSFORME based on comment 9.

Note You need to log in before you can comment on or make changes to this bug.