Bug 98157 - up2date crash leaving box in inconsistent state
Summary: up2date crash leaving box in inconsistent state
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: i686 Linux
medium
high
Target Milestone: ---
: ---
Assignee: Adrian Likins
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-27 03:28 UTC by Rob Gerth
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-04 18:38:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rob Gerth 2003-06-27 03:28:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Ran up2date on a vanilla RH9 box. Download/repackaging ok, but when trying to 
update glibc, up2date got into a fatal error as it couldn't access (locked?) 
original glibc.
End result is an inoperable box due to version conflicts (specifically 
with /lib/i686/lptreadths...).

Dunno what else to tell you: I was using the graphical up2date under
kde; nothing 'else' running.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try :-)


Expected Results:  Unless the box crashes, up2date should never ever leave the 
OS in an
inconsistent state. Seems that up2date blindly starts updating packages 
without checking it can follow through. Especially essential for core packages 
such as glibc and friends

Additional info:


Note You need to log in before you can comment on or make changes to this bug.