Bug 981585 - Session key on remote WSRP portlets not unique
Session key on remote WSRP portlets not unique
Status: CLOSED WONTFIX
Product: JBoss Enterprise Portal Platform 5
Classification: JBoss
Component: Portal (Show other bugs)
5.1.1.GA
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Heute
:
Depends On:
Blocks: 983898
  Show dependency treegraph
 
Reported: 2013-07-05 04:05 EDT by Adam Kovari
Modified: 2015-08-31 23:04 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 983898 (view as bug list)
Environment:
EPP 5.1.1
Last Closed: 2014-09-26 03:42:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker GTNWSRP-369 Major Resolved Portlet sessions are not properly scoped on consumer 2014-07-24 05:58:36 EDT

  None (edit)
Description Adam Kovari 2013-07-05 04:05:09 EDT
Description of problem:
We have created a remote portlet (wsrp) which saves a value as session
attribute:

  request.getPortletSession().setAttribute("inputValue", inputValue)

and retrieves it again

  String inputValue = (String)
  request.getPortletSession().getAttribute("inputValue");

The problem is, that if we are placing the portlet twice one the same
page, both portlets are showing the same inputValue. So the
setAttribute() and getAttribute() method is not unique for the portlet
instance.

Version-Release number of selected component (if applicable):
EPP 5.1.1

How reproducible:
Always

Steps to Reproduce:
1. See description

Actual results:
Portlet Session attributes shared accross same portlets on one page

Expected results:
Portlet Session attributes not shared accross same portlets on one page

Additional info:

Note You need to log in before you can comment on or make changes to this bug.