Bug 981596 - Disable F2 key when starting installing RHEV-H.
Summary: Disable F2 key when starting installing RHEV-H.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node
Version: 6.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Fabian Deutsch
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-05 08:44 UTC by cshao
Modified: 2014-01-21 19:44 UTC (History)
12 users (show)

Fixed In Version: ovirt-node-3.0.1-2.el6
Doc Type: Bug Fix
Doc Text:
Previously the 'progress page' allowed pressing the F2 key to drop to shell. If the F2 key was pressed repeatedly when starting the hypervisor installation, the action could cause the hypervisor installation to fail. The F2 key is now disabled when starting the hypervisor installation, after the installation is finished, the F2 key is enabled again.
Clone Of:
Environment:
Last Closed: 2014-01-21 19:44:51 UTC
Target Upstream Version:


Attachments (Terms of Use)
failed (73.84 KB, image/png)
2013-07-05 08:44 UTC, cshao
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0033 0 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2014-01-22 00:14:30 UTC
oVirt gerrit 16525 0 None None None Never

Description cshao 2013-07-05 08:44:22 UTC
Created attachment 769139 [details]
failed

Description of problem:
Disable F2 key when starting installing RHEV-H. it may lead to the failure, just as 6.4 did. 

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20130222.0.auto1707.el6.iso
ovirt-node-3.0.0-1.999.20130701111251git99aadc6.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Boot from pxe and install RHEV-H 6.5.
2. Enter installing RHEV-H page.
3. Press F2 key repeated.

Actual results:
Failed to install RHEV-H sometimes.

Expected results:
Disable F2 key when starting installing RHEV-H, just as 6.4 did. 

Additional info:

Comment 2 haiyang,dong 2013-07-09 01:46:25 UTC
upstream patch:
http://gerrit.ovirt.org/#/c/16525/

Disabled F2 key when starting installing RHEV-H, after finished
installing RHEV-H, and enabled F2 key again in progress page

Comment 3 Mike Burns 2013-09-26 19:36:21 UTC
Fixed in ovirt-node-3.0.0 release upstream

Comment 5 cshao 2013-10-24 11:12:05 UTC
rhev-hypervisor6-6.5-20131017.0
ovirt-node-3.0.1-4.el6.noarch

F2 key and ESC key are disabled when starting installing RHEV-H.

So the bug is fixed, change bug status to VERIFIED.

Comment 7 Cheryn Tan 2013-11-08 00:28:45 UTC
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.

Comment 9 errata-xmlrpc 2014-01-21 19:44:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html


Note You need to log in before you can comment on or make changes to this bug.