Bug 981614 - Should replan which format of hostname is valid
Summary: Should replan which format of hostname is valid
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node
Version: 6.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Ryan Barry
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-05 09:40 UTC by wanghui
Modified: 2014-01-21 19:45 UTC (History)
13 users (show)

Fixed In Version: ovirt-node-3.0.1-2.el6
Doc Type: Bug Fix
Doc Text:
It wasn't apparent which format of hostname is valid. The hostname as FQDN format was not accepted so clarification was needed. There is now added validation (to comply with RFC1035) to check the length of each field, as well as the entire hostname to make sure it's not too long
Clone Of:
Environment:
Last Closed: 2014-01-21 19:45:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0033 0 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2014-01-22 00:14:30 UTC
oVirt gerrit 15583 0 None None None Never

Description wanghui 2013-07-05 09:40:34 UTC
Description of problem:
Should replan which format of hostname is valid. Because now we have tested some of the hostname as FQDN format is not accept. So we need to clarify which format is valid.

Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.5-20130222.0.auto1711.el6
ovirt-node-3.0.0-1.999.20130702120359git0015156.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1. Clean install rhev-hypervisor6-6.5-20130222.0.auto1711.el6.
2. Enter hostname like the follows.
   local                             Pass
   123                               Fail
   123.local                         Fail
   123.local.com                     Fail
   local.com                         Pass
   localhost.localdomain             Pass
   1test.local.com                   Fail
   1.test.local.com                  Pass
   10.66.6.1                         Pass
   2001::1                           Pass
   test-123                          Pass
   Test-1.com                        Pass

Actual results:
The result is as step2.

Expected results:
Should be replanning which format of hostname is valid.

Additional info:
And there is a related bug(1) to clarify which format is valid. And some of them are not allowed in rhevh6.5 now.
[1] https://bugzilla.redhat.com/show_bug.cgi?id=720956

Comment 6 wanghui 2013-10-10 07:22:37 UTC
Test version:
rhev-hypervisor6-6.5-20130930.0.auto665.el6.iso
ovirt-node-3.0.1-3.el6.noarch

Test steps and results:
1. Clean install rhev-hypervisor6-6.5-20130930.0.auto665.el6.iso.
2. Enter hostname like the follows.
   local                             Pass
   123                               Pass
   123.local                         Pass
   123.local.com                     Pass
   local.com                         Pass
   localhost.localdomain             Pass
   1test.local.com                   Pass
   1.test.local.com                  Pass
   10.66.6.1                         Pass
   2001::1                           Pass
   test-123                          Pass
   Test-1.com                        Pass
3. Enter hostname with other symbol as follows.
   a[`!@#$%^&*()_+[]{}|\;:'"<,>?/]   Fail

So the bug is fixed in rhev-hypervisor6-6.5-20130930.0.auto665.el6.iso. I will recheck it in official build.

Comment 7 wanghui 2013-10-18 08:42:32 UTC
Test version:
rhev-hypervisor6-6.5-20131017.0.iso
ovirt-node-3.0.1-4.el6.noarch

Test steps and results:
1. Clean install rhev-hypervisor6-6.5-20131017.0.iso.
2. Enter hostname like the follows.
   local                             Pass
   123                               Pass
   123.local                         Pass
   123.local.com                     Pass
   local.com                         Pass
   localhost.localdomain             Pass
   1test.local.com                   Pass
   1.test.local.com                  Pass
   10.66.6.1                         Pass
   2001::1                           Pass
   test-123                          Pass
   Test-1.com                        Pass
3. Enter hostname with other symbol as follows.
   a[`!@#$%^&*()_+[]{}|\;:'"<,>?/]   Fail

So the bug is fixed in rhev-hypervisor6-6.5-20131017.0.iso. So change the bugs's status from ON_QA to VERIFIED.

Comment 9 Cheryn Tan 2013-11-08 00:24:55 UTC
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.

Comment 11 errata-xmlrpc 2014-01-21 19:45:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html


Note You need to log in before you can comment on or make changes to this bug.