Bug 981621 - SELinux is preventing /opt/google/chrome/chrome from append, open access on the file /home/vadim/libpeerconnection.log.
SELinux is preventing /opt/google/chrome/chrome from append, open access on t...
Status: CLOSED DUPLICATE of bug 960792
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2013-07-05 05:57 EDT by Vadim
Modified: 2013-07-10 12:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-07-10 12:51:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Vadim 2013-07-05 05:57:08 EDT
Description of problem:
Chrome start
SELinux is preventing /opt/google/chrome/chrome from append, open access on the file /home/vadim/libpeerconnection.log.

*****  Plugin restorecon (99.5 confidence) suggests  *************************

If you want to fix the label. 
/home/vadim/libpeerconnection.log default label should be user_home_t.
Then you can run restorecon.
# /sbin/restorecon -v /home/vadim/libpeerconnection.log

*****  Plugin catchall (1.49 confidence) suggests  ***************************

If you believe that chrome should be allowed append open access on the libpeerconnection.log file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
allow this access for now by executing:
# grep chrome /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c
Target Context                unconfined_u:object_r:user_home_dir_t:s0
Target Objects                /home/vadim/libpeerconnection.log [ file ]
Source                        chrome
Source Path                   /opt/google/chrome/chrome
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           google-chrome-stable-28.0.1500.71-209842.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-57.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.8-300.fc19.x86_64 #1 SMP Thu
                              Jun 27 19:24:23 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-07-05 10:23:39 IST
Last Seen                     2013-07-05 10:23:39 IST
Local ID                      6b51ba81-d306-4413-8f42-2f42bc800155

Raw Audit Messages
type=AVC msg=audit(1373016219.552:1122): avc:  denied  { append open } for  pid=11989 comm="chrome" path="/home/vadim/libpeerconnection.log" dev="dm-1" ino=1707025 scontext=unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=file

type=SYSCALL msg=audit(1373016219.552:1122): arch=x86_64 syscall=open success=no exit=EACCES a0=7fd486ce6588 a1=441 a2=1b6 a3=ffffe000 items=0 ppid=0 pid=11989 auid=7001 uid=7001 gid=7001 euid=7001 suid=7001 fsuid=7001 egid=7001 sgid=7001 fsgid=7001 ses=3 tty=(none) comm=chrome exe=/opt/google/chrome/chrome subj=unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c0.c1023 key=(null)

Hash: chrome,chrome_sandbox_t,user_home_dir_t,file,append,open

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.8-300.fc19.x86_64
type:           libreport

Potential duplicate: bug 975393
Comment 1 Daniel Walsh 2013-07-10 12:51:20 EDT

*** This bug has been marked as a duplicate of bug 960792 ***

Note You need to log in before you can comment on or make changes to this bug.