Bug 981627 - Can not boot kernel 3.9.8-100.fc17.x86_64
Can not boot kernel 3.9.8-100.fc17.x86_64
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-05 06:31 EDT by Herald van der Breggen
Modified: 2013-07-31 22:30 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-31 22:30:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (908.45 KB, image/jpeg)
2013-07-05 06:31 EDT, Herald van der Breggen
no flags Details

  None (edit)
Description Herald van der Breggen 2013-07-05 06:31:41 EDT
Created attachment 769204 [details]
screenshot

Description of problem:
kernel 3.9.8-100.fc17.x86_64 causes kernel panic when booting (older versions, 3.8.13-100.fc17.x86_64 and before, still work)

Version-Release number of selected component (if applicable):
3.9.8-100.fc17.x86_64

How reproducible:
boot the kernel
My hardware: Asus zenbook UX31E

Steps to Reproduce:
1. boot
2.
3.

Actual results:
kernel panic - not syncing: VFS: Unable to mount rootfs on unknown-block(0,0)
see also screenshot (attached)

Expected results:
booting normally

Additional info:
I tried upgrading with Fedup, but selecting in grub the 'System Upgrade (fedup)' entry, the same boot problem occurs.
Comment 1 Herald van der Breggen 2013-07-06 13:56:13 EDT
I have been able to upgrade from fc17 to fc19 using fedup. After doing again a "yum update" and "fedup-cli --network 19" I was able to run to installer.

However, I still have problems running the 3.9 kernels (both the fc19 and the fc17 version). I don't see the kernel panic anymore, instead the boot process stops when the logo is shown (so before starting the graphical mode). Then nothing happens. I guess I need to create a new bug report for that, related to Fedora 19. I'll do that later.

Currently I run 3.8 kernel from fc17 on Fedora 19. That works.

It crossed my mind that kernel 3.9 has some new SSD related updates and this laptop has SSD.
Comment 2 Herald van der Breggen 2013-07-06 16:12:18 EDT
created bug report 981898, related to Fedora 19.
Comment 3 Fedora End Of Life 2013-07-31 22:30:35 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.