Bug 981646 - SELinux is preventing /usr/bin/evince-thumbnailer from 'unlink' accesses on the file .mate_desktop_thumbnail.TX91YW.
SELinux is preventing /usr/bin/evince-thumbnailer from 'unlink' accesses on t...
Status: CLOSED DUPLICATE of bug 961373
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:66a7325803ac468b7c4fdf8dae4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-05 07:54 EDT by klaus
Modified: 2013-10-25 05:29 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-25 05:29:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description klaus 2013-07-05 07:54:29 EDT
Description of problem:
No idea what's going on here, definitely it does not seem ok, that evince-thumbnailer should simply allowed to unlink
randomly.
SELinux is preventing /usr/bin/evince-thumbnailer from 'unlink' accesses on the file .mate_desktop_thumbnail.TX91YW.

*****  Plugin catchall (100. confidence) suggests  ***************************

If sie denken, dass es evince-thumbnailer standardmässig erlaubt sein sollte, unlink Zugriff auf .mate_desktop_thumbnail.TX91YW file zu erhalten.
Then sie sollten dies als Fehler melden.
Um diesen Zugriff zu erlauben, können Sie ein lokales Richtlinien-Modul erstellen.
Do
zugriff jetzt erlauben, indem Sie die nachfolgenden Befehle ausführen:
# grep evince-thumbnai /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:user_tmp_t:s0
Target Objects                .mate_desktop_thumbnail.TX91YW [ file ]
Source                        evince-thumbnai
Source Path                   /usr/bin/evince-thumbnailer
Port                          <Unbekannt>
Host                          (removed)
Source RPM Packages           evince-3.8.2-1.fc19.i686
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-52.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.5-301.fc19.i686.PAE #1 SMP Tue
                              Jun 11 19:46:44 UTC 2013 i686 i686
Alert Count                   2
First Seen                    2013-06-19 12:30:34 CEST
Last Seen                     2013-06-19 12:30:38 CEST
Local ID                      67071433-5e8d-488a-aa1e-57a92cd51e9a

Raw Audit Messages
type=AVC msg=audit(1371637838.566:572): avc:  denied  { unlink } for  pid=10968 comm="evince-thumbnai" name=".mate_desktop_thumbnail.TX91YW" dev="tmpfs" ino=743387 scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_tmp_t:s0 tclass=file


type=SYSCALL msg=audit(1371637838.566:572): arch=i386 syscall=unlink success=no exit=EACCES a0=9535b28 a1=0 a2=4aea8000 a3=0 items=0 ppid=1432 pid=10968 auid=1000 uid=1000 gid=0 euid=1000 suid=1000 fsuid=1000 egid=0 sgid=0 fsgid=0 ses=1 tty=(none) comm=evince-thumbnai exe=/usr/bin/evince-thumbnailer subj=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 key=(null)

Hash: evince-thumbnai,thumb_t,user_tmp_t,file,unlink

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.6-301.fc19.i686.PAE
type:           libreport

Potential duplicate: bug 961373
Comment 1 Wolfgang Ulbrich 2013-07-08 08:18:42 EDT
Seems you're using MATE-Desktop?
You can use mate-document-viewer (fork of evience) which provides better desktop integration for MATE.
Comment 2 Daniel Walsh 2013-07-08 14:38:21 EDT
Where is .mate_desktop_thumbnail.TX91YW. located and who created it?
Comment 3 Wolfgang Ulbrich 2013-07-08 15:03:37 EDT
I don't see that file in my user or root directory, but i don't use evince.
Maybe evince-thumbnailer in this case.
I think we need some user interaction.
Comment 4 Lukas Vrabec 2013-10-25 05:29:17 EDT

*** This bug has been marked as a duplicate of bug 961373 ***

Note You need to log in before you can comment on or make changes to this bug.