Bug 981649 - Import feature allows to import the same workspace more times.
Import feature allows to import the same workspace more times.
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: BAM (Show other bugs)
6.0.0
Unspecified Unspecified
low Severity low
: ER4
: 6.0.0
Assigned To: Jan
Jan Hrcek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-05 07:57 EDT by Marek Baluch
Modified: 2014-08-06 16:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:09:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Exported workspace which may be used for reproduction. (10.81 KB, application/zip)
2013-07-05 07:57 EDT, Marek Baluch
no flags Details

  None (edit)
Description Marek Baluch 2013-07-05 07:57:51 EDT
Created attachment 769228 [details]
Exported workspace which may be used for reproduction.

Description of problem:

It is possible to import one exported workspace more then once. I presume this is not intended behaviour as duplicating a workspace adds the prefix "Copy of" to the workspace name.

How to reproduce:
1) import the attached workspace multiple times
Comment 1 Jan 2013-09-06 06:22:18 EDT
The fact that "Copy of" is added to the workspace name is NOT due to the action of importing the workspace, but to the fact that the attached exported workspace has the name "Copy of Showcase". So in very probably you exported a duplicate of the Showcase workspace (which caused some confusion on my part when trying to establish the origin ;D ).
Comment 2 Jan 2013-09-09 12:02:11 EDT
A workaround has been implemented in the following commits:

https://github.com/droolsjbpm/dashboard-builder/commit/2bde36a89
https://github.com/droolsjbpm/dashboard-builder/commit/68f4d5be9

When importing workspaces with already existing names, a reasonable attempt to give a unique name to the newly imported workspace is made by appending "(x)" to its original name (with x reprensenting an integer).
Comment 6 Jan Hrcek 2013-10-18 02:33:15 EDT
Ok, verified with BPMS 6.0.0 ER4

Note You need to log in before you can comment on or make changes to this bug.