Bug 981657 - [abrt] WARNING: at lib/list_debug.c:59 __list_del_entry+0xa1/0xd0()
[abrt] WARNING: at lib/list_debug.c:59 __list_del_entry+0xa1/0xd0()
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:aadfd272e124e3ea348301a9b4b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-05 08:23 EDT by Mateusz Marzantowicz
Modified: 2013-09-18 17:40 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-18 17:40:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (76.07 KB, text/plain)
2013-07-05 08:23 EDT, Mateusz Marzantowicz
no flags Details

  None (edit)
Description Mateusz Marzantowicz 2013-07-05 08:23:04 EDT
Description of problem:
Restart qemu/kvm guest with virtio net driver (other drivers do not trigger this bug).

Additional info:
reporter:       libreport-2.1.5
WARNING: at lib/list_debug.c:59 __list_del_entry+0xa1/0xd0()
Hardware name: XPS 8300  
list_del corruption. prev->next should be ffff8802012f0120, but was           (null)
Modules linked in: fuse vhost_net macvtap macvlan ip6table_filter ip6_tables ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat_ipv4 nf_nat nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack xt_CHECKSUM iptable_mangle tun bnep bluetooth rfkill bridge stp llc snd_hda_codec_ca0110 snd_hda_codec_hdmi snd_hda_codec_realtek mperf snd_hda_intel coretemp snd_hda_codec kvm_intel snd_hwdep snd_seq snd_seq_device snd_pcm kvm iTCO_wdt snd_page_alloc iTCO_vendor_support snd_timer broadcom snd lpc_ich tg3 mei shpchp dcdbas soundcore i2c_i801 microcode ptp pps_core usblp mfd_core serio_raw uinput binfmt_misc dm_crypt usb_storage raid1 radeon i2c_algo_bit drm_kms_helper crc32_pclmul ttm crc32c_intel drm ghash_clmulni_intel i2c_core
Pid: 1338, comm: qemu-system-x86 Not tainted 3.9.9-301.fc19.x86_64 #1
Call Trace:
 [<ffffffff81306e00>] ? __list_del_entry+0x70/0xd0
 [<ffffffff8105cc56>] warn_slowpath_common+0x66/0x80
 [<ffffffff8105ccbc>] warn_slowpath_fmt+0x4c/0x50
 [<ffffffff810f3fa0>] ? call_rcu_bh+0x20/0x20
 [<ffffffff81306e31>] __list_del_entry+0xa1/0xd0
 [<ffffffff81306e6d>] list_del+0xd/0x30
 [<ffffffff81080eb6>] remove_wait_queue+0x26/0x40
 [<ffffffffa0468772>] vhost_vring_ioctl+0x4d2/0x5b0 [vhost_net]
 [<ffffffffa04679a0>] ? vhost_work_flush+0xe0/0x110 [vhost_net]
 [<ffffffffa046b44e>] vhost_net_ioctl+0x2ee/0x650 [vhost_net]
 [<ffffffffa025fcf2>] ? kvm_vm_ioctl+0x1d2/0x590 [kvm]
 [<ffffffff812957a1>] ? selinux_file_alloc_security+0x41/0x70
 [<ffffffff811ab495>] do_vfs_ioctl+0x305/0x520
 [<ffffffff8129495e>] ? file_has_perm+0x8e/0xa0
 [<ffffffff811ab731>] sys_ioctl+0x81/0xa0
 [<ffffffff8164f319>] system_call_fastpath+0x16/0x1b
Comment 1 Mateusz Marzantowicz 2013-07-05 08:23:09 EDT
Created attachment 769233 [details]
File: dmesg
Comment 2 Josh Boyer 2013-09-18 16:50:07 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 3 Brad Hubbard 2013-09-18 17:31:55 EDT
Haven't seen this personally for quite some time now.
Comment 4 Josh Boyer 2013-09-18 17:40:16 EDT
Thanks for letting us know.

Note You need to log in before you can comment on or make changes to this bug.