Bug 981659 - SELinux is preventing /usr/bin/python2.7 from 'search' accesses on the directory /home.
SELinux is preventing /usr/bin/python2.7 from 'search' accesses on the direct...
Status: CLOSED DUPLICATE of bug 909526
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:c77a17dc556765ece780a4d17e3...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-05 08:28 EDT by sheepdestroyer
Modified: 2013-07-10 19:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-10 19:03:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sheepdestroyer 2013-07-05 08:28:48 EDT
Description of problem:
SELinux is preventing /usr/bin/python2.7 from 'search' accesses on the directory /home.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that python2.7 should be allowed search access on the home directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep firewalld /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:firewalld_t:s0
Target Context                system_u:object_r:home_root_t:s0
Target Objects                /home [ dir ]
Source                        firewalld
Source Path                   /usr/bin/python2.7
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           python-2.7.5-1.fc19.x86_64
Target RPM Packages           filesystem-3.2-12.fc19.x86_64
Policy RPM                    selinux-policy-3.12.1-57.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.10.0 #1 SMP Mon Jul 1 11:01:23
                              JST 2013 x86_64 x86_64
Alert Count                   13
First Seen                    2013-06-27 13:48:57 JST
Last Seen                     2013-07-05 00:24:12 JST
Local ID                      59b208aa-8abc-4f04-ab8a-0c624eecdaa9

Raw Audit Messages
type=AVC msg=audit(1372951452.270:26): avc:  denied  { search } for  pid=390 comm="firewalld" name="home" dev="sda7" ino=623 scontext=system_u:system_r:firewalld_t:s0 tcontext=system_u:object_r:home_root_t:s0 tclass=dir


type=SYSCALL msg=audit(1372951452.270:26): arch=x86_64 syscall=stat success=no exit=EACCES a0=1318cf0 a1=7fff7759fe00 a2=7fff7759fe00 a3=0 items=0 ppid=1 pid=390 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=firewalld exe=/usr/bin/python2.7 subj=system_u:system_r:firewalld_t:s0 key=(null)

Hash: firewalld,firewalld_t,home_root_t,dir,search

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.10.0
type:           libreport

Potential duplicate: bug 909526
Comment 1 Daniel Walsh 2013-07-10 19:03:36 EDT

*** This bug has been marked as a duplicate of bug 909526 ***

Note You need to log in before you can comment on or make changes to this bug.