Bug 981660 - Hide menu bar by default
Hide menu bar by default
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Horak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-05 08:29 EDT by Allan Day
Modified: 2013-08-28 06:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-26 10:06:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 896887 None None None Never

  None (edit)
Description Allan Day 2013-07-05 08:29:54 EDT
Firefox provides the option to hide the menu bar and move its menu items to a single menu that is situated next to the tab bar. Right now this is disabled by default in Fedora.

All the browsers nowadays try to reduce the vertical footprint of their chrome. This gives maximum space to web pages. It is why Chrome has a button menu instead of a menu bar, and why Firefox on Windows uses a single button attached to the top of the window.

Hiding the menu bar in Fedora would have the same effect - it would give more room to web pages, would look nicer, and would actually be easier to use (see how other GNOME applications are moving away from menu bars using a similar approach).

I suspect that the reason Firefox doesn't hide the menu bar by default under Linux is because Ubuntu relocates the menubar to the top panel under Unity. Since that isn't possible in GNOME 3, this change seems like a reasonable adjustment.
Comment 1 Martin Stransky 2013-07-15 07:46:01 EDT
This change is requested only for Rawhide (Fedora 21), right? 

I guess the hidden menu bar it primary aimed for gnome-shell, but have you tested this style with other WM? This change should not break the other desktops shipped in Fedora.

Also Jan told me there was some difference in style between Windows and Linux when the menu bar is hidden, but he's on PTO this week.
Comment 2 Alberto Ruiz 2013-07-15 12:57:32 EDT
I was partially involved with Unity integration, Canonical is more than happy to modify the FF package to integrate it nicely, so they don't really care whether the menubar is hidden or not from the default package, if they don't care we shouldn't care either.

The hidden menu bar is not just a GNOME Shell matter I'd say it should be the preferred way in any desktop (as it is in Windows and Mac). The main issue with it is vertical pixels being wasted in a world where most screens are wide, in a 1280x800 screen, those 80 pixels do make a difference no matter what desktop you are using.
Comment 3 Jan Horak 2013-07-23 01:46:10 EDT
We're going to track it also on upstream:
https://bugzilla.mozilla.org/show_bug.cgi?id=896887
Comment 4 Allan Day 2013-07-23 06:06:25 EDT
(In reply to Martin Stransky from comment #1)
> This change is requested only for Rawhide (Fedora 21), right? 

No, we're targetting F20.
Comment 5 Jan Horak 2013-08-26 10:06:37 EDT
This bug will be fixed by Firefox UX release (project australis). See upstream bug for details.
Comment 6 Alberto Ruiz 2013-08-26 10:12:43 EDT
\o/

Good job guys!
Comment 7 Allan Day 2013-08-28 06:05:19 EDT
Excellent news! I'm excited about this.

Note You need to log in before you can comment on or make changes to this bug.