Bug 981695 - systemd configuration for quantum-l3-agent.service is incorrect
systemd configuration for quantum-l3-agent.service is incorrect
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openstack-quantum (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Terry Wilson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-05 09:59 EDT by Jonathan Barber
Modified: 2013-11-13 16:40 EST (History)
10 users (show)

See Also:
Fixed In Version: openstack-quantum-2013.1.1-5.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-13 16:40:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Barber 2013-07-05 09:59:41 EDT
Description of problem:
After installing openstack-quantum the quantum-l3-agent doesn't start.

Version-Release number of selected component (if applicable):
openstack-quantum-2013.1-0.6.rc2.fc19.noarch

How reproducible:
Always

Steps to Reproduce:
1. install f19 @core, yum install openstack-quantum
2. systemctl start quantum-l3-agent.service 
3. systemctl status quantum-l3-agent.service

Actual results:

# systemctl status quantum-l3-agent.service
quantum-l3-agent.service - OpenStack Quantum Load Balancing as a Service Agent
   Loaded: loaded (/usr/lib/systemd/system/quantum-l3-agent.service; disabled)
   Active: failed (Result: exit-code) since Fri 2013-07-05 14:53:17 WEST; 14s ago
  Process: 20064 ExecStart=/usr/bin/quantum-lbaas-agent --config-file /etc/quantum/quantum.conf --config-file /etc/quantum/l3_agent.ini --log-file /var/log/quantum/lbaas-agent.log (code=exited, status=1/FAILURE)

Jul 05 14:53:16 cas08.grid.fe.up.pt systemd[1]: Started OpenStack Quantum Load Balancing as a Service Agent.
Jul 05 14:53:17 cas08.grid.fe.up.pt quantum-lbaas-agent[20064]: 2013-07-05 14:53:17 CRITICAL [quantum] 'NoneType' object has no attribute 'rpartition'
Jul 05 14:53:17 cas08.grid.fe.up.pt systemd[1]: quantum-l3-agent.service: main process exited, code=exited, status=1/FAILURE
Jul 05 14:53:17 cas08.grid.fe.up.pt systemd[1]: Unit quantum-l3-agent.service entered failed state.

and generates the /var/log/message logs:
Jul  5 14:53:16 cas08 systemd[1]: Starting OpenStack Quantum Load Balancing as a Service Agent...
Jul  5 14:53:16 cas08 systemd[1]: Started OpenStack Quantum Load Balancing as a Service Agent.
Jul  5 14:53:17 cas08 quantum-lbaas-agent[20064]: 2013-07-05 14:53:17 CRITICAL [quantum] 'NoneType' object has no attribute 'rpartition'
Jul  5 14:53:17 cas08 systemd[1]: quantum-l3-agent.service: main process exited, code=exited, status=1/FAILURE
Jul  5 14:53:17 cas08 systemd[1]: Unit quantum-l3-agent.service entered failed state.

Expected results:
The service should start without errors.

Additional info:
This appears to be a problem with the ExecStart line in the unit file /usr/lib/systemd/system/quantum-l3-agent.service which reads:
ExecStart=/usr/bin/quantum-l3-agent --config-file /etc/quantum/quantum.conf --config-file /etc/quantum/l3_agent.ini --log-file /var/log/quantum/l3-agent.log

Changing this to:
ExecStart=/usr/bin/quantum-l3-agent --config-file /etc/quantum/quantum.conf --config-file /etc/quantum/l3_agent.ini --log-file /var/log/quantum/l3-agent.log

allows the service to start.

Per this report:
https://ask.openstack.org/question/1043/critical-quantum-nonetype-object-has-no-attribute-rpartition/

the problem probably also exists in F18
Comment 1 Terry Wilson 2013-07-05 12:09:02 EDT
This should already be fixed in an upcoming release: 2013.1.1-3

Note You need to log in before you can comment on or make changes to this bug.