Bug 981739 - virt-v2v fails with "too many IDE bus" message on kvm to rhev conversion
virt-v2v fails with "too many IDE bus" message on kvm to rhev conversion
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: virt-v2v (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Matthew Booth
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-05 12:22 EDT by Jim Wildman
Modified: 2014-09-10 08:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-10 08:52:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
typescript file of command execution (851.85 KB, text/plain)
2013-07-05 12:22 EDT, Jim Wildman
no flags Details
xml of vm being converted (3.82 KB, text/xml)
2013-07-05 12:23 EDT, Jim Wildman
no flags Details
machine definition (vmx) file of VMware ESX source VM (3.26 KB, text/plain)
2013-10-29 06:49 EDT, Johannes Tiefenbacher
no flags Details
machine definition extension (vmxf) file of VMware ESX source VM (273 bytes, application/xml)
2013-10-29 06:50 EDT, Johannes Tiefenbacher
no flags Details
logfile of conversion command execution (469.44 KB, application/x-gzip)
2013-10-29 06:56 EDT, Johannes Tiefenbacher
no flags Details

  None (edit)
Description Jim Wildman 2013-07-05 12:22:44 EDT
Created attachment 769320 [details]
typescript file of command execution

Description of problem:
virt-v2v fails with "too many IDE bus" when attempting to convert a vm with 6 drives from libvirt/kvm to rhev (3.1)


Version-Release number of selected component (if applicable):
virt-v2v-0.8.9-2.el6.x86_64

How reproducible:
Attempt to convert a vm with 6 drives from libvirt to rhev
virt-v2v -i libvirtxml -o rhev -os 192.168.1.3:/Public/exports -of raw -oa preallocated  --network rhevm /etc/libvirt/qemu/satellite.xml


Steps to Reproduce:
1.see above
2.
3.

Actual results:
see attached typescript file and vm xml file


Expected results:
successful conversion/export of vm


Additional info:
Comment 1 Jim Wildman 2013-07-05 12:23:44 EDT
Created attachment 769321 [details]
xml of vm being converted
Comment 2 Johannes Tiefenbacher 2013-10-29 06:45:53 EDT
I get the same error ("too many IDE bus") when converting a VMware ESX VM with 4 scsi drives and NO IDE drives!

command used:
LIBGUESTFS_DEBUG=1 virt-v2v -ic esx://esx1/?no_verify=1 -o rhev -of qcow2 -oa sparse -os 192.168.10.59:/home/ExImport --network rhevm "TransProxy64_CLONE" 2>&1 | tee virt-v2v.log

Reproduce with above command and a VMware VM using a vmx file similiar to the one attached (4 SCSI drives and 0 IDE drives)

Also attached you find a logfile of the complete conversion output.
Comment 3 Johannes Tiefenbacher 2013-10-29 06:49:24 EDT
Created attachment 817045 [details]
machine definition (vmx) file of VMware ESX source VM
Comment 4 Johannes Tiefenbacher 2013-10-29 06:50:09 EDT
Created attachment 817046 [details]
machine definition extension (vmxf) file of VMware ESX source VM
Comment 5 Johannes Tiefenbacher 2013-10-29 06:56:35 EDT
Created attachment 817047 [details]
logfile of conversion command execution

zipped due to size (20MB)
Comment 6 Richard W.M. Jones 2014-09-10 08:52:16 EDT
This is fixed in virt-v2v >= 1.27.

Note You need to log in before you can comment on or make changes to this bug.