Bug 981758 - IceWM Clearlooks Theme titlebar broken
IceWM Clearlooks Theme titlebar broken
Status: CLOSED DUPLICATE of bug 960663
Product: Fedora
Classification: Fedora
Component: icewm (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gilboa Davara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-05 13:57 EDT by leszek.lesner
Modified: 2013-12-22 10:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-16 01:23:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot showing the broken theme (24.71 KB, image/png)
2013-07-05 13:57 EDT, leszek.lesner
no flags Details

  None (edit)
Description leszek.lesner 2013-07-05 13:57:56 EDT
Created attachment 769348 [details]
Screenshot showing the broken theme

Description of problem:
The icewm-clearlooks theme seems to be broken. At least I don't get a title in the border (see screenshot)

Version-Release number of selected component (if applicable):


How reproducible:
Install the icewm-clearlooks package

Steps to Reproduce:
1. Start Icewm
2. Open a window

Actual results:
Broken window border

Expected results:
No broken window border

Additional info:
Fix propose:
Run 
mogrify -alpha off *.xpm 
in the theme directory to disable alpha layer in the xpm files (they are not necessary for this theme). Restart IceWM
So a simple repackaging with alpha off xpms should fix this issue
Comment 1 Henry Jensen 2013-07-08 06:02:14 EDT
It's not the fault of the icewm-clearlooks package, but a bug in xorg-x11-server, see https://bugzilla.redhat.com/show_bug.cgi?id=960663

However, the workaround to disable alpha layer in the xpm files is helpful, since it seems thta this bug won't be fixed soon.
Comment 2 Gilboa Davara 2013-07-09 09:23:16 EDT
Just for the record, what's your hardware configuration? (xorg driver, etc)

- Gilboa
Comment 3 leszek.lesner 2013-07-09 15:01:16 EDT
Lenovo 3000 N200
Intel Core 2 Duo CPU T7500
Nvidia Geforce Go 7300 (G72M) - Nvidia Driver 304.88
Comment 4 Gilboa Davara 2013-07-15 01:36:40 EDT
This issue also plagued my nVidia based machines. I solved the issue by increasing the size of several 1 pixel wide images to 2 pixels.
I'm thinking about generating an nVidia compatible icewm theme, as I doubt this issue will be solved by xorg-upstream or nVidia.

- Gilboa
Comment 5 Denilson Figueiredo de Sá 2013-12-02 21:35:41 EST
I can confirm the issue related to 1-pixel images, also on nvidia hardware.

I can confirm that resizing the images to 2 pixels solve the issue.

I've had a very similar issue years ago, in the Frets on Fire game:
http://www.fretsonfire.net/forums/viewtopic.php?t=24960

I've had this issue with Gentoo running xorg-server 1.14.3-r2 and nvidia-drivers-319.60 on GeForce 8200:
https://bugs.gentoo.org/show_bug.cgi?id=493186


The following commands auto-resize all 1-pixel images, fixing this issue:

find . -type f -name '*.xpm' -exec identify {} \; | egrep ' 1x' | sed 's/ XPM .*//' | while read f ; do convert "$f" -resize 200%x100%! "$f" ; done
find . -type f -name '*.xpm' -exec identify {} \; | egrep 'x1 ' | sed 's/ XPM .*//' | while read f ; do convert "$f" -resize 100%x200%! "$f" ; done
Comment 6 Denilson Figueiredo de Sá 2013-12-02 22:03:31 EST
Note: the command-lines I posted above are buggy.

'convert' will write the new file before 'find' has finished listing all the files, which means there is a racing condition that can let find re-read and re-list the same file again, which will make 'convert' re-convert it and re-write it to disk, and so on.

Adding "| sort" or "| tac" to the pipeline should fix this racing condition.

Alternatively, just read from one directory and write the fixed files into another one.
Comment 7 Gilboa Davara 2013-12-16 01:23:37 EST

*** This bug has been marked as a duplicate of bug 960663 ***
Comment 8 Gilboa Davara 2013-12-16 05:38:36 EST
FWIW 1.3.8 package will include a second clearlooks-2px that, as the name suggests, uses a 2-pixel wide borders (more or less based on Denilson's suggestion).

- Gilboa
Comment 9 Henry Jensen 2013-12-18 10:35:09 EST
Fedora 20 still affected. And it's not only clearlooks, but additionally the following themes where the problem occurs:

Infadel2
icedesert
Comment 10 Gilboa Davara 2013-12-22 10:11:42 EST
Henry,

I rather wait before posting a -2px versions of Infadel2 and icedesert - maybe this issue can be fixed upstream.

- Gilboa

Note You need to log in before you can comment on or make changes to this bug.