Bug 981767 - Flashplayer fullscreen opens in background
Flashplayer fullscreen opens in background
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mutter (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-05 14:15 EDT by leszek.lesner
Modified: 2015-02-12 06:13 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-12 06:13:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Videodemonstration (3.58 MB, video/webm)
2013-07-05 14:15 EDT, leszek.lesner
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 643740 None None None Never
GNOME Bugzilla 700288 None None None Never

  None (edit)
Description leszek.lesner 2013-07-05 14:15:35 EDT
Created attachment 769353 [details]
Videodemonstration

Description of problem:
Opening up a flash video and clicking on fullscreen works for the first time but not for the second. The pluginContainer Window of Firefox just opens in the background. (see Videodemonstration)

Steps to Reproduce:
1.Open Firefox and surf on a website like http://www.myvideo.de/watch/9136494/BATTLE_OF_THE_YEAR_HD_Trailer_C_Ab_21_11_13_im_Kino
2. Click to make the video fullscreen.
3. Leave fullscreen and try to go to fullscreen again.

Actual results:
No fullscreen video

Expected results:
Fullscreen video

Additional info:
With gnome-shell classic and the window list extension you can see the pluginContainer window in background and can bring it in front again. (so you'll see the flash video playing in fullscreen) 
This does not work however with alt+tab . 
It works btw. with other window-managers like metacity or icewm.
Comment 1 Peter Robinson 2013-07-06 15:24:32 EDT
Have you tried Alt+` on gnome-shell to bring it to the foreground. The classic gnome is still all gnome3 shell just a different look and feel
Comment 2 leszek.lesner 2013-07-06 15:56:36 EDT
(In reply to Peter Robinson from comment #1)
> Have you tried Alt+` on gnome-shell to bring it to the foreground. The
> classic gnome is still all gnome3 shell just a different look and feel

I tried ALT+<TILDE> (the key above the tab key) but that is not helping either. As its is recognized as seperate application in the "Alt+Tab" application. 
Also I can navigate to that application but it has no window preview and Alt+Tab is not bringing the window into front. It seems like it is minimized or something. 
Btw. I also tried that with Gnome 3.6 and there it is working. So it is definitely a regression in the window manager mutter.
Comment 3 leszek.lesner 2013-07-06 15:58:20 EDT
> Btw. I also tried that with Gnome 3.6 and there it is working. So it is
> definitely a regression in the window manager mutter.

Just as clearification I don't mean the ALT+Tab or Alt+<TILDE> thing here but just plain toggle fullscreen on the flashplayer plugin which works without any problem.
Comment 4 Electron 2013-07-24 10:32:45 EDT
I confirm the same problem with 
Firefox 22.0
Adobe Flash Player Version: 11.2.202.297
GNOME 3.8 for all flash video.

Previously worked with F19 Beta I think.
No problem now with Firefox 22.0 and KDE 4.10.5.

All Updated today with yum.

AMD Radeon HD7950 with proprietary driver 13.6-0.1Beta.fc19 (no overlay for tvtime with the opensource driver unfortunately)

Best regards,
Electron.
Comment 5 ivolopez 2013-07-26 09:28:10 EDT
I can confirm this problem too. 

gnome-shell: 3.8.3-3
mutter: 3.8.3-1
firefox: 22.0-1
flash-plugin: 11.2.202.297

Intel core i3 with no proprietary driver.

For now, I am using the gnome extension "Minimized Windows List" to choose the fullscreen video.  This is a workaround for those that do not use gnome-shell classic view.
Comment 6 Christian Weiss 2013-09-10 10:23:12 EDT
Same behavior with:

gnome-shell-3.8.4-2.fc19.x86_64
firefox-23.0.1-4.fc19.x86_64
flash-plugin-11.2.202.310-release.x86_64

I found out that you can put the plugin-container to foreground in the "Activities"-Menu (mouse to the left-upper-edge). You'll find the plugin-container at the end of the list/icons.
Comment 7 leszek.lesner 2013-10-02 18:37:40 EDT
Still in gnome-shell 3.10 and firefox 24. 

I found a nice workaround also :)
Just double click the full screen button in the flash video player (if it has a fullscreen button). Somehow this brings the window into foreground. 
At least it works for me but I also noticed that it does not work reliable every time.
Comment 8 Taras 2013-10-07 06:38:33 EDT
The same issue. I'm confirming
Comment 9 Igor Gnatenko 2014-01-26 06:24:07 EST
This problem isn't in GS.
Comment 10 leszek.lesner 2014-01-26 06:31:03 EST
Instead of closing how about reassigning to mutter as it actually is a bug of the window manager.
Comment 11 Igor Gnatenko 2014-01-26 07:04:12 EST
We have workaround, but now I can't find original bug at BGO..

https://github.com/RussianFedora/mutter/blob/f20/fixes/mutter-3.8.3-fullscreen-flash-player.patch
Comment 12 Peter Robinson 2014-01-26 08:42:26 EST
We're not going to apply a random patch. It needs to be upstream and a patch in git master at the very least
Comment 13 Igor Gnatenko 2014-01-26 08:51:06 EST
(In reply to Peter Robinson from comment #12)
> We're not going to apply a random patch. It needs to be upstream and a patch
> in git master at the very least
Sure, I'm also don't like such patches.

I will try to find bug in BGO.

*pointer = TRUE anyway bad solution.

BTW, problems in flashplayer I think.
Comment 14 Igor Gnatenko 2014-01-26 08:53:43 EST
Peter, I really want to close this bug as WONTFIX, because flash-player is proprietary software. gnash-plugin always works OK in fullscreen cases.

What do you think ?
Comment 15 Peter Robinson 2014-01-26 08:58:05 EST
I'm happy to close this as won't fix but even though it is proprietary it is still a legitimate bug that could affect other applications that aren't proprietary so I'd still like to know, for reference in this bug what the upstream bug report is.
Comment 16 leszek.lesner 2014-01-26 09:00:13 EST
It would be sad closing this because flash-player as buggy and proprietary as it is is working fine with other window managers (e.g. metacity) and worked before with gnome 2.x . 
Not fixing this bug would definitely dissatisfy the users suffering from it.
Comment 18 Peter Robinson 2014-01-26 11:42:18 EST
That needs to land upstream before we'll even consider pulling it back
Comment 19 Fedora End Of Life 2015-01-09 13:41:52 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Note You need to log in before you can comment on or make changes to this bug.