This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 981774 - PostgreSQL cartridge should not receive 'control force-reload' message
PostgreSQL cartridge should not receive 'control force-reload' message
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Mrunal Patel
libra bugs
:
Depends On:
Blocks: 981780
  Show dependency treegraph
 
Reported: 2013-07-05 15:08 EDT by Hiro Asari
Modified: 2015-05-14 19:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-09 16:42:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hiro Asari 2013-07-05 15:08:08 EDT
Description of problem:
When a postgresql cartridge is sent 'reload' from CLI, the actual message sent is 'force-reload', not 'reload'

Version-Release number of selected component (if applicable):
devenv_3450

How reproducible:
Always

Steps to Reproduce:
1. create an app with postgres cart 
2. rhc cartridge reload postgresql-9.2 -a APP
3. Check platform-trace.log; it has log such as:

July 05 14:17:30 INFO oo_spawn running /sbin/runuser -s /bin/sh e03003d2e58b11e290f712313d1c8819 -c "exec /usr/bin/runcon 'unconfined_u:system_r:openshift_t:s0:c0,c501' /bin/sh -
c \"set -e; /var/lib/openshift/e03003d2e58b11e290f712313d1c8819/postgresql/bin/control force-reload\"": {:unsetenv_others=>true, :close_others=>true, :in=>"/dev/null", :chdir=>"/
var/lib/openshift/e03003d2e58b11e290f712313d1c8819/postgresql", :out=>#<IO:fd 12>, :err=>#<IO:fd 10>}


Actual results:


Expected results:


Additional info:
Comment 1 Hiro Asari 2013-07-05 15:19:46 EDT
Confirmed with jbossas-7.0.
Comment 2 Mrunal Patel 2013-07-08 19:39:50 EDT
I was unable to reproduce this:

July 08 19:38:03 INFO oo_spawn running cgset -r cpu.cfs_quota_us=30000 /openshift/5ed433dce82711e2b7bc12313d1b85b0: {:unsetenv_others=>false, :close_others=>true, :in=>"/dev/null", :out=>#<IO:fd 12>, :err=>#<IO:fd 10>}
July 08 19:38:58 INFO oo_spawn running /sbin/runuser -s /bin/sh 460152077254854726123520 -c "exec /usr/bin/runcon 'unconfined_u:system_r:openshift_t:s0:c0,c502' /bin/sh -c \"set -e; /var/lib/openshift/460152077254854726123520/postgresql/bin/control reload\"": {:unsetenv_others=>true, :close_others=>true, :in=>"/dev/null", :chdir=>"/var/lib/openshift/460152077254854726123520/postgresql", :out=>#<IO:fd 12>, :err=>#<IO:fd 10>}
July 08 19:38:58 INFO oo_spawn buffer(11/) server signaled


What was the status of the jboss app? I will try this again with jboss once
jboss related fixes are in.
Comment 3 Hiro Asari 2013-07-08 21:56:46 EDT
The postgresql cart should be down. I thought I'd verified the steps, but perhaps I missed it.
Comment 4 Mrunal Patel 2013-07-09 16:30:17 EDT
I wasn't able to reproduce the issue with jbossas-7 w/ postgresql-9.2, either.
Comment 5 Hiro Asari 2013-07-09 16:42:13 EDT
I cannot reproduce this, either. Must have crossed the mental wires. Closing.

Note You need to log in before you can comment on or make changes to this bug.