Bug 981783 - It appears as though the "INSTALLS" tag is not applied to distros imported into beaker.
It appears as though the "INSTALLS" tag is not applied to distros imported in...
Status: CLOSED NOTABUG
Product: Beaker
Classification: Community
Component: lab controller (Show other bugs)
0.13
All Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: beaker-dev-list
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-05 15:32 EDT by drohwer
Modified: 2018-02-05 19:41 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 19:48:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description drohwer 2013-07-05 15:32:24 EDT
Description of problem:

It appears as though the "INSTALLS" tag is not applied to distros that have been imported into beaker.   When you click on Distros -> All -> then select an ID from the list the majority of them do not have tags associated with them.  Is this by design?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Dan Callaghan 2013-07-18 19:48:34 EDT
(In reply to drohwer from comment #0)
> Is this by design?

Short answer: yes. The INSTALLS tag is no longer used in Beaker. You probably want STABLE instead.

Long answer: prior to Beaker 0.9, tags were stored on distro trees (they were called distros at the time). The INSTALLS tag meant that a tree was installable, and if all trees for a given distro were installable then they would all also be tagged STABLE. As of Beaker 0.9 (June 2012) tags are stored at the distro level only, so STABLE continues to have the same meaning (all trees for that distro can be successfully installed) but the INSTALLS tag is no longer used.

The current behaviour (with the STABLE tag) is documented here:

http://beaker-project.org/docs/admin-guide/distro-import.html#automated-jobs-for-new-distros

whereas old behaviour (INSTALLS and STABLE) was never documented anywhere.

The INSTALLS tag may still be present on older distros which were imported prior to June 2012.

Note You need to log in before you can comment on or make changes to this bug.