Bug 981791 - kernel newer than 3.8.8-203 does not boot on 3G iBook "pismo"
kernel newer than 3.8.8-203 does not boot on 3G iBook "pismo"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
ppc Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-05 16:18 EDT by Ingvar Hagelund
Modified: 2013-09-27 08:38 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-27 08:38:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
camera screenshot of hanging boot screen (1.53 MB, image/jpeg)
2013-07-05 16:50 EDT, Ingvar Hagelund
no flags Details
camera screenshot with udbg-immortal upper part (1.53 MB, image/jpeg)
2013-07-06 02:20 EDT, Ingvar Hagelund
no flags Details
camera screenshot with udbg-immortal lower part (1.57 MB, image/jpeg)
2013-07-06 02:22 EDT, Ingvar Hagelund
no flags Details

  None (edit)
Description Ingvar Hagelund 2013-07-05 16:18:02 EDT
Description of problem:
On newer 3.9.x based kernels, my 3G iBook does no longer boot

Version-Release number of selected component (if applicable):
kernel-3.9.4-200.fc18.ppc

How reproducible:
Always

Steps to Reproduce:
1. Install fedora on iBook (well, that takes a lot of effort, actually)
2. Boot 3.9.x kernel


Actual results:
Kernel never jumps to framebuffer, and eventually reboots

Expected results:
A normal boot

Additional info:

I know Fedora does no longer officially support 32 bit ppc, but Ben asked me to report it, so here it is.

I'll try to attach a screenshot.

[ingvar@notteroy ~]$ cat /proc/cpuinfo 
processor	: 0
cpu		: 750FX
temperature 	: 24 C (uncalibrated)
clock		: 700.000000MHz
revision	: 2.2 (pvr 7000 0202)
bogomips	: 49.67
timebase	: 24835245
platform	: PowerMac
model		: PowerBook4,3
machine		: PowerBook4,3
motherboard	: PowerBook4,3 MacRISC2 MacRISC Power Macintosh
detected as	: 257 (iBook 2 rev. 2)
pmac flags	: 0000001a
L2 cache	: 512K unified
pmac-generation	: NewWorld
Memory		: 640 MB

[ingvar@notteroy ~]$ sudo lspci -v
0000:00:0b.0 Host bridge: Apple Inc. UniNorth/Pangea AGP
	Flags: bus master, 66MHz, medium devsel, latency 16
	Capabilities: [80] AGP version 1.0
	Kernel driver in use: agpgart-uninorth

0000:00:10.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV200 [Mobility Radeon 7500] (prog-if 00 [VGA controller])
	Subsystem: Advanced Micro Devices [AMD] nee ATI RV200 [Mobility Radeon 7500]
	Flags: bus master, stepping, 66MHz, medium devsel, latency 255, IRQ 48
	Memory at 98000000 (32-bit, prefetchable) [size=128M]
	I/O ports at 0400 [size=256]
	Memory at 90000000 (32-bit, non-prefetchable) [size=64K]
	Expansion ROM at 90020000 [size=128K]
	Capabilities: [58] AGP version 2.0
	Capabilities: [50] Power Management version 2

0001:10:0b.0 Host bridge: Apple Inc. UniNorth/Pangea PCI
	Flags: bus master, 66MHz, medium devsel, latency 16

0001:10:17.0 Unassigned class [ff00]: Apple Inc. KeyLargo/Pangea Mac I/O
	Flags: bus master, medium devsel, latency 16
	Memory at 80000000 (32-bit, non-prefetchable) [size=512K]
	Kernel driver in use: macio

0001:10:18.0 USB controller: Apple Inc. KeyLargo/Pangea USB (prog-if 10 [OHCI])
	Flags: bus master, medium devsel, latency 16, IRQ 27
	Memory at 80081000 (32-bit, non-prefetchable) [size=4K]
	Capabilities: [50] Power Management version 2
	Kernel driver in use: ohci_hcd

0001:10:19.0 USB controller: Apple Inc. KeyLargo/Pangea USB (prog-if 10 [OHCI])
	Flags: bus master, medium devsel, latency 16, IRQ 28
	Memory at 80080000 (32-bit, non-prefetchable) [size=4K]
	Capabilities: [50] Power Management version 2
	Kernel driver in use: ohci_hcd

0002:20:0b.0 Host bridge: Apple Inc. UniNorth/Pangea Internal PCI
	Flags: bus master, 66MHz, medium devsel, latency 16

0002:20:0e.0 FireWire (IEEE 1394): Apple Inc. UniNorth/Pangea FireWire (prog-if 10 [OHCI])
	Subsystem: Apple Inc. UniNorth/Pangea FireWire
	Flags: bus master, 66MHz, medium devsel, latency 16, IRQ 40
	Memory at f5000000 (32-bit, non-prefetchable) [size=4K]
	Capabilities: [44] Power Management version 2
	Kernel driver in use: firewire_ohci

0002:20:0f.0 Ethernet controller: Apple Inc. UniNorth/Pangea GMAC (Sun GEM)
	Flags: bus master, 66MHz, slow devsel, latency 16, IRQ 41
	Memory at f5200000 (32-bit, non-prefetchable) [size=2M]
	Expansion ROM at f5100000 [disabled] [size=1M]
	Kernel driver in use: gem
Comment 1 Ingvar Hagelund 2013-07-05 16:45:00 EDT
I guess it dies  because it's unable to open a primary console. Perhaps I could add a USB serial dongle, and boot with console on serial?
Comment 2 Ingvar Hagelund 2013-07-05 16:50:27 EDT
Created attachment 769394 [details]
camera screenshot of hanging boot screen
Comment 3 Benjamin Herrenschmidt 2013-07-05 18:28:27 EDT
It dies after the console is taken over by the VT subsystem and before an actual
fb driver picks up. It would be nice if we could one day fix it so that VT
only takes over the kernel console when some kind of backend actually starts.

Can you try adding "udbg-immortal" to your kernel command line ? That might give
us more data.
Comment 4 Ingvar Hagelund 2013-07-06 02:20:51 EDT
Created attachment 769511 [details]
camera screenshot with udbg-immortal upper part
Comment 5 Ingvar Hagelund 2013-07-06 02:22:08 EDT
Created attachment 769512 [details]
camera screenshot with udbg-immortal lower part
Comment 6 Ingvar Hagelund 2013-07-06 02:23:14 EDT
Added a two-part camera screenshot of the hanging bootscreen with udbg-immortal.
Comment 7 Benjamin Herrenschmidt 2013-07-06 03:26:39 EDT
Thanks. That *might* be something we fixed already but let me check with Mikey first. I'll come back to you.
Comment 8 Michael Neuling 2013-07-06 06:08:44 EDT
This is fixed upstream in 82a9f16 (powerpc/hw_breakpoints: Add DABRX cpu feature to fix 32-bit regression).

It's in 3.9.6 stable also.
Comment 9 Josh Boyer 2013-07-06 09:59:21 EDT
Fedora 18 is on 3.9.6-200.fc18 for primary arches and will be moving to 3.9.9 soon.  Looks like the ppc builders just need to catch up.  I'll mark this as modified until 3.9.6 or newer hits the ppc repos.
Comment 10 Ingvar Hagelund 2013-07-29 14:22:29 EDT
I can confirm that I can boot successfully again with 3.11.0-0.rc1.git1.1.fc20.ppc

I get a lot of these, though:

WARNING: at include/linux/pagemap.h:154 (...)
I didn't get those with the last working kernel. Should I report these somewhere? They seem to be provoked by userspace.

[root@notteroy ~]# echo; dmesg | grep Comm | cut -c 38- | sed 's,^ ,,g;' | \
  sort | uniq -c | sort -n 

      1 worker/0:2 Tainted: G        W    3.11.0-0.rc1.git1.1.fc20.ppc #1
      2 razor-lightdm-g Tainted: G        W    3.11.0-0.rc1.git1.1.fc20.ppc #1
      2 razor-notificat Tainted: G        W    3.11.0-0.rc1.git1.1.fc20.ppc #1
      2 razor-policykit Tainted: G        W    3.11.0-0.rc1.git1.1.fc20.ppc #1
      3 gvfsd-fuse Tainted: G        W    3.11.0-0.rc1.git1.1.fc20.ppc #1
      3 razor-session Tainted: G        W    3.11.0-0.rc1.git1.1.fc20.ppc #1
      5 razor-desktop Tainted: G        W    3.11.0-0.rc1.git1.1.fc20.ppc #1
     15 QInotifyFileSys Tainted: G        W    3.11.0-0.rc1.git1.1.fc20.ppc #1
     24 pool Tainted: G        W    3.11.0-0.rc1.git1.1.fc20.ppc #1
     69 lvm Tainted: G        W    3.11.0-0.rc1.git1.1.fc20.ppc #1


Ingvar

Note You need to log in before you can comment on or make changes to this bug.