This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 981817 - virtio-win drivers seemingly incompatible with Windows 2008 R2 during installation
virtio-win drivers seemingly incompatible with Windows 2008 R2 during install...
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-05 20:22 EDT by Bryan Yount
Modified: 2013-08-08 14:17 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-29 06:18:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Selecting the proper VirtIO driver folder (166.57 KB, image/png)
2013-07-05 20:22 EDT, Bryan Yount
no flags Details
Warning message (162.40 KB, image/png)
2013-07-05 20:23 EDT, Bryan Yount
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 17463 None None None Never

  None (edit)
Description Bryan Yount 2013-07-05 20:22:17 EDT
Created attachment 769451 [details]
Selecting the proper VirtIO driver folder

Description of problem:
When installing a Windows 2008 R2 (64-bit) guest, the virtio storage drivers in the Win2008R2 folder do not appear to be "automatically compatible" with this particular OS which causes the user to have to go through additional steps that may not be apparent.

Version-Release number of selected component (if applicable):
virtio-win-1.6.4-1.el6_4

How reproducible:
Very

Steps to Reproduce:
1. Begin installation of Windows 2008 R2 64-bit guest
2. Attach virtio-win-1.6.4_amd64.vfd to VM using "Run once" menu
3. Select Load driver when prompted
4. Browse to A:\amd64\Win2008R2
5. Click OK

Actual results:
A warning message appears informing the user that "No device drivers were found." as shown in the win2008r2-virtio-02.png screenshot.

Expected results:
VirtIO SCSI controller should appear in the list

Additional info:
After dismissing the warning message. If the user unchecks "Hide drivers that are not compatible..." and clicks rescan, they are able to choose the VirtIO scsi controller for Windows 2008 and proceed with installation.
Comment 1 Bryan Yount 2013-07-05 20:23:39 EDT
Created attachment 769452 [details]
Warning message

I just tested with the latest "virtio-win-1.6.5-5.el6_4" and the issue persists.
Comment 2 Mike Cao 2013-07-08 04:54:19 EDT
I can reproduce but let developer decide it whether it is a bug .
BTW ,We reports some bugs about virtio serial/balloon can not be installed during guest installation .but they all closed as notabug at last
Comment 3 Vadim Rozenfeld 2013-07-08 05:35:12 EDT
It's not a bug. Vista and higher, do not honor the floppy disk layout anymore.
Comment 4 Mike Cao 2013-07-08 05:45:13 EDT
(In reply to Vadim Rozenfeld from comment #3)
> It's not a bug. Vista and higher, do not honor the floppy disk layout
> anymore.

FYI, I tried to attach the virtio-win.iso  steps same as comment #0 

Actual Results:
A warning message appears informing the user that "No device drivers were found." as shown in the win2008r2-virtio-02.png screenshot.

Additional Info:
After dismissing the warning message. If the user unchecks "Hide drivers that are not compatible..." and clicks rescan, *still* can not find driver
Comment 5 Vadim Rozenfeld 2013-07-08 07:37:00 EDT
(In reply to Mike Cao from comment #4)
> (In reply to Vadim Rozenfeld from comment #3)
> > It's not a bug. Vista and higher, do not honor the floppy disk layout
> > anymore.
> 
> FYI, I tried to attach the virtio-win.iso  steps same as comment #0 
> 
> Actual Results:
> A warning message appears informing the user that "No device drivers were
> found." as shown in the win2008r2-virtio-02.png screenshot.
> 
> Additional Info:
> After dismissing the warning message. If the user unchecks "Hide drivers
> that are not compatible..." and clicks rescan, *still* can not find driver

Mike, can you please check if it the only win2008r2 problem? What about Win7/32-bit does it have the same problem?

Thanks,
Vadim.
Comment 6 Ronen Hod 2013-07-29 06:18:52 EDT
Closing,
It is known that Microsoft's scanning does not work and that the user has to select the driver manually.
The only way to fix it is to build an ISO per guest OS, and we prefer not to.

Note You need to log in before you can comment on or make changes to this bug.