This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 981831 - system-config-date should say "Real-time clock (RTC) uses UTC", not "System clock uses UTC"
system-config-date should say "Real-time clock (RTC) uses UTC", not "System c...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: system-config-date (Show other bugs)
rawhide
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-06 01:55 EDT by Andre Robatino
Modified: 2016-08-11 07:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-11 07:59:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2013-07-06 01:55:22 EDT
Description of problem:
See https://bugzilla.redhat.com/show_bug.cgi?id=881403#c33 . Quote:

Máirín: For the record, the F17 installer has a check box for "System clock uses UTC". This wording is confusing, in part, because it is wrong. The check box tells the installer whether the hardware clock (aka RTC) uses UTC or local time. The label should read "Hardware clock uses UTC". See the hwclock man page.

Version-Release number of selected component (if applicable):
system-config-date-1.10.5-2.fc19
Comment 1 Andre Robatino 2013-07-30 15:11:30 EDT
Might be better to say "Real-time clock (RTC) uses UTC" - see https://en.wikipedia.org/wiki/Real-time_clock#Terminology . BTW, I consider this a bug fix, not an enhancement - I only set FutureFeature to keep the bug from expiring.
Comment 2 Steve Tyler 2013-07-30 15:36:42 EDT
Thanks for raising this issue of terminology.

The hwclock man page has this to say:

"This clock is commonly called the hardware clock, the real time clock, the RTC, the BIOS clock, and the CMOS clock.  Hardware Clock, in its capitalized form, was coined for use by hwclock because all of the other names are inappropriate to the point of being misleading."

HWCLOCK(8)
hwclock - query or set the hardware clock (RTC)
http://man7.org/linux/man-pages/man8/hwclock.8.html

For the record, the kernel uses rtc or RTC extensively:

$ dmesg | grep -i rtc
[    0.153993] RTC time: 15:44:01, date: 07/30/13
[    5.044569] rtc_cmos 00:02: RTC can wake from S4
[    5.044702] rtc_cmos 00:02: rtc core: registered rtc_cmos as rtc0
[    5.044733] rtc_cmos 00:02: alarms up to one month, y3k, 114 bytes nvram, hpet irqs
[    7.366421] rtc_cmos 00:02: setting system clock to 2013-07-30 15:44:08 UTC (1375199048)
Comment 3 Nils Philippsen 2016-08-11 07:59:27 EDT
Thanks for taking the time to submit this request for enhancement.
Unfortunately, I haven't gotten around to implement this feature, sorry for
that.

Because I don't actively develop system-config-date anymore, I won't likely find
the time to work on this ticket, so I'll close it now.

Note You need to log in before you can comment on or make changes to this bug.