Bug 98186 - Fatal Error on package removal
Fatal Error on package removal
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
All Linux
high Severity medium
: ---
: ---
Assigned To: Adrian Likins
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-27 15:06 EDT by Matt Jamison
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 12:53:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josef Komenda 2003-06-27 15:06:07 EDT
Description of problem: Installed Amanda and it's related packages, scheduled a
removal to Amanda only, fails with the following error on rhn-farm-03:

do_call(packages.remove, ([['amanda', '2.4.2p2', '4', '']],))
Traceback (innermost last):
  File "/usr/sbin/rhn_check", line 179, in handle_action
    (status, message, data) = do_call(method, params)
  File "/usr/sbin/rhn_check", line 92, in do_call
    retval = apply(method, params)
  File "/usr/share/rhn/actions/packages.py", line 73, in remove
    return (14, "%s" % e, {})
  File "/usr/share/rhn/up2date_client/up2dateErrors.py", line 86, in __repr__
    msg = _("RPM dependency error.  The message was:\n") + self.errmsg
TypeError: illegal argument type for built-in operation
Sending back response: ((6,), 'Fatal error in Python code occured', {})


Version-Release number of selected component (if applicable): 61-RC3
Comment 1 Josef Komenda 2003-06-27 15:08:18 EDT
Was able to remove 4suite, and if I schedule ALL of the Amanda stuff to be
removed, it works - this seems to be breaking Bretm's depsolver code. 
Comment 2 Adrian Likins 2003-06-27 15:33:40 EDT
that appears to be a client side error...

what version of up2date?
Comment 3 Josef Komenda 2003-06-27 15:45:25 EDT
Seems to be a client side error or AS - RH9 works lovely. Closing.
Comment 4 Josef Komenda 2003-06-27 15:49:09 EDT
Silly me, shouldn't close this, should dump over to Alikins. 

up2date-2.8.45-1.2.1AS
up2date-gnome-2.8.45-1.2.1AS

Note You need to log in before you can comment on or make changes to this bug.