Bug 981868 - KVM crashes fedora 19
KVM crashes fedora 19
Status: CLOSED DUPLICATE of bug 980254
Product: Fedora
Classification: Fedora
Component: kvm (Show other bugs)
19
x86_64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-06 10:06 EDT by Joshua Rosen
Modified: 2013-07-08 15:46 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-08 15:46:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Installed RPMs (81.38 KB, text/plain)
2013-07-06 10:09 EDT, Joshua Rosen
no flags Details
/var/log/messages (1.08 MB, text/plain)
2013-07-06 10:12 EDT, Joshua Rosen
no flags Details
/var/log/messages from 2nd system (536.95 KB, text/plain)
2013-07-06 10:17 EDT, Joshua Rosen
no flags Details

  None (edit)
Description Joshua Rosen 2013-07-06 10:06:57 EDT
Description of problem: Booting and Shutting Down KVM virtual machines can crash F19. This is a hard crash, system won't respond to external pings. I'm using Scientific Linux 6.4 and XP VMs, this happens with both.

I've experienced this on two separate boxes, both of which are completely stable when running Scientific Linux 6.4 (RHEL clone). There seem to be other kernel problems, I've experienced other crashes with F19 but it's not nearly as frequent (days apart, happens when the system is idle). The KVM induced crash is very frequent, booting a VM frequently causes a crash.


Version-Release number of selected component (if applicable):


How reproducible: Happens about 25% of the time.


Steps to Reproduce:
1. Boot VM from the Virtual Machine Manager
2.
3.

Actual results: Frequently causes a system crash.


Expected results:


Additional info:
Comment 1 Joshua Rosen 2013-07-06 10:09:04 EDT
Created attachment 769625 [details]
Installed RPMs

Here is the list of my installed RPMs
Comment 2 Joshua Rosen 2013-07-06 10:12:47 EDT
Created attachment 769626 [details]
/var/log/messages

I don't see anything suspicious here but I'm attaching anyway.
Comment 3 Joshua Rosen 2013-07-06 10:17:56 EDT
Created attachment 769628 [details]
/var/log/messages from 2nd system

This system crashed when shutting down an XP VM
Comment 4 Wolfram 2013-07-08 07:52:43 EDT
Hello,
typical "same here" comment...
But let me add some substance:

64 Bit Fedora 19, KDE Spin (KDE is running), standard repositories, latest patchlevel, on Intel CPU (Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz) with Intel Graphics (a Dell Laptop)

A complete kernel panic on the host occurs (system totaly unresponsible; no tty... nothing), when:

- shutting down a *winxp 32 Bit* vm (crash occurs, when the shutdown is complete)
- shutting down a *win 7 64 Bit* vm (crash occurs, when the shutdown is complete)

 - The winxp-Machines (yes, two of them) are "overtaken" from a previous Fedora 17, where anything did run well.

 - The win 7 64 Bit Machine was created on Fedora 19.
All the machines have different vesions of Spice- and kvm-guest-tools installed.

What I have tried without success;
- cpu setup was on "Copy from host" in virt-manager --> changed to "DualCore2" model
- change Video driver from QXL to VGA
- change Spice-output output to VNC 
- change Harddisk optimisation parameters (from default / default to various variations)
- change NIC hardware from virtio to rt8139 and back
- remove macvtap devices (only Nat remains)
- Start with and without KDE Compositing

Virtual Harddisks are connected per virtual "IDE" controler (not virtio).
HD-Image-Formats differ from machine to machine (RAW, Qcow2 and vmdk).

The Harddisk Images are physically on a luks/crypt filesystem which is ext4 formated.
Mountoptions: 
 rw,relatime,data=ordered  (taken from /proc/mounts)

Today a kernel update came in, but still those kvm-crashes remain.

I'm running out of options now.

BTW: On the "Fedora 19 Welcome Party" here in Berlin (at Belug) also KVM crashed the host machine of the speaker in public during a shutdown (this time Fedora 19 was the running guest - but I don't know much of the setup here). I remember this, because I've never ever experienced something like that with KVM (not on Cent, not on Redhat, not on Ubuntu Server, not on Fedora 17, not on Fedora 16).

Crashes do not occur on a Ubuntu 32 Bit (13.04-32Bit) guest.

Best Regards,
Wolfram 

PS: Sorry I do not have much time for providing more information about that. So this is still a "same here" comment.
Comment 5 Joshua Rosen 2013-07-08 09:46:42 EDT
I've now seen this on a third system. The three systems are a first generation iCore7, an Ivy Bridge iCore7 and a Sandy Bridge iCore5. All three systems are using the Mate spin of F19.
Comment 7 Cole Robinson 2013-07-08 15:46:35 EDT

*** This bug has been marked as a duplicate of bug 980254 ***

Note You need to log in before you can comment on or make changes to this bug.