Bug 981869 - Strigi 0.7.8 is available
Strigi 0.7.8 is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: strigi (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-06 10:25 EDT by Ernesto Manríquez
Modified: 2013-07-16 23:14 EDT (History)
4 users (show)

See Also:
Fixed In Version: strigi-0.7.8-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-16 23:03:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ernesto Manríquez 2013-07-06 10:25:10 EDT
Description of problem:
Yes, I know Strigi release management is pathetic. But please, can you update this in Rawhide (and if possible, in F18/19)? We all know that if Strigi is outdated, then we will have reduced performance and subtle bugs with KDE 4.10/4.11, and we want to avoid that.

Version-Release number of selected component (if applicable):
0.7.7-fc-any

How reproducible, etc: Irrelevant.
Comment 1 Kevin Kofler 2013-07-06 16:11:48 EDT
I'm taking care of this, including the Upstream Release Monitoring entry to ensure we don't miss the next release again.
Comment 3 Kevin Kofler 2013-07-06 16:52:24 EDT
Building strigi-0.7.8-1.fc20 for Rawhide now. I'll file updates for F1[789] once the Rawhide build succeeds.
Comment 4 Kevin Kofler 2013-07-06 17:09:35 EDT
Note that we were already carrying all of these:
 - Fix xpm and xbm index. (Weng Xuetian)
 - Extract tracknumber and track count from a value like "03/16". (Sebastian Trueg)
 - Fixed indexing of m3u files. (Sebastian Trueg)
 - Fix FLAC Files: Remove addtional 'db' in replaygain (Vishesh Handa)
 - Fix: flac analizer was importing only one artist tag. (Ignacio Serantes)
 - Fix: non numeric genres in id3 v2 mp3 are ignored. (Ignacio Serantes)
 - Fix parsing of genre field in id3v2 tags(Sune Vuorela)

and that these are not relevant for us (e.g., because they are build-time-only issues, and if it builds, it works, or because they only apply to the FFmpeg plugin we cannot ship):
 - C++11 fixes (Raphael Kubo da Costa)
 - Let the strigi ffmpeg plugin compile on modern ffmpeg versions. (Simeon Bird)
 - Simeon Bird (Let the ffmpeg analyser deal with files with have track numbers with a / in them)
 - Use GNUInstallDirs in order to install into lib64 automatically (David Faure)
 - Allow the Strigi submodules to be installed in custom prefixes. (Christophe Giboudeaux)

and that this one is only marginally relevant to us (allows removing a bogus BuildRequires, but does not matter for our users):
 - Remove dependency on boost. (Jos van den Oever)

That leaves only these 3 changes as possibly relevant (of which the 3rd is interesting only for developers or packagers):
 - Change: TPE2 tag it's used as nmm:albumArtist instead as nmm:performer in ID3 analyzer. (Ignacio Serantes)
 - Change: added support to TRACKTOTAL tag as an equivalent to TRACKCOUNT in FLAC analyzer. (Ignacio Serantes)
 - Install a version file for the CMake config module (Christophe Giboudeaux)

so it's not as big a catastrophe that we haven't been carrying the latest version as you are painting it.
Comment 5 Fedora Update System 2013-07-06 18:02:18 EDT
strigi-0.7.8-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/strigi-0.7.8-1.fc18
Comment 6 Fedora Update System 2013-07-06 18:02:32 EDT
strigi-0.7.8-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/strigi-0.7.8-1.fc17
Comment 7 Fedora Update System 2013-07-06 18:02:41 EDT
strigi-0.7.8-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/strigi-0.7.8-1.fc19
Comment 8 Ernesto Manríquez 2013-07-06 21:52:16 EDT
Good to know, Kevin. And I'm pleased to see that the packaging team in Fedora is among the best. The "hidden bugs" part was speaking in a general way; I suffered badly when Strigi was outdated a long time ago, but even KDE doesn't use it as before, so there was no catastrophe to begin with ;)

Testing and reporting.
Comment 9 Fedora Update System 2013-07-07 20:51:02 EDT
Package strigi-0.7.8-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing strigi-0.7.8-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12546/strigi-0.7.8-1.fc17
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2013-07-16 23:03:25 EDT
strigi-0.7.8-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2013-07-16 23:12:15 EDT
strigi-0.7.8-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2013-07-16 23:14:39 EDT
strigi-0.7.8-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.