Bug 981870 - Keyboard layout "no" is broken in virtual consoles after Fedora 18 -> 19 upgrade [NEEDINFO]
Keyboard layout "no" is broken in virtual consoles after Fedora 18 -> 19 upgrade
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kbd (Show other bugs)
19
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Vitezslav Crhonek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-06 10:34 EDT by Håkon Løvdal
Modified: 2013-11-11 19:34 EST (History)
4 users (show)

See Also:
Fixed In Version: kbd-1.15.5-8.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-11 19:34:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
vcrhonek: needinfo? (hlovdal)


Attachments (Terms of Use)

  None (edit)
Description Håkon Løvdal 2013-07-06 10:34:37 EDT
Description of problem:

After upgrading from Fedora 18 to 19, the keyboard layout in virtual consoles
is severely broken (the keyboard layout in X11 is fine).

Version-Release number of selected component (if applicable):

kbd-misc-1.15.5-6.fc19.noarch


How reproducible:


Steps to Reproduce:
1.
2.
3.


Actual results:

Most of the keys are working like expected, but 5 keys are wrong:

keycode: 13
` is not a dead key like it should.

keycode: 26
This key have the English keyboard mapping and does not produce the å character like it should.

keycode: 27
The dead, double dot key (used to for instance produce ö) is missing.

keycode: 39
This key have the English keyboard mapping and does not produce the ø character like it should.

keycode: 40
This key have the English keyboard mapping and does not produce the æ character like it should.


I see that the content of /usr/lib/kbd/keymaps/i386/qwerty/no.map.gz is
actually identical in both Fedora 19 and 17, so I am not sure why this has not
surfaced before, however looking into the content it is clearly bogous,
e.g. the line like

	keycode  40 = braceleft        bracketleft

should obviously have been

	keycode  40 = +ae	+AE



Expected results:

Please fix so that virtual console "no" keymap is 100% identical to the X11 "no" keymap.



Additional info:

$ localectl
   System Locale: LANG=en_US.UTF-8
       VC Keymap: no
      X11 Layout: no
       X11 Model: pc105
     X11 Options: terminate:ctrl_alt_bksp,
$

/etc/vconsole.conf (content unchanged since at least February this year):
FONT=latarcyrheb-sun16
KEYMAP=no

non-existing files:
/etc/sysconfig/keyboard
/etc/sysconfig/i18n
Comment 1 Fedora Update System 2013-08-28 09:29:30 EDT
kbd-1.15.5-7.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kbd-1.15.5-7.fc19
Comment 2 Vitezslav Crhonek 2013-08-28 09:32:58 EDT
Thanks for the bug report.

Could you please try /lib/kbd/keymaps/xkb/no.map.gz keymap from the updated package (kbd-1.15.5-7.fc19). Does it work as expected?
Comment 3 Fedora Update System 2013-11-06 08:04:11 EST
kbd-1.15.5-8.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kbd-1.15.5-8.fc19
Comment 4 Fedora Update System 2013-11-06 22:34:38 EST
Package kbd-1.15.5-8.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kbd-1.15.5-8.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20801/kbd-1.15.5-8.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-11-11 19:34:03 EST
kbd-1.15.5-8.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.