Bug 981881 - Add larger progress bar with more progress details to fedup post reboot screen
Add larger progress bar with more progress details to fedup post reboot screen
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedup (Show other bugs)
19
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-06 12:21 EDT by monkeypet
Modified: 2013-12-22 00:33 EST (History)
2 users (show)

See Also:
Fixed In Version: fedup-0.8.0-3.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 02:20:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description monkeypet 2013-07-06 12:21:39 EDT
Description of problem:

I used fedup to upgrade from fedora 18.  When I rebooted to proceed with the upgrade, the black screen had the flashing fedora logo with only a tiny progress bar.  I had to strain my eyes to see if that progress bar was moving.  I suggest have a larger progress bar and giving some more details on what is happening.  I almost rebooted the system not knowing that the proper thing was happening.  For newbies, they would have done that.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. fedup-cli --network 19
2. reboot when done
3. you should see the black scree with flashing fedora logo, tiny progress bar.

Actual results:


Expected results:


Additional info:
Comment 1 Will Woods 2013-07-08 12:36:30 EDT
There's three factors that make fedup progress reporting problematic:

1) The upgrade takes a long time - usually 60-90 minutes, but up to 3 hours;
2) The progress meter is handled by plymouth's "system-update" mode, which only supports integer percentages between 0-100; and
3) Some individual RPM actions (e.g. the %post script for selinux-targeted) can take several minutes by themselves.

So: given that we only have 100 "notches" in the progress meter, the fastest the meter can possibly move for a normal upgrade is once every 36 seconds. Typical times will be more like once every minute.

For the "notch" that includes installing selinux-targeted, the meter probably won't move for several minutes, because *we get no information about the progress of the script*.

(This is why the fedora logo blinks continuously: to let you know that the system hasn't actually hung.)

So, we *can* make the progress meter bigger, but we can't make it update more frequently without making serious changes to plymouth.

Still, a bigger logo/progress bar might help make the progress more obvious.
Comment 2 monkeypet 2013-07-09 00:51:05 EDT
Also, I don't remember seeing any text on the screen. I would like it to say "upgrading" or "updating".  The logo blinking doesn't really signal an upgrade for me either, maybe some sort of animation or change the icon to make it clear that it is is updating, maybe a spinning cog on the fedora logo.  However, I'll settle for a bigger logo/progress bar.
Comment 3 Will Woods 2013-07-09 16:39:03 EDT
(In reply to monkeypet from comment #2)
> Also, I don't remember seeing any text on the screen.

If you want details, you can hit "Esc" to show the text console, which has detailed log information.

But you can't write text on the plymouth splash screen without:

- Translations for most of the ~125 languages supported in Fedora
- TrueType fonts for all those languages
- Libraries for rendering TrueType fonts
- Other libraries required by the TTF libraries
- fontconfig files to decide which fonts to use when
- libraries for handling the fontconfig

&c. It's enormously complex and very fragile. It doubled the size of upgrade.img and it still didn't work half the time. So we opted not to do that.

> The logo blinking doesn't really signal an
> upgrade for me either, maybe some sort of animation or change the icon to
> make it clear that it is is updating, maybe a spinning cog on the fedora
> logo.

Sounds great. Attach suitable replacement images to this bug (or email them to me) and I'll happily use them.
Comment 4 Fedora Update System 2013-12-11 17:11:24 EST
fedup-0.8.0-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/fedup-0.8.0-3.fc19
Comment 5 Fedora Update System 2013-12-11 17:19:43 EST
fedup-0.8.0-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/fedup-0.8.0-3.fc20
Comment 6 Fedora Update System 2013-12-11 17:21:35 EST
fedup-0.8.0-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fedup-0.8.0-3.fc18
Comment 7 Fedora Update System 2013-12-13 00:08:42 EST
Package fedup-0.8.0-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing fedup-0.8.0-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23316/fedup-0.8.0-3.fc19
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-12-19 02:20:54 EST
fedup-0.8.0-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-12-19 20:43:45 EST
fedup-0.8.0-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-12-22 00:33:51 EST
fedup-0.8.0-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.