Bug 98189 - Cannot upload file to create a content item
Cannot upload file to create a content item
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: ccm-bugs-list
Jon Orris
:
Depends On:
Blocks: rc0blockers
  Show dependency treegraph
 
Reported: 2003-06-27 15:44 EDT by Richard Li
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-27 16:07:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Li 2003-06-27 15:44:14 EDT
Version-Release number of selected component (if applicable):

On PG 7.3.

How reproducible:

Always

Steps to Reproduce:
1. Create article
2. Edit article
3. On body page, choose upload file
4. Upload file

Actual results:

-*-*-*- Section: Stack trace -*-*-*-
com.arsdigita.util.UncheckedWrapperException (root cause:
javax.xml.transform.Transform\
erException)
    at
com.arsdigita.sitenode.BasePresentationManager.servePage(BasePresentationManager\
.java:505)
    at com.arsdigita.cms.dispatcher.CMSPage$1.excurse(CMSPage.java:267)
    at com.arsdigita.cms.CMSExcursion.run(CMSExcursion.java:71)
    at com.arsdigita.cms.dispatcher.CMSPage.dispatch(CMSPage.java:270)
    at
_packages._content_22dsection._www._admin._item__jsp._jspService(_item__jsp.java\
:59)
    at com.caucho.jsp.JavaPage.service(JavaPage.java:75)
    at com.caucho.jsp.Page.subservice(Page.java:485)
    at com.caucho.server.http.FilterChainPage.doFilter(FilterChainPage.java:182)
    at com.caucho.server.http.Invocation.service(Invocation.java:312)
    at
com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:213)
    at
com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:100)
    at com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:77)
    at
com.arsdigita.dispatcher.DispatcherHelper.forwardHelper(DispatcherHelper.java:17\
4)
    at
com.arsdigita.dispatcher.DispatcherHelper.forwardRequestByPath(DispatcherHelper.\
java:203)
    at
com.arsdigita.dispatcher.DispatcherHelper.forwardRequestByPath(DispatcherHelper.\
java:216)
    at
com.arsdigita.cms.dispatcher.FileDispatcher.chainedDispatch(FileDispatcher.java:\
61)
    at com.arsdigita.dispatcher.DispatcherChain.dispatch(DispatcherChain.java:74)
    at
com.arsdigita.cms.ContentSectionServlet.doService(ContentSectionServlet.java:134\
)
    at
com.arsdigita.web.BaseApplicationServlet$1.excurse(BaseApplicationServlet.java:1\
19)
    at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
    at
com.arsdigita.web.BaseApplicationServlet.doService(BaseApplicationServlet.java:1\
13)
    at com.arsdigita.web.BaseServlet$1.excurse(BaseServlet.java:127)
    at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
    at com.arsdigita.web.BaseServlet.internalService(BaseServlet.java:102)
    at com.arsdigita.web.BaseServlet.doPost(BaseServlet.java:237)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:165)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:103)
    at
com.caucho.server.http.FilterChainServlet.doFilter(FilterChainServlet.java:96)
    at com.caucho.server.http.Invocation.service(Invocation.java:312)
...
Root cause:
javax.xml.transform.TransformerException
    at
org.apache.xalan.transformer.TransformerImpl.transformNode(TransformerImpl.java(\
Compiled Code))
    at
org.apache.xalan.transformer.TransformerImpl.transform(TransformerImpl.java:504)
    at
org.apache.xalan.transformer.TransformerImpl.transform(TransformerImpl.java:1174\
)
    at
com.arsdigita.sitenode.BasePresentationManager.servePage(BasePresentationManager\
.java:497)
    at com.arsdigita.cms.dispatcher.CMSPage$1.excurse(CMSPage.java:267)
    at com.arsdigita.cms.CMSExcursion.run(CMSExcursion.java:71)
    at com.arsdigita.cms.dispatcher.CMSPage.dispatch(CMSPage.java:270)
    at
_packages._content_22dsection._www._admin._item__jsp._jspService(_item__jsp.java\
:59)
    at com.caucho.jsp.JavaPage.service(JavaPage.java:75)
    at com.caucho.jsp.Page.subservice(Page.java:485)
    at com.caucho.server.http.FilterChainPage.doFilter(FilterChainPage.java:182)
    at com.caucho.server.http.Invocation.service(Invocation.java:312)
    at
com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:213)
    at
com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:100)
    at com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:77)
    at
com.arsdigita.dispatcher.DispatcherHelper.forwardHelper(DispatcherHelper.java:17\
4)
    at
com.arsdigita.dispatcher.DispatcherHelper.forwardRequestByPath(DispatcherHelper.\
java:203)
    at
com.arsdigita.dispatcher.DispatcherHelper.forwardRequestByPath(DispatcherHelper.\
java:216)
    at
com.arsdigita.cms.dispatcher.FileDispatcher.chainedDispatch(FileDispatcher.java:\
61)
    at com.arsdigita.dispatcher.DispatcherChain.dispatch(DispatcherChain.java:74)
    at
com.arsdigita.cms.ContentSectionServlet.doService(ContentSectionServlet.java:134\
)
    at
com.arsdigita.web.BaseApplicationServlet$1.excurse(BaseApplicationServlet.java:1\
19)
    at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
    at
com.arsdigita.web.BaseApplicationServlet.doService(BaseApplicationServlet.java:1\
13)
    at com.arsdigita.web.BaseServlet$1.excurse(BaseServlet.java:127)
    at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
   at
com.arsdigita.web.BaseApplicationServlet.doService(BaseApplicationServlet.java:1\
13)
    at com.arsdigita.web.BaseServlet$1.excurse(BaseServlet.java:127)
    at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
    at com.arsdigita.web.BaseServlet.internalService(BaseServlet.java:102)
    at com.arsdigita.web.BaseServlet.doPost(BaseServlet.java:237)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:165)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:103)
    at
com.caucho.server.http.FilterChainServlet.doFilter(FilterChainServlet.java:96)
    at com.caucho.server.http.Invocation.service(Invocation.java:312)
    at
com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:213)
    at
com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:100)
    at com.caucho.server.http.QRequestDispatcher.forward(QRequestDispatcher.java:77)
    at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:212)
    at com.arsdigita.web.BaseDispatcher.forward(BaseDispatcher.java:198)
    at com.arsdigita.web.BaseDispatcher.dispatch(BaseDispatcher.java:130)
    at com.arsdigita.web.DispatcherServlet.service(DispatcherServlet.java:136)
    at
com.caucho.server.http.FilterChainServlet.doFilter(FilterChainServlet.java:96)
    at com.caucho.server.http.Invocation.service(Invocation.java:312)
    at com.caucho.server.http.HttpRequest.handleRequest(HttpRequest.java:221)
    at com.caucho.server.http.HttpRequest.handleConnection(HttpRequest.java:163)
    at com.caucho.server.TcpConnection.run(TcpConnection.java:137)
    at java.lang.Thread.run(Thread.java:512)
---------
java.lang.NullPointerException
    at
org.apache.xml.utils.FastStringBuffer.append(FastStringBuffer.java(Compiled Code\
))
    at org.apache.xpath.DOMHelper.getNodeData(DOMHelper.java:1314)
    at org.apache.xpath.DOMHelper.getNodeData(DOMHelper.java:1308)
    at org.apache.xpath.DOMHelper.getNodeData(DOMHelper.java:1267)
    at org.apache.xpath.objects.XRTreeFrag.str(XRTreeFrag.java:162)
    at org.apache.xalan.templates.ElemValueOf.execute(ElemValueOf.java(Compiled
Code))
    at
org.apache.xalan.transformer.TransformerImpl.executeChildTemplates(TransformerIm\
pl.java(Compiled Code))
    at org.apache.xalan.templates.ElemChoose.execute(ElemChoose.java(Compiled Code))
    at
org.apache.xalan.transformer.TransformerImpl.executeChildTemplates(TransformerIm\
pl.java(Compiled Code))
    at org.apache.xalan.templates.ElemTemplate.execute(ElemTemplate.java:380)
    at
org.apache.xalan.templates.ElemCallTemplate.execute(ElemCallTemplate.java:202)
    at
org.apache.xalan.templates.ElemForEach.transformSelectedNodes(ElemForEach.java(C\
ompiled Code))
    at
org.apache.xalan.templates.ElemApplyTemplates.execute(ElemApplyTemplates.java:19\
3)
    at
org.apache.xalan.transformer.TransformerImpl.executeChildTemplates(TransformerIm\
pl.java(Compiled Code))
Expected results:


Additional info:
Comment 1 Richard Li 2003-06-27 16:07:59 EDT
Traced to out of date enterprise.init.in file.

Note You need to log in before you can comment on or make changes to this bug.