Bug 981901 - Openbox hotkeys doesn't work when any LXDE system tray menu is open
Openbox hotkeys doesn't work when any LXDE system tray menu is open
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: openbox (Show other bugs)
19
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-06 16:26 EDT by Alexander230
Modified: 2014-04-15 09:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-15 09:12:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander230 2013-07-06 16:26:06 EDT
Description of problem:
When I open any menu from system tray in LXDE (for example, by right clicking on network connection), all Openbox hotkeys don't work. I've found it when tried to make a screenshot of Dropbox tray menu by binding scrot to Print Screen key. It works when menu is not open, but it doesn't when menu is open. All other Openbox hotkeys (like Super+E that launch pcmanfm) also don't work when any tray menu is open.
Comment 1 Miroslav Lichvar 2013-08-13 08:55:29 EDT
I think this may be one of the X11 limitations. When a menu grabs the input, no other client will receive the input.

http://www.x.org/wiki/Development/X12/

Does it work with other window managers?
Comment 2 Alexander230 2013-08-13 08:58:37 EDT
I don't have other window managers, so I can't test it.
Comment 3 Miroslav Lichvar 2014-04-15 09:12:49 EDT
Ok, I'm closing this as CANTFIX. If you think it's not a X11 limitation and can't reproduce it with another window manager, please reopen.

Note You need to log in before you can comment on or make changes to this bug.